Search Support

I don't get the "new tab" when I click on the + sign. ALSO, whenever I open Firefox, the Bookmarks panel is open down the side

more options

FIRST: I was just reading about personalizing a "new tab," which I have wanted to do. But the "new tab" that I get when I click on the + sign (I have the tab bar down the side — which I REALLY like, incidentally! — the + is at the very top.) doesn't have that gear thingy on it; it appears to be a different browser or something (I'm guessing), though I have set, time and again, FF as my default/preferred/only browser! It might be a Google page, though it doesn't have the Google look either.

ATTACHED: Is this the "new tab"? It does have a "gear" at the bottom of the page. OR, is there another place I should be looking for the "new tab" button?

SECOND: Every time I open FF, the Bookmarks Sidebar is there. I close it, but when I reopen, it's there again. This has been happening for just a few days, but it IS annoying.

Attached screenshots

Modified by JulieAnn01

Chosen solution

The bookmarks tab might re-open if it was opened before. You can close it using either:

  • Small "x" button on the sidebar (upper right corner)
  • Ctrl+b (for the bookmarks sidebar; it's Ctrl+h for the history sidebar)
  • Bookmarks button on the mail toolbar > Uncheck View Bookmarks Sidebar

If it keeps opening, you might need to have Firefox regenerate one of its settings files, I'll list that at the end of this reply.


That isn't Firefox's new tab page. You have a lot of extensions, so I suspect one of the might be substituting the display. However, I don't recognize it so I don't have a guess as to which one it might be.

If you right-click a blank area of the page, and open View Page Info, what is shown as its address?


Glitches with window/dialog sizes/positions can be caused by corruption in a particular settings file. You can rename the file to restore default sizes/positions. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again. Does the sidebar default back to closed?

If you were previously showing the menu bar or bookmarks toolbar, you'll need to turn them back on. You can use one of these methods to show the toolbar list and select the desired bars there:

Read this answer in context 👍 0

All Replies (8)

more options

Chosen Solution

The bookmarks tab might re-open if it was opened before. You can close it using either:

  • Small "x" button on the sidebar (upper right corner)
  • Ctrl+b (for the bookmarks sidebar; it's Ctrl+h for the history sidebar)
  • Bookmarks button on the mail toolbar > Uncheck View Bookmarks Sidebar

If it keeps opening, you might need to have Firefox regenerate one of its settings files, I'll list that at the end of this reply.


That isn't Firefox's new tab page. You have a lot of extensions, so I suspect one of the might be substituting the display. However, I don't recognize it so I don't have a guess as to which one it might be.

If you right-click a blank area of the page, and open View Page Info, what is shown as its address?


Glitches with window/dialog sizes/positions can be caused by corruption in a particular settings file. You can rename the file to restore default sizes/positions. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again. Does the sidebar default back to closed?

If you were previously showing the menu bar or bookmarks toolbar, you'll need to turn them back on. You can use one of these methods to show the toolbar list and select the desired bars there:

more options

I think your new tab page is the experimental "Activity Stream" page.

more options

jscher2000 said

I think your new tab page is the experimental "Activity Stream" page.

That's part the TestPilot which appears in your list of installed extensions.

more options

That isn't Firefox's new tab page. You have a lot of extensions, so I suspect one of the might be substituting the display. However, I don't recognize it so I don't have a guess as to which one it might be.

If you right-click a blank area of the page, and open View Page Info, what is shown as its address?

OK: I think the Bookmarks thing is solved (for the moment anyway)!

When I right click on the "new page," this is what I get (attached).

I'm going to look at the extensions now.

more options

I think the Page Info confirms it is the "Activity Stream" page that you're testing.

more options

OK: I've got the Bookmark thing solved. I don't know where to give credit; it seems as if two different people were offering suggestions, but it was the xulstore.json suggestion that solved it for me.

Now, if only I could get the "new tab" page back so I get the links to the things I use most often back. I don't like the "history" appearing on my new tab page — that's not really very helpful (IMHO).

Anyway, my thanks to all!

more options

To remove the Activity Stream from the New Tab Page, try the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side, try disabling Activity Stream. Can it be separately disabled? If not, you might need to disable Test Pilot.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that do it?

more options

Julieann01 said

OK: I've got the Bookmark thing solved. I don't know where to give credit; it seems as if two different people were offering suggestions, but it was the xulstore.json suggestion that solved it for me. Now, if only I could get the "new tab" page back so I get the links to the things I use most often back. I don't like the "history" appearing on my new tab page — that's not really very helpful (IMHO). Anyway, my thanks to all!

I selected the correct "solution" for the xulstore.json fix.


To get rid of that "Activity Stream" as your New Tab page, go here: https://testpilot.firefox.com/experiments and open the Activity Stream page from the left- test feature button.

or go here directly: https://testpilot.firefox.com/experiments/activity-stream

And use the Disable Activity Stream button.

Test Pilot uses an online page to enable / disable the feature that are currently being tested. Note, you will need to be logged in to your Firefox Account ( 3-dot button in the upper-right corner of that page ) to work with Test Pilot extension features. I think it is done that way for the data collection and data collation aspects of these tests, and to ask for feedback if or when each user has completed their testing of each of the features.