Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox make hard drive run at 100%

  • 3 replies
  • 2 have this problem
  • 12 views
  • Last reply by John99

more options

I have set the cache to limit at 1024Mb. One day i launched firefox (x64 version) and it would make my drive run at 100% whatever i do. The only solution was to close firefox. Is it a problem with clearing the cache?

All Replies (3)

more options

Was that only a one off problem or are you still having that problem.

If you still have a problem first of all try Firefox's safe mode, then if necessary do a Refresh, but make a note of any Firefox extensions. I suggest bookmarking their home pages.


Off topic but presumably you realise you are running short of time if you wish to take the free upgrade from Windows 8.1 to 10

I believe the offer ends at the end of this month. It does give an option to downgrade again if you do not like it, but again that must be done within time limits.

more options

The problem appared one or two times, i don't remember. I don't have any plugins. I would like to know: perhaps there is a limit to maximum cache size?

more options

Cache can be good it may help speed up Firefox. Sorry I am not aware of any limits Firefox imposes on Cache Size, but that is not saying there are no limits.

However cache may increase when there is a problem, and large amounts of cache on a computer with nor much available RAM will cause slowdowns. If you have only seen this a few times it is probably not worth speculating.

Note you may check what is in the cache using about:cache <- Key into the address bar and press Enter

Also see