Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I get back to the previous tab design, where there was always a tab to the right of those I had opened in the tab bar, ready to use?

  • 2 replies
  • 1 has this problem
  • 12 views
  • Last reply by cor-el

more options

Now when I open Firefox, only one tab appears, without a second one next to it which I can click to start a new tab. The tab bar next to my one open tab is just blank. I have to use keyboard shortcuts such as ctrl-T to open each new tab, and it's driving me crazy. How can I get the "ready-to-use" tab back?

All Replies (2)

more options

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.


If that doesn't help, open the 3-bar menu > Customize, and click on Restore Defaults. More here - Customize Firefox controls, buttons and toolbars.

When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you!

more options

Make sure toolbars like the "Bookmarks Toolbar" are visible.

  • "3-bar" menu button -> Customize -> Show/Hide Toolbars
  • View -> Toolbars
    You can tap the Alt key or press F10 to show the Menu Bar
  • Right-click empty toolbar area

Open the Customize window and set which toolbar items to display.

  • "3-bar" menu button -> Customize
  • check that "Bookmarks Toolbar Items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar Items" is not on the Bookmarks Toolbar then drag it back from the Customize palette to the Customize window to the Bookmarks Toolbar
  • if missing items are in the Customize palette then drag them back from the Customize window to the toolbar
  • if you do not see an item on a toolbar and in the Customize palette then click the Restore Defaults button in the Customize palette window to restore the default toolbar set.