X
Tap here to go to the mobile version of the site.

Support Forum

How can I stop Firefox from hanging due to Shockwave/Flash?

Posted

This problem began suddenly in the middle of the day yesterday. I was trying to log in to Imgur, and the browser hanged. I suspected it was due to Shockwave or Flash, so I made it 'Ask to Activate', and am now able to use Imgur and even Youtube fine. But now, Twitch does not work. I activated the plugin on the page, and Firefox immediately hanged until I managed to close the tab with Twitch open. I get an error to 'stop plugin', but it appears only for a couple seconds before vanishing (I suspect to try and load again). Annoyed that I can't watch live streaming because Flash or Shockwave (or both) are giving my Firefox crap. As far as I know, everything I have is up to date, and I'm running Windows 10. Any insight to this issue would be immensely helpful. Thanks in advance.

This problem began suddenly in the middle of the day yesterday. I was trying to log in to Imgur, and the browser hanged. I suspected it was due to Shockwave or Flash, so I made it 'Ask to Activate', and am now able to use Imgur and even Youtube fine. But now, Twitch does not work. I activated the plugin on the page, and Firefox immediately hanged until I managed to close the tab with Twitch open. I get an error to 'stop plugin', but it appears only for a couple seconds before vanishing (I suspect to try and load again). Annoyed that I can't watch live streaming because Flash or Shockwave (or both) are giving my Firefox crap. As far as I know, everything I have is up to date, and I'm running Windows 10. Any insight to this issue would be immensely helpful. Thanks in advance.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.16.20045
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • LastPass Plugin
  • Shockwave Flash 22.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

FredMcD
  • Top 10 Contributor
4229 solutions 59020 answers

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

Question owner

I can't disable hardware acceleration for Flash, because attempting to load the page with the animated tree on it made Firefox hang and I had to close the tab.

I will try the rest and see if they work.'

I can't disable hardware acceleration for Flash, because attempting to load the page with the animated tree on it made Firefox hang and I had to close the tab. I will try the rest and see if they work.'
FredMcD
  • Top 10 Contributor
4229 solutions 59020 answers

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Find Shockwave Flash, and press the Options button. Uncheck Enable Adobe Flash Protected Mode.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins.''' Find '''Shockwave Flash,''' and press the '''Options''' button. Uncheck '''Enable Adobe Flash Protected Mode.'''

Question owner

Did it. No dice.

Worth noting that it works fine in Chrome, so this is strictly a Firefox issue.

Did it. No dice. Worth noting that it works fine in Chrome, so this is strictly a Firefox issue.
tehuti88 0 solutions 12 answers

This won't solve your problem, but some months back (following a Firefox update), I started having issues with Firefox completely locking up my computer for a minute or more when I visit certain sites (e. g., Yahoo!, Imgur, DeviantArt, etc.). I had Flash disabled for all of those, though, so I didn't think that could be the issue.

I had to completely uninstall Flash yesterday due to the latest update (22) being buggy with Firefox and not working whatsoever. (I reinstalled it for use in Internet Explorer, but it no longer shows up on the list of Firefox plugins.) I just went and checked out the three sites listed above, which would always make my computer hang when I visited them. They all seem to work fine now that I have no Flash plugin for Firefox.

So I guess you could say that for some months now I've been having a much similar issue (only in Windows 7), I just wasn't aware it was Flash related, since apparently, having Flash installed in Firefox, yet disabled, isn't enough to prevent the problem.

This won't solve your problem, but some months back (following a Firefox update), I started having issues with Firefox completely locking up my computer for a minute or more when I visit certain sites (e. g., Yahoo!, Imgur, DeviantArt, etc.). I had Flash disabled for all of those, though, so I didn't think that could be the issue. I had to completely uninstall Flash yesterday due to the latest update (22) being buggy with Firefox and not working whatsoever. (I reinstalled it for use in Internet Explorer, but it no longer shows up on the list of Firefox plugins.) I just went and checked out the three sites listed above, which would always make my computer hang when I visited them. They all seem to work fine now that I have no Flash plugin for Firefox. So I guess you could say that for some months now I've been having a much similar issue (only in Windows 7), I just wasn't aware it was Flash related, since apparently, having Flash installed in Firefox, yet disabled, isn't enough to prevent the problem.
jscher2000
  • Top 10 Contributor
8639 solutions 70685 answers

At this point, I haven't seen anyone explain why some people get incessant plugin error dialogs with the .192 update (after allowing Flash) and some people do not.

Since the problem occurs in Firefox's Safe Mode, I think we can rule out extensions as a potential culprit. To rule out other settings, a logical experiment is:

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager. You can use the Start menu search box or the Run dialog. Type or paste the following and press the Enter key to run it:

firefox.exe -P

This should launch a small window. Don't delete anything here!

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like June2016, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile.

Any improvement?

When returning to the Profile Manager, you might be tempted to use the Delete Profile button for June2016. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.


If the problem occurs in a new profile, that suggests external factors such as:

  • a particular Windows update
  • security software
  • something else
At this point, I haven't seen anyone explain why some people get incessant plugin error dialogs with the .192 update (after allowing Flash) and some people do not. Since the problem occurs in Firefox's Safe Mode, I think we can rule out extensions as a potential culprit. To rule out other settings, a logical experiment is: '''Create a new Firefox profile''' A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder. Exit Firefox and start up in the Profile Manager. You can use the Start menu search box or the Run dialog. Type or paste the following and press the Enter key to run it: firefox.exe -P This should launch a small window. ''Don't delete anything here!'' Any time you want to switch profiles, exit Firefox and return to this dialog. Click the Create Profile button, assign a name like June2016, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile. Any improvement? When returning to the Profile Manager, you might be tempted to use the Delete Profile button for June2016. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong. ---- If the problem occurs in a new profile, that suggests external factors such as: * a particular Windows update * security software * ''something else''

Question owner

... Woke up this morning, only to find the problem has, somehow, fixed itself. Weird. Thanks to everyone for the suggestions made here. I'm bookmarking this topic in case this happens again in the future.

... Woke up this morning, only to find the problem has, somehow, fixed itself. Weird. Thanks to everyone for the suggestions made here. I'm bookmarking this topic in case this happens again in the future.
FredMcD
  • Top 10 Contributor
4229 solutions 59020 answers

It could have been a corrupt file that was overwritten.

It could have been a corrupt file that was overwritten.