X
Tap here to go to the mobile version of the site.

Support Forum

I am using Win 10 Pro, and Firefox keeps stalling in the middle of browsing a web page.

Posted

Hi, I have been using Firefox for years, with Win 3.1, Win XP, Win 7 and now Win 10. However this week Firefox has suddenly decided to go mad. When I open Firefox I start to browse web pages, and after perhaps 10 different pages Firefox stalls. First, there is a funny round icon for the cursor when I try to move the cursor, then after I click on the top task bar Firefox suddenly stops responding, and the page goes opaque.

The only thing I can do at this point is to shut down Firefox and restart the program. When Firefox is restarted it goes to the original page when it stopped responding. I can then use Firefox as normal for a while, but it will then stop responding again, And again. And again.

I have deleted the program and removed everything from the registry, three times, but once I reload Firefox it will start doing the same thing all over again.

I have finally formatted the whole hard-drive and reinstalled a cloned copy of the disc from 4 months ago, but this has not solved the issue.

I suspect there is a problem between Firefox and Win 10, but the solutions posted are way too complicated for me to follow. I have found that the easiest solution is to use Chrome, which I don't really like, but at least it is stable.

As far as anti-virus programs are concerned my laptop runs Norton Anti Virus, Hitman Pro and Malwarebytes, and they run scans on a constant basis.

As I say, I think that the problem seems to be that Firefox no longer works with Windows 10.

Also there are no add-ons or anything with Firefox, but if there was anything I have disabled it, I went through Firefox at the time and disabled everything that was there, but to no avail.

Perhaps some-one might have a simple, straight forward solution.

Hi, I have been using Firefox for years, with Win 3.1, Win XP, Win 7 and now Win 10. However this week Firefox has suddenly decided to go mad. When I open Firefox I start to browse web pages, and after perhaps 10 different pages Firefox stalls. First, there is a funny round icon for the cursor when I try to move the cursor, then after I click on the top task bar Firefox suddenly stops responding, and the page goes opaque. The only thing I can do at this point is to shut down Firefox and restart the program. When Firefox is restarted it goes to the original page when it stopped responding. I can then use Firefox as normal for a while, but it will then stop responding again, And again. And again. I have deleted the program and removed everything from the registry, three times, but once I reload Firefox it will start doing the same thing all over again. I have finally formatted the whole hard-drive and reinstalled a cloned copy of the disc from 4 months ago, but this has not solved the issue. I suspect there is a problem between Firefox and Win 10, but the solutions posted are way too complicated for me to follow. I have found that the easiest solution is to use Chrome, which I don't really like, but at least it is stable. As far as anti-virus programs are concerned my laptop runs Norton Anti Virus, Hitman Pro and Malwarebytes, and they run scans on a constant basis. As I say, I think that the problem seems to be that Firefox no longer works with Windows 10. Also there are no add-ons or anything with Firefox, but if there was anything I have disabled it, I went through Firefox at the time and disabled everything that was there, but to no avail. Perhaps some-one might have a simple, straight forward solution.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.84 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59401 answers

What is your Firefox? What you describe sounds like the computers CPU is being overworked.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding

What is your Firefox? What you describe sounds like the computers CPU is being overworked. Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ------------- '''https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently''' '''https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster''' '''https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix''' '''https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding''' '''https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding'''

Question owner

Hi, I have tried that but with no result.

The laptop is an i7 processor with 8 gb of RAM, so I don't quite see why the CPU should suddenly start getting overworked by a single program.

I can use Chrome without a problem, it is Firefox that has suddenly become unusable. As I say, my opinion is, because of the way that it has happened, there is a problem of compatibility between Windows 10 Pro and Firefox, but I have no idea how to fix it.

Reloading and re-installing Firefox makes no difference. Formatting the drive after cleaning out all Firefox files, and reloading an earlier clone of the disc doesn't fix the problem, either.

It looks like Firefox has finally reached the end of the road, and I now need to look for a different, more stable, browser.

Unless some-one has an answer ?

Parkman.

Hi, I have tried that but with no result. The laptop is an i7 processor with 8 gb of RAM, so I don't quite see why the CPU should suddenly start getting overworked by a single program. I can use Chrome without a problem, it is Firefox that has suddenly become unusable. As I say, my opinion is, because of the way that it has happened, there is a problem of compatibility between Windows 10 Pro and Firefox, but I have no idea how to fix it. Reloading and re-installing Firefox makes no difference. Formatting the drive after cleaning out all Firefox files, and reloading an earlier clone of the disc doesn't fix the problem, either. It looks like Firefox has finally reached the end of the road, and I now need to look for a different, more stable, browser. Unless some-one has an answer ? Parkman.
FredMcD
  • Top 10 Contributor
4246 solutions 59401 answers

A number of Win 10 users having problems reverted their Windows back.

parkman said

I don't quite see why the CPU should suddenly start getting overworked by a single program.

These days, no computer is running just one program. A great many programs are always running in the background. Communication, protection, self maintenance . . . . . . .

Sometimes there are programs that don't work together. And sometimes it takes time to find them.


Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

A number of Win 10 users having problems reverted their Windows back. ''parkman [[#answer-887716|said]]'' <blockquote> I don't quite see why the CPU should suddenly start getting overworked by a single program. </blockquote> These days, no computer is running just one program. A great many programs are always running in the background. Communication, protection, self maintenance . . . . . . . Sometimes there are programs that don't work together. And sometimes it takes time to find them. ------------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

You probably saw this article but just in case: Firefox hangs or is not responding - How to fix.

As you know, some popular sites includes vast amounts of third party content. You might test in a private window to see whether sites that have difficulty loading can load when Firefox's Tracking Protection feature is applied. See: What happened to Tracking Protection?.

You probably saw this article but just in case: [[Firefox hangs or is not responding - How to fix]]. As you know, some popular sites includes vast amounts of third party content. You might test in a private window to see whether sites that have difficulty loading can load when Firefox's Tracking Protection feature is applied. See: [[Tracking Protection in Private Browsing]].

Question owner

Hi, I have been away for a while, and I returned home this week. I decided to re-install Firefox to see if there is any change to its stability, but unfortunately it is just the same as it was, it just hangs as soon as I try scrolling down a page.

I see an answer by FredMcD, that another user went back to a previous version of Windows, by which I assume was Win 7 or 8. I am not prepared to do that, as I feel that Win 10 is working better on my i7 64 bit laptops than Win 7 did. So that's not an option, to revert to Win 7.

I have two other laptops in our offices in Dublin, both Toshiba, both upgraded to Win 10 from Win7, and there has never been a problem with them. It is only the Acer laptop in our office in Liverpool that has become unstable.

As I have no problems using Chrome, I suspect that the problem is being caused by one of a couple of things - that there is something strange happening with TalkTalk [my broadband supplier]; that there is something strange with the UK downloads of Firefox; or that the UK version of Firefox is incompatible with Win 10 upgrades.

I have not downloaded and installed any new programs in the last three or four months, so I have to suspect that the problem is somewhere within Firefox itself.

Unless there is a virus that has bypassed my Norton Anti-virus program. And my Malwarebytes program. And my Hitman Pro program. I suppose that could be possible, but I would have thought that there would have been posts on the Norton website if that were the case.

The only thing that I can think of at this stage is to replace both memory blocks in the laptops, and fit new items. As the machine is using an i7 processor and 8gb of ram I find it unlikely that the hardware is being over-worked. For instance, the fan very, very rarely comes on, the laptop runs cool all the time. If the hardware was being over-worked then I suspect that the fan would be coming on with increased frequency.

It is a pity that no-one has come up with a more simple means to see how the problem can be cured. I am able to follow the more simple solutions, like turning off hardware acceleration [ a bit pointless as far as I am concerned, as I watch the occasional video which I have downloaded] but I am not comfortable with rooting about in the registry.

Also, turning off other programs to see if they affect Firefox is so vague and time-consuming that I discounted it immediately. As this is a very recent problem I doubt that going that route would make any difference anyway. The installed programs on the laptop had always worked perfectly, including Firefox.

I still believe that it is a problem with the current version of Firefox, and as my laptop automatically downloads new versions it is very difficult to get Firefox to remain as a old version.

Again, any straightforward solutions, apart from saying to just use Chrome, would be most welcome.

parkman

Hi, I have been away for a while, and I returned home this week. I decided to re-install Firefox to see if there is any change to its stability, but unfortunately it is just the same as it was, it just hangs as soon as I try scrolling down a page. I see an answer by FredMcD, that another user went back to a previous version of Windows, by which I assume was Win 7 or 8. I am not prepared to do that, as I feel that Win 10 is working better on my i7 64 bit laptops than Win 7 did. So that's not an option, to revert to Win 7. I have two other laptops in our offices in Dublin, both Toshiba, both upgraded to Win 10 from Win7, and there has never been a problem with them. It is only the Acer laptop in our office in Liverpool that has become unstable. As I have no problems using Chrome, I suspect that the problem is being caused by one of a couple of things - that there is something strange happening with TalkTalk [my broadband supplier]; that there is something strange with the UK downloads of Firefox; or that the UK version of Firefox is incompatible with Win 10 upgrades. I have not downloaded and installed any new programs in the last three or four months, so I have to suspect that the problem is somewhere within Firefox itself. Unless there is a virus that has bypassed my Norton Anti-virus program. And my Malwarebytes program. And my Hitman Pro program. I suppose that could be possible, but I would have thought that there would have been posts on the Norton website if that were the case. The only thing that I can think of at this stage is to replace both memory blocks in the laptops, and fit new items. As the machine is using an i7 processor and 8gb of ram I find it unlikely that the hardware is being over-worked. For instance, the fan very, very rarely comes on, the laptop runs cool all the time. If the hardware was being over-worked then I suspect that the fan would be coming on with increased frequency. It is a pity that no-one has come up with a more simple means to see how the problem can be cured. I am able to follow the more simple solutions, like turning off hardware acceleration [ a bit pointless as far as I am concerned, as I watch the occasional video which I have downloaded] but I am not comfortable with rooting about in the registry. Also, turning off other programs to see if they affect Firefox is so vague and time-consuming that I discounted it immediately. As this is a very recent problem I doubt that going that route would make any difference anyway. The installed programs on the laptop had always worked perfectly, including Firefox. I still believe that it is a problem with the current version of Firefox, and as my laptop automatically downloads new versions it is very difficult to get Firefox to remain as a old version. Again, any straightforward solutions, apart from saying to just use Chrome, would be most welcome. parkman
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

Many users have reported problems with recent updates to Flash in Firefox. While you are troubleshooting this, it might be helpful, to avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Find "Shockwave Flash" on the right side and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

Not a solution, but hopefully will help a bit.

Many users have reported problems with recent updates to Flash in Firefox. While you are troubleshooting this, it might be helpful, to avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. To set "Ask to Activate", open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Find "Shockwave Flash" on the right side and change "Always Activate" to "Ask to Activate". With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later. Not a solution, but hopefully will help a bit.