X
Tap here to go to the mobile version of the site.

Support Forum

"Bookmark This Page" Pop up Box closing suddenly

Posted

Hi

I have noticed over the last couple of weeks that when I click on "Bookmark this page" it brings up the usual pop-up windows but, when I try to retype the title of the bookmark the window closes before I have finished typing and before I have identified where I want the bookmark to go in my bookmarks list. It then saves the bookmark just at the bottom of the list of bookamrks and folders and I have to go back in and move it around and retitle it in there. I assume it is related to one of the more recent upgrades as I am currently using 47.0.

Does anyone have any ideas on what might be causing this and how to fix it?

Thanks

Hi I have noticed over the last couple of weeks that when I click on "Bookmark this page" it brings up the usual pop-up windows but, when I try to retype the title of the bookmark the window closes before I have finished typing and before I have identified where I want the bookmark to go in my bookmarks list. It then saves the bookmark just at the bottom of the list of bookamrks and folders and I have to go back in and move it around and retitle it in there. I assume it is related to one of the more recent upgrades as I am currently using 47.0. Does anyone have any ideas on what might be causing this and how to fix it? Thanks

Additional System Details

Installed Plug-ins

  • Shockwave Flash 21.0 r0
  • Plugin for Wacom tablets.
  • ~Mirage 6.1.60.0 Plugin for Visual Mirage Projects

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

FredMcD
  • Top 10 Contributor
4257 solutions 59606 answers

Helpful Reply

Are you using any bookmark add-ons? Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Are you using any bookmark add-ons? Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

Firefox 47 changed how the star icon works to show the editing panel immediately rather than requiring a second click. I'm not sure why, but user interface people undoubtedly decided this was best...

If I click the star or press Ctrl+d and do nothing, Firefox closes the little panel after about 3 seconds. If I press any key (e.g., right arrow to go to the end of the name, or Delete or any character to start editing the name), then the panel remains indefinitely.

Edit: Or if I press the Tab key to move the focus to the recent folders button, that also prevents it from closing.

Does that work for you or does yours disappear in the middle of typing?

The Esc key has always closed the panel, but perhaps other things that occur in the background might do it as well.

Firefox 47 changed how the star icon works to show the editing panel immediately rather than requiring a second click. I'm not sure why, but user interface people undoubtedly decided this was best... If I click the star or press Ctrl+d and do nothing, Firefox closes the little panel after about 3 seconds. If I press any key (e.g., right arrow to go to the end of the name, or Delete or any character to start editing the name), then the panel remains indefinitely. ''Edit: Or if I press the Tab key to move the focus to the recent folders button, that also prevents it from closing.'' Does that work for you or does yours disappear in the middle of typing? The Esc key has always closed the panel, but perhaps other things that occur in the background might do it as well.

Modified by jscher2000

Question owner

Hi jscher2000, pressing a key as described didn't make the pop-up window remain for any longer I'm afraid. thanks for the suggestion though.

Thanks FredMcD, I tried Safe Mode and the error did not happen so, as you say possibly an Add-On misbehaving with the new build.

Not sure I have anything particularly for Bookmarks installed apart from Bookmark Favicon Changer, Menu Editor or Classic Theme Restorer but I'll check it out.

It is annoying that Firefox was developed to be adaptable from a simple core and now it seems that every new update breaks something else.

Hi jscher2000, pressing a key as described didn't make the pop-up window remain for any longer I'm afraid. thanks for the suggestion though. Thanks FredMcD, I tried Safe Mode and the error did not happen so, as you say possibly an Add-On misbehaving with the new build. Not sure I have anything particularly for Bookmarks installed apart from Bookmark Favicon Changer, Menu Editor or Classic Theme Restorer but I'll check it out. It is annoying that Firefox was developed to be adaptable from a simple core and now it seems that every new update breaks something else.
FredMcD
  • Top 10 Contributor
4257 solutions 59606 answers

Almost every upgrade, we get flooded with users asking for help. For a long time, I don't update my Firefox until an update is put out for the upgrade. V47 is out, but I will wait before going to v47.0.1


Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.


It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Almost every upgrade, we get flooded with users asking for help. For a long time, I don't update my Firefox until an update is put out for the upgrade. V47 is out, but I will wait before going to v47.0.1 ------------- Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox. ------------- It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac=<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

Helpful Reply

Hi marcoporcellini, it sounds as though "something" is moving the focus away from the bookmark drop-panel, whether it's a keystroke that is dismissing the panel by virtually clicking Done or something that moves the focus to the page, or another tab, etc. I don't have a guess as to what it might be; this all seems to be a new scenario.

When the panel disappears, if you click the star or press Ctrl+d, did Firefox save your input up to that point or does it still show the original name?

Hi marcoporcellini, it sounds as though "something" is moving the focus away from the bookmark drop-panel, whether it's a keystroke that is dismissing the panel by virtually clicking Done or something that moves the focus to the page, or another tab, etc. I don't have a guess as to what it might be; this all seems to be a new scenario. When the panel disappears, if you click the star or press Ctrl+d, did Firefox save your input up to that point or does it still show the original name?

Question owner

Thanks for the responses.

FredMcD, I've tried disabling a few of the more obvious ones but nothing so far, I'll keep trying though.

jscher2000, I tried Control+D once it had disappeared and the same bookmark entry opened with whatever was in there and I was able to change the title at my leisure (it only seems to give 2 or 3 seconds before closing initially).

Thanks for the responses. FredMcD, I've tried disabling a few of the more obvious ones but nothing so far, I'll keep trying though. jscher2000, I tried Control+D once it had disappeared and the same bookmark entry opened with whatever was in there and I was able to change the title at my leisure (it only seems to give 2 or 3 seconds before closing initially).
cor-el
  • Top 10 Contributor
  • Moderator
17533 solutions 158534 answers

When you do not do anything then the "Edit This Bookmark" dialog closes automatically after a few seconds when you bookmark the current tab via a click on the star on the Navigation Toolbar or in the right-click context menu.

When you do not do anything then the "Edit This Bookmark" dialog closes automatically after a few seconds when you bookmark the current tab via a click on the star on the Navigation Toolbar or in the right-click context menu.

Question owner

Thanks cor-el but this happens with or without input into the dialogue box so it closes itself after a few seconds either way, I'm afraid.

Thanks cor-el but this happens with or without input into the dialogue box so it closes itself after a few seconds either way, I'm afraid.
noergler 0 solutions 1 answers

The change to version 47.0 contains a BUG: The "Edit This Bookmark" dialog closes unintentionally if the mouse leaves the dialog or if the sub-pop-up "Folder" is opened.

The thing is, however, that WE DON'T WANT TO HAVE THAT CHANGE AT ALL!!!

Most people set thousands of bookmarks and they don't want to organize all of them in folders. Only a small number of bookmarks is organized in folders.

Thus the old one-click-solution was fine. Now the workaround for most users to set a bookmark (without organizing it in folders) is to click twice on the star with a delay of at least 0.3 seconds.

THAT'S TEDIOUS!!!

The change to version 47.0 contains a BUG: The "Edit This Bookmark" dialog closes unintentionally if the mouse leaves the dialog or if the sub-pop-up "Folder" is opened. The thing is, however, that WE DON'T WANT TO HAVE THAT CHANGE AT ALL!!! Most people set thousands of bookmarks and they don't want to organize all of them in folders. Only a small number of bookmarks is organized in folders. Thus the old one-click-solution was fine. Now the workaround for most users to set a bookmark (without organizing it in folders) is to click twice on the star with a delay of at least 0.3 seconds. THAT'S TEDIOUS!!!
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40233 answers

noergler said

The change to version 47.0 contains a BUG: The "Edit This Bookmark" dialog closes unintentionally if the mouse leaves the dialog or if the sub-pop-up "Folder" is opened. The thing is, however, that WE DON'T WANT TO HAVE THAT CHANGE AT ALL!!!

You can let Mozilla know how you feel about that change by submitting your feedback here: https://input.mozilla.org/en-US/feedback

The support contributors here are just other users like you, especially on the weekend. We have no "say" in what get's changed in Firefox. Very few Mozilla personnel "ever grace us with their presence".

''noergler [[#answer-898043|said]]'' <blockquote> The change to version 47.0 contains a BUG: The "Edit This Bookmark" dialog closes unintentionally if the mouse leaves the dialog or if the sub-pop-up "Folder" is opened. The thing is, however, that WE DON'T WANT TO HAVE THAT CHANGE AT ALL!!! </blockquote> You can let Mozilla know how you feel about that change by submitting your feedback here: https://input.mozilla.org/en-US/feedback The support contributors here are just other users like you, especially on the weekend. We have no "say" in what get's changed in Firefox. Very few Mozilla personnel "ever grace us with their presence".
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40233 answers

BTW, this extension does get around that "quick closing" problem.

https://addons.mozilla.org/en-US/firefox/addon/add-bookmark-here-2/

The latest version is only compatible with Firefox 47 and later.

BTW, this extension does get around that "quick closing" problem. https://addons.mozilla.org/en-US/firefox/addon/add-bookmark-here-2/ The latest version is only compatible with Firefox 47 ''and later''.
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

noergler said

Most people set thousands of bookmarks and they don't want to organize all of them in folders. Only a small number of bookmarks is organized in folders.

Thus the old one-click-solution was fine. Now the workaround for most users to set a bookmark (without organizing it in folders) is to click twice on the star with a delay of at least 0.3 seconds.

If you click the star once, the bookmark should be created in Unsorted Bookmarks immediately. The panel doesn't dismiss itself for about 3 seconds, but you don't need to click the star (or the page) to close it unless you find it to be extremely distracting.

All the discussion makes me thing we could use a preference for the edit bookmark panel similar to the one that determines how long the full screen warning bar displays (full-screen-api.warning.timeout). Then users who find the default too long or too short could modify that (imaginary) value.

''noergler [[#answer-898043|said]]'' <blockquote> Most people set thousands of bookmarks and they don't want to organize all of them in folders. Only a small number of bookmarks is organized in folders. <br><br> Thus the old one-click-solution was fine. Now the workaround for most users to set a bookmark (without organizing it in folders) is to click twice on the star with a delay of at least 0.3 seconds. </blockquote> If you click the star once, the bookmark should be created in Unsorted Bookmarks immediately. The panel doesn't dismiss itself for about 3 seconds, but you don't need to click the star (or the page) to close it unless you find it to be extremely distracting. All the discussion makes me thing we could use a preference for the edit bookmark panel similar to the one that determines how long the full screen warning bar displays (full-screen-api.warning.timeout). Then users who find the default too long or too short could modify that (imaginary) value.
goodwitch 10 solutions 117 answers

This is still a major problem in Firefox 50.0. I always edit the name of the bookmark to make it easier to find before I choose which folder to place it in, or to include the date the article was written. Up until I found this thread I had thought that something else was causing the problem, namely some windows 7 function running in the background.

This is still a major problem in Firefox 50.0. I always edit the name of the bookmark to make it easier to find before I choose which folder to place it in, or to include the date the article was written. Up until I found this thread I had thought that something else was causing the problem, namely some windows 7 function running in the background.
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40233 answers

If you are looking for a "fix", have you tried the extension that I mentioned? https://addons.mozilla.org/en-US/firefox/addon/add-bookmark-here-2/

If you are looking for a "fix", have you tried the extension that I mentioned? https://addons.mozilla.org/en-US/firefox/addon/add-bookmark-here-2/
goodwitch 10 solutions 117 answers

Initially I was put off by some of the review comments on the download page. It's installed now and it does seem to fix the problem. Thanks a million.

Initially I was put off by some of the review comments on the download page. It's installed now and it does seem to fix the problem. Thanks a million.