X
Tap here to go to the mobile version of the site.

Support Forum

java does not get detected in broswer

Posted

I am running Firefox 46.0.1 (32bit) on a 64-bit Windows 8 machine. I have installed Java 8u92, have enabled it in browser, ensured that javascript is turned on in my browser but still the java is never detected in my browser.

I am running Firefox 46.0.1 (32bit) on a 64-bit Windows 8 machine. I have installed Java 8u92, have enabled it in browser, ensured that javascript is turned on in my browser but still the java is never detected in my browser.

Modified by kalpit

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • McAfee MSC FF plugin DLL
  • McAfee Virtual Technician plugin
  • Picasa plugin
  • Shockwave Flash 21.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Make sure your Java (Not JavaScript) is up to date Verify Java and Find Out-of-Date Versions {web link}

Version 8 Update 91 Release date April 19, 2016 http://java.com/en/download/manual.jsp


Separate Security Issue: Update your Adobe Reader Version 2015.016.20039 Note: Other Software is offered in the download.


Use this link to check that your plugins are up-to-date. If any are listed as unknown or research, do not worry about them.

Make sure your Java (Not JavaScript) is up to date '''[http://java.com/en/download/installed.jsp Verify Java and Find Out-of-Date Versions]''' {web link} Version 8 Update 91 Release date April 19, 2016 http://java.com/en/download/manual.jsp ------------ Separate Security Issue: Update your '''[http://get.adobe.com/reader/ Adobe Reader Version 2015.016.20039]''' '''Note: Other Software''' is offered in the download. ------------- '''[https://www.mozilla.org/en-US/plugincheck/ Use this link to check that your plugins are up-to-date.]''' If any are listed as unknown or research, do not worry about them.
cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157899 answers

Java and JavaScript are different languages. To avoid confusion, see:


It is possible that the correct Windows Registry keys are missing if Firefox doesn't detect the Java plugin. You can try to uninstall and reinstall Java, possibly as administrator to ensure the proper permissions. See also:

Java and JavaScript are different languages. To avoid confusion, see: *http://kb.mozillazine.org/JavaScript_is_not_Java ---- It is possible that the correct Windows Registry keys are missing if Firefox doesn't detect the Java plugin. You can try to uninstall and reinstall Java, possibly as administrator to ensure the proper permissions. See also: *http://kb.mozillazine.org/Java

Question owner

I have uninstalled and re-installed the latest Java.

I have also ensured that Java is enabled in the browser through the Java control panel.

Still my browser doesn't detect Java - same problem persists.

I have uninstalled and re-installed the latest Java. I have also ensured that Java is enabled in the browser through the Java control panel. Still my browser doesn't detect Java - same problem persists.
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins.''' Make sure the ones you want to use are set to '''Ask''' or '''Allow.''' -------------- Go to the web page. Once the page is loading, mouse to the address bar and '''Left''' click the icon. Select '''Permissions.''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow.'''
cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157899 answers

The browser setting in the Java control panel doesn't apply to current Firefox release.

Did you check the Windows Registry?

64 bit Windows:

  • HKLM\Software\Wow6432Node\MozillaPlugins\@java.com/JavaPlugin,version=xx.xx.xx
The browser setting in the Java control panel doesn't apply to current Firefox release. Did you check the Windows Registry? *http://kb.mozillazine.org/Java#Add_back_missing_registry_key 64 bit Windows: *HKLM\Software\Wow6432Node\MozillaPlugins\@java.com/JavaPlugin,version=xx.xx.xx