X
Tap here to go to the mobile version of the site.

Support Forum

Warning: unresponsive script ...on this page might be busy googleads.

Posted

Hello, after installing FF x64 on my new laptop I decided not to use any adblocker or other addon. I wanted to get used to the adworld no matter the cost on efficiency. However, lately I am facing more and more of this problem.

Unresponsive script that relates to google ads and the sites I am visiting. What am I doing wrong and how to fix it? Thank you

Hello, after installing FF x64 on my new laptop I decided not to use any adblocker or other addon. I wanted to get used to the adworld no matter the cost on efficiency. However, lately I am facing more and more of this problem. Unresponsive script that relates to google ads and the sites I am visiting. What am I doing wrong and how to fix it? Thank you
Attached screenshots

Chosen solution

Try to check for issues caused by plugins.

  • set plugins to "Ask to Activate" on the about:addons page ("3-bar" menu button or Tools > Add-ons > Plugins)
  • plugins are not affected by Firefox Safe Mode

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 21.0 r0

Application

  • Firefox 46.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-GB/

Extensions

  • Firefox Hello Beta 1.3.2 (loop@mozilla.org)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 520
  • adapterDescription2:
  • adapterDeviceID: 0x1916
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 382a17aa
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 10-28-2015
  • driverDate2:
  • driverVersion: 20.19.15.4312
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 520 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157343 answers

Chosen Solution

Try to check for issues caused by plugins.

  • set plugins to "Ask to Activate" on the about:addons page ("3-bar" menu button or Tools > Add-ons > Plugins)
  • plugins are not affected by Firefox Safe Mode

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Try to check for issues caused by plugins. *set plugins to "Ask to Activate" on the about:addons page ("3-bar" menu button or Tools > Add-ons > Plugins) *plugins are not affected by Firefox Safe Mode Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10
peterriva 0 solutions 16 answers

I have tried everything. IE does NOT have this problem so it is not GoDaddy. Other computers in the office do not have this Firefox problem either. Adobe Flash reset as instructed. This is a serious PAIN since the upgrade (Really? In what sense if this an upgrade to lose huge amounts of time?) to newest Firefox.

I have tried everything. IE does NOT have this problem so it is not GoDaddy. Other computers in the office do not have this Firefox problem either. Adobe Flash reset as instructed. This is a serious PAIN since the upgrade (Really? In what sense if this an upgrade to lose huge amounts of time?) to newest Firefox.
Thomas.a4000 0 solutions 12 answers

i have tried this, no good, this happen only on firefox, not internet explorer, is their a way to disconnect , this screen from coming up. maybe busy, options never show this again, debug, stop , I can't use firefox, because of this screen, Help

i have tried this, no good, this happen only on firefox, not internet explorer, is their a way to disconnect , this screen from coming up. maybe busy, options never show this again, debug, stop , I can't use firefox, because of this screen, Help

Modified by Thomas.a4000

Thomas.a4000 0 solutions 12 answers

Helpful Reply

Thomas.a4000 said

i have tried this, no good, this happen only on firefox, not internet explorer, is their a way to disconnect , this screen from coming up. maybe busy, options never show this again, debug, stop , I can't use firefox, because of this screen, Help
''Thomas.a4000 [[#answer-889400|said]]'' <blockquote> i have tried this, no good, this happen only on firefox, not internet explorer, is their a way to disconnect , this screen from coming up. maybe busy, options never show this again, debug, stop , I can't use firefox, because of this screen, Help </blockquote>
peterriva 0 solutions 16 answers

happens every day, all the *&&^^%$ time. Really losing faith in Mozilla.

happens every day, all the *&&^^%$ time. Really losing faith in Mozilla.

Question owner

Please, try the solution suggested. Many websites seem to use flash plugin without permission (not sure how chrome is actually handling these). Just set the plugin to ask to activate.

The problem is that if you visit the website, it asks for you to "Allow flash plugin". - You click "Allow once" - You repeat this on every visit. If you click "Always allow" you will be getting the same issue. Internet is a crappy place these days. I decided to remove flash player (only required for p0rn after all) but still there are other options.

Please, try the solution suggested. Many websites seem to use flash plugin without permission (not sure how chrome is actually handling these). Just set the plugin to ask to activate. The problem is that if you visit the website, it asks for you to "Allow flash plugin". - You click "Allow once" - You repeat this on every visit. If you click "Always allow" you will be getting the same issue. Internet is a crappy place these days. I decided to remove flash player (only required for p0rn after all) but still there are other options.
jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Hi peterriva and Thomas.a4000, are you using a recent version of Windows?

In addition to the issues spelled out in the support article "Warning Unresponsive script - What it means and how to fix it", a common cause of unresponsive script errors on Windows 7-10 is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Hi peterriva and Thomas.a4000, are you using a recent version of Windows? In addition to the issues spelled out in the support article "[[Warning Unresponsive script - What it means and how to fix it]]", a common cause of unresponsive script errors on Windows 7-10 is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then ''uncheck'' the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.
peterriva 0 solutions 16 answers

Nice try... the unchecking of the shockwave "protected mode" was done weeks ago. Still same problem.

Nice try... the unchecking of the shockwave "protected mode" was done weeks ago. Still same problem.
jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Hi peterriva, are the addresses in the dialog scripts from the site you are trying to visit, from external sites such as ad networks, or internal (URLs starting with chrome:// or resource:// instead of http/https)?

Hi peterriva, are the addresses in the dialog scripts from the site you are trying to visit, from external sites such as ad networks, or internal (URLs starting with chrome:// or resource:// instead of http/https)?
peterriva 0 solutions 16 answers

Basically any site - all http or https that have some gizmo that we need to see in shockwave in order to access information.

Basically any site - all http or https that have some gizmo that we need to see in shockwave in order to access information.
peterriva 0 solutions 16 answers

QuickBooks, for a start...

QuickBooks, for a start...
jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

peterriva said

Basically any site - all http or https that have some gizmo that we need to see in shockwave in order to access information.

Just to confirm: it's an unresponsive script error, not an unresponsive plugin error.

So the address that is of interest to me is not the address of the page, but the address displayed in the unresponsive script dialog.

''peterriva [[#answer-889505|said]]'' <blockquote> Basically any site - all http or https that have some gizmo that we need to see in shockwave in order to access information. </blockquote> Just to confirm: it's an unresponsive ''script'' error, not an unresponsive ''plugin'' error. So the address that is of interest to me is not the address of the page, but the address displayed in the unresponsive script dialog.
peterriva 0 solutions 16 answers

when I have time to do this work for you, I'll come back.

when I have time to do this work for you, I'll come back.
Thomas.a4000 0 solutions 12 answers

jscher2000 said

Hi peterriva, are the addresses in the dialog scripts from the site you are trying to visit, from external sites such as ad networks, or internal (URLs starting with chrome:// or resource:// instead of http/https)?
''jscher2000 [[#answer-889462|said]]'' <blockquote> Hi peterriva, are the addresses in the dialog scripts from the site you are trying to visit, from external sites such as ad networks, or internal (URLs starting with chrome:// or resource:// instead of http/https)? </blockquote>
Thomas.a4000 0 solutions 12 answers

Helpful Reply

This problem appears mostly went I go to www.cbssports.com

I went to adobe free download and found a debugging option and down loaded. I tried just a couple of times and decided to not mozilla firefox for this website, when i use internet explorer for this website, I don't have any issues what so ever.

The warning says busy it doesn't say not responsive

So why would this not be a problem with Internet explorer?

This problem appears mostly went I go to www.cbssports.com I went to adobe free download and found a debugging option and down loaded. I tried just a couple of times and decided to not mozilla firefox for this website, when i use internet explorer for this website, I don't have any issues what so ever. The warning says busy it doesn't say not responsive So why would this not be a problem with Internet explorer?
LadySythe 0 solutions 2 answers

I've been having the same exact issue - unresponsive script - issues for about a year now. It happens most when viewing facebook.com , and sometimes on other pages. When the error window pops up, it's usually something different each time on the message window. Hitting the Debug button and waiting for the debugger to load unlocks firefox out of its freeze...until it freezes up again. Sometimes it only effects the one tab that facebook is on and I can view the other tabs, sometimes it effects them all. It's getting seriously friggin annoying! None of the work-arounds, fixes etc work.

  • waits for firefox to lock up with error window to screencap...doesn't happen when needed*

And WHY is this browser such a ram and cpu hog?! O.o WOW!

I've been having the same exact issue - unresponsive script - issues for about a year now. It happens most when viewing facebook.com , and sometimes on other pages. When the error window pops up, it's usually something different each time on the message window. Hitting the Debug button and waiting for the debugger to load unlocks firefox out of its freeze...until it freezes up again. Sometimes it only effects the one tab that facebook is on and I can view the other tabs, sometimes it effects them all. It's getting seriously friggin annoying! None of the work-arounds, fixes etc work. *waits for firefox to lock up with error window to screencap...doesn't happen when needed* And WHY is this browser such a ram and cpu hog?! O.o WOW!

Modified by LadySythe

jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers
Hi LadySythe, did you try: https://support.mozilla.org/questions/1124163#answer-889430
LadySythe 0 solutions 2 answers

jscher2000 said

Hi LadySythe, did you try: https://support.mozilla.org/questions/1124163#answer-889430

As I stated, I tried all the different fixes, etc. They don't work.

''jscher2000 [[#answer-908052|said]]'' <blockquote> Hi LadySythe, did you try: https://support.mozilla.org/questions/1124163#answer-889430 </blockquote> As I stated, I tried all the different fixes, etc. They don't work.
jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Hi LadySythe, can you tell whether Flash is the issue? Try setting Flash to Click-to-Play ("Ask to Activate"), and not activating it on Facebook and other sites where you have this problem.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

For diagnostic purposes, do not enable Flash on Facebook or other sites where you have this problem. This will prevent you from viewing Facebook Live streams, but I think most other videos will still work if you have Windows Vista or newer.

Hi LadySythe, can you tell whether Flash is the issue? Try setting Flash to Click-to-Play ("Ask to Activate"), and not activating it on Facebook and other sites where you have this problem. To set "Ask to Activate", open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. For diagnostic purposes, do not enable Flash on Facebook or other sites where you have this problem. This will prevent you from viewing Facebook Live streams, but I think most other videos will still work if you have Windows Vista or newer.
peterriva 0 solutions 16 answers

The answer seems to be - swicth to IE (arghhhhhhhhhh...) funny how it never happens in IE. But Mozilla claims it is eveyone's fault but theirs.

Is there another browser we can ALL switch to away from Mozilla and NOT MS?

The answer seems to be - swicth to IE (arghhhhhhhhhh...) funny how it never happens in IE. But Mozilla claims it is eveyone's fault but theirs. Is there another browser we can ALL switch to away from Mozilla and NOT MS?