X
Tap here to go to the mobile version of the site.

Support Forum

Help!! MAKE FF/MOZILLA STOP BLOCKING MIXED CONTENT! I UNBLOCK. FF REBLOCKS. ** STOP IT!!**

Posted

GOING INSANE NOW. SEARCHED FF/MOZILLA HIGH AND LOW. FOUND THE FIX TO UNBLOCK THE BLOCKED MIXED CONTENT. BUT THE BLOCKS KEEP COMING BACK. I CAN'T STAND THIS ANY MORE!!!! I JUST WANT TO READ MY (&^t#& EMAIL AND ASSOCIATED PAGES! i JUST WANT TO DO THAT AND NOT HAVE TO JUMP THRU 837 MOZILLA HOOPS TO GET THERE. I DO NOT CARE IF THERE IS MIXED CONTENT IN AOL MAIL. I'VE BEEN USING IT FOR OVER ***TWENTY YEARS***. TELL ME HOW TO STOP THIS STUPID BLOCKING ONCE AND FOR ALL! AND TELL ME NOW PLEASE!

KATHY

GOING INSANE NOW. SEARCHED FF/MOZILLA HIGH AND LOW. FOUND THE FIX TO UNBLOCK THE BLOCKED MIXED CONTENT. BUT THE BLOCKS KEEP COMING BACK. I CAN'T STAND THIS ANY MORE!!!! I JUST WANT TO READ MY (&^t#& EMAIL AND ASSOCIATED PAGES! i JUST WANT TO DO THAT AND NOT HAVE TO JUMP THRU 837 MOZILLA HOOPS TO GET THERE. I DO NOT CARE IF THERE IS MIXED CONTENT IN AOL MAIL. I'VE BEEN USING IT FOR OVER ***TWENTY YEARS***. TELL ME HOW TO STOP THIS STUPID BLOCKING ONCE AND FOR ALL! AND TELL ME NOW PLEASE! KATHY

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.16.20039
  • GEPlugin
  • Google Update
  • NPWLPG
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0

Application

  • Firefox 46.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.7.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Firefox Hello 1.2.6 (loop@mozilla.org)
  • Kaspersky Protection 4.6.3-7 (light_plugin_ACF0E80077C511E59DED005056C00008@kaspersky.com)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • E-Web Print 1.20.00 (e-webprint@epson.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 8570D
  • adapterDescription2:
  • adapterDeviceID: 0x990e
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 768
  • adapterRAM2:
  • adapterSubsysID: 2ae0103c
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.18123
  • driverDate: 9-10-2013
  • driverDate2:
  • driverVersion: 13.152.1.1000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 3
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 8570D Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4270 solutions 59898 answers

Please turn off your caps lock.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Please turn off your caps lock. '''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save''' Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

Helpful Reply

Firefox only blocks mixed active content like HTTP iframes and scripts. Images are only flagged, but are still displayed. If you use extensions that force a secure connection then you are much more likely to encounter issues with mixed content.

You can always check the Web Console ("3-bar" menu button or Tools > Web Developer) to see what content this is about.

If you are willing to take the risk then set security.mixed_content.block_active_content to false.

Firefox only blocks mixed active content like HTTP iframes and scripts. Images are only flagged, but are still displayed. If you use extensions that force a secure connection then you are much more likely to encounter issues with mixed content. You can always check the Web Console ("3-bar" menu button or Tools > Web Developer) to see what content this is about. *https://developer.mozilla.org/Tools/Web_Console *https://developer.mozilla.org/Security/MixedContent If you are willing to take the risk then set security.mixed_content.block_active_content to false.
James
  • Top 25 Contributor
  • Moderator
1602 solutions 11343 answers

Hmm I wonder if the Kaspersky client or Kaspersky Protection extension in Firefox is doing some interference with this.

Hmm I wonder if the Kaspersky client or Kaspersky Protection extension in Firefox is doing some interference with this.

Modified by James

Question owner

FredMcD said

Please turn off your caps lock. https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Hello Fred McD. My caps lock was not on because I am stupid or blind. My caps lock was on because I have been trying to solve this problem for over a week, I'm actually quite good with computers and software, having been one of the first people I knew back then to get a computer, and I was and still am FURIOUS!

I have already read and tried all of the things at your link. No help. Thanks for trying. Kathy

''FredMcD [[#answer-879581|said]]'' <blockquote> Please turn off your caps lock. '''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save''' Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software. </blockquote> Hello Fred McD. My caps lock was not on because I am stupid or blind. My caps lock was on because I have been trying to solve this problem for over a week, I'm actually quite good with computers and software, having been one of the first people I knew back then to get a computer, and I was and still am FURIOUS! I have already read and tried all of the things at your link. No help. Thanks for trying. Kathy

Question owner

cor-el said

Firefox only blocks mixed active content like HTTP iframes and scripts. Images are only flagged, but are still displayed. If you use extensions that force a secure connection then you are much more likely to encounter issues with mixed content. You can always check the Web Console ("3-bar" menu button or Tools > Web Developer) to see what content this is about. If you are willing to take the risk then set security.mixed_content.block_active_content to false.

Dear cor-el, Thank you for your suggestions. The only web app I am having trouble with so far, and it has just begun happening, is AOL web-based Email and its associated pages. (I do not have to full-blown, old fashioned AOL app). I can open it the first time just fine. If I happen to close it, intending to get back to answer it later, the 2nd time I open it, the email content flashes for one second, then the page goes blank. The lock icon, upper left of addy bar, either has a red strip thru it or the infamous yellow triangle with exclamation mark in it. Message is page has been blocked due to mixed content.

I have triend 7 ways to Sunday to make it stop that. It has made my only email product, AOL Email, unusable. And no, I do not want to change to a different email address or email program for now.

I have blocked the FF app numerous times and it usually works for as long as I have that AOL email window open. Once closed and reopened, same old stuff happens again. I even got so frustrated I did the ultimate as you suggested ("If you are willing to take the risk then set security.mixed_content.block_active_content to false.") That only lasted until I rebooted my computer.

So now the problem is still there, as if nothing had been tried or done. I am not able to open any email a second time, rendering my email useless.

At wits' end. Thinking of dumping Firefox, which I have adored for so so long. (Hate IE.) Now what? Kathy

''cor-el [[#answer-879582|said]]'' <blockquote> Firefox only blocks mixed active content like HTTP iframes and scripts. Images are only flagged, but are still displayed. If you use extensions that force a secure connection then you are much more likely to encounter issues with mixed content. You can always check the Web Console ("3-bar" menu button or Tools > Web Developer) to see what content this is about. *https://developer.mozilla.org/Tools/Web_Console *https://developer.mozilla.org/Security/MixedContent If you are willing to take the risk then set security.mixed_content.block_active_content to false. </blockquote> Dear cor-el, Thank you for your suggestions. The only web app I am having trouble with so far, and it has just begun happening, is AOL web-based Email and its associated pages. (I do not have to full-blown, old fashioned AOL app). I can open it the first time just fine. If I happen to close it, intending to get back to answer it later, the 2nd time I open it, the email content flashes for one second, then the page goes blank. The lock icon, upper left of addy bar, either has a red strip thru it or the infamous yellow triangle with exclamation mark in it. Message is page has been blocked due to mixed content. I have triend 7 ways to Sunday to make it stop that. It has made my only email product, AOL Email, unusable. And no, I do not want to change to a different email address or email program for now. I have blocked the FF app numerous times and it usually works for as long as I have that AOL email window open. Once closed and reopened, same old stuff happens again. I even got so frustrated I did the ultimate as you suggested ("If you are willing to take the risk then set security.mixed_content.block_active_content to false.") That only lasted until I rebooted my computer. So now the problem is still there, as if nothing had been tried or done. I am not able to open any email a second time, rendering my email useless. At wits' end. Thinking of dumping Firefox, which I have adored for so so long. (Hate IE.) Now what? Kathy

Question owner

PS. The AOL email content being blocked is images, according to FF. I rarely even get graphics or images in my email except in the form of text presented in graphic form. It is nothing bad, certainly no porn or anything remotely similar to that!!!

PS. The AOL email content being blocked is images, according to FF. I rarely even get graphics or images in my email except in the form of text presented in graphic form. It is nothing bad, certainly no porn or anything remotely similar to that!!!

Question owner

James said

Hmm I wonder if the Kaspersky client or Kaspersky Protection extension in Firefox is doing some interference with this.

Hi James, I would wonder the same thing, had I not turned it off and still had the same result in AOL web-based email. I, in desperation, disabled the whole of Kaspersky (and temporarily enabled the Win firewall) and still had the same FF problem with AOL email. It does seem to be a FF problem.

Kaspersky certainly does keep one safe, and even safe from themselves, but man is it invasive! I don't need to be kept safe from myself, however! For example, the Kaspersky in Firefox to which you refer (in Add-ons), will let me disable it or even delete it, but upon reboot, it once again reappears as enabled. I am disillusioned with Kaspersky and all of its spider fingers and will not be renewing it next time.

I am only trying to read and reread my dumb email! Haven't been able to for a week now, unless I jump thru all the FF hoops so I can read and reply **for that session only**. No acceptable to me!

Thanks for your ideas though. Kathy

''James [[#answer-879602|said]]'' <blockquote> Hmm I wonder if the Kaspersky client or Kaspersky Protection extension in Firefox is doing some interference with this. </blockquote> Hi James, I would wonder the same thing, had I not turned it off and still had the same result in AOL web-based email. I, in desperation, disabled the whole of Kaspersky (and temporarily enabled the Win firewall) and still had the same FF problem with AOL email. It does seem to be a FF problem. Kaspersky certainly does keep one safe, and even safe from themselves, but man is it invasive! I don't need to be kept safe from myself, however! For example, the Kaspersky in Firefox to which you refer (in Add-ons), will let me disable it or even delete it, but upon reboot, it once again reappears as enabled. I am disillusioned with Kaspersky and all of its spider fingers and will not be renewing it next time. I am only trying to read and reread my dumb email! Haven't been able to for a week now, unless I jump thru all the FF hoops so I can read and reply **for that session only**. No acceptable to me! Thanks for your ideas though. Kathy
FredMcD
  • Top 10 Contributor
4270 solutions 59898 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ------------ Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

Helpful Reply

Firefox doesn't blocked images that come via an open HTTP connection by default.

You can see a special padlock at the left end of the location/address bar.

  • a padlock with a strike through means that mixed active content is blocked.
  • a padlock with an exclamation mark attached means that mixed passive content (e.g. images) is present, but not blocked.

What mixed active content is blocked when you see a padlock with a strike through?

Sometimes this happens when pages aren't meant to be accessed via a secure connection, but need to be accessed via an open connection and you force a secure connection.

Firefox doesn't blocked images that come via an open HTTP connection by default. You can see a special padlock at the left end of the location/address bar. *a padlock with a strike through means that mixed active content is blocked. *a padlock with an exclamation mark attached means that mixed passive content (e.g. images) is present, but not blocked. *https://support.mozilla.org/kb/mixed-content-blocking-firefox *https://support.mozilla.org/kb/control-center-site-privacy-and-security-firefox *https://developer.mozilla.org/Security/MixedContent What mixed active content is blocked when you see a padlock with a strike through? Sometimes this happens when pages aren't meant to be accessed via a secure connection, but need to be accessed via an open connection and you force a secure connection.