X
Tap here to go to the mobile version of the site.

Support Forum

my laptop sometimes overheats when browsing with Firefox

Posted

Seems that Firefox uses a great deal of memory to function at times. Is there a fix?

Seems that Firefox uses a great deal of memory to function at times. Is there a fix?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • GEPlugin
  • Google Update
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0

Application

  • Firefox 46.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-US/

Extensions

  • Amazon Assistant for Firefox 10.1604.8.747 (abb@amazon.com)
  • Apollo Sync for Firefox 2.0.1.1-signed.1-signed (ffsync@apollobrowser.com)
  • Firefox Hello 1.2.6 (loop@mozilla.org)
  • Google Image Search 1.15.1-signed.1-signed ({73007fef-a6e0-47d3-b4e7-dfc116ed6f65})
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Old Google Image Search Beta4.rev53.1.1-signed.1-signed (jid0-hVK3JChToUWBtJHMEmFM9ELeInk@jetpack)
  • Pocket 1.0 (firefox@getpocket.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 3000
  • adapterDescription2:
  • adapterDeviceID: 0x0116
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 16521043
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 3-8-2013
  • driverDate2:
  • driverVersion: 9.17.10.3062
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D11 vs_4_1 ps_4_1)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4194 solutions 58544 answers

Overheating? That might be the CPU is overworked. Is the computers case hot? Make sure the fan(s) are working properly. Buy a can of compressed air, and blow out the air ducts now and then.


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Overheating? That might be the CPU is overworked. Is the computers case hot? Make sure the fan(s) are working properly. Buy a can of compressed air, and blow out the air ducts now and then. ----------- Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
FredMcD
  • Top 10 Contributor
4194 solutions 58544 answers

Security Issue: Update your Adobe Reader Version 2015.016.20039 Note: Other Software is offered in the download.

Security Issue: Update your '''[http://get.adobe.com/reader/ Adobe Reader Version 2015.016.20039]''' '''Note: Other Software''' is offered in the download.
cor-el
  • Top 10 Contributor
  • Moderator
17350 solutions 156823 answers

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration