X
Tap here to go to the mobile version of the site.

Support Forum

Firefox very slow to load www.hl.co.uk

Posted

My Firefox is taking about a minute to load www.hl.co.uk. HL support have said that there is a problem with add ons and to "Refresh" Firefox. The page loads OK in Safe Mode and also loads OK immediately after a Refresh. However, the problem then comes back.

On going to hl.co.uk, the whole browser freezes (no other page will load) and the CPU goes to about 28% and stays there. After a minute the page loads and the CPU reverts to background %.

System is: Win 7 fully updated (except Win 10 updates); Firefox 38.8 ESR (FF45 breaks a lot of stuff as it defaults to 64 bit installation). - I have tried other FF versions back and forward and no difference - Addons are Avast Online security, Classic Theme Restorer, Classic Toobar Buttons, New Tab Homepage. - Whilst safe mode disable of Addons works to cure the issue, disabling Addons manually does not help. - The problem only occurs on the first load of www.hl.co.uk after starting Firefox. If you leave the page and go back to it, there is no delay - if you close FF and wait for it to fully exit then re-start, the problem occurs again - and again only once. - Totally reproducible! - IE11 loads the page fine, - Firefox is not slow on any other page (other than occasional but totally usual delays).

Unfortunately HL have declined any further help and suggest usign another browser - but it is clear that many of their users have the same problem

Help!

My Firefox is taking about a minute to load www.hl.co.uk. HL support have said that there is a problem with add ons and to "Refresh" Firefox. The page loads OK in Safe Mode and also loads OK immediately after a Refresh. However, the problem then comes back. On going to hl.co.uk, the whole browser freezes (no other page will load) and the CPU goes to about 28% and stays there. After a minute the page loads and the CPU reverts to background %. System is: Win 7 fully updated (except Win 10 updates); Firefox 38.8 ESR (FF45 breaks a lot of stuff as it defaults to 64 bit installation). - I have tried other FF versions back and forward and no difference - Addons are Avast Online security, Classic Theme Restorer, Classic Toobar Buttons, New Tab Homepage. - Whilst safe mode disable of Addons works to cure the issue, disabling Addons manually does not help. - The problem only occurs on the first load of www.hl.co.uk after starting Firefox. If you leave the page and go back to it, there is no delay - if you close FF and wait for it to fully exit then re-start, the problem occurs again - and again only once. - Totally reproducible! - IE11 loads the page fine, - Firefox is not slow on any other page (other than occasional but totally usual delays). Unfortunately HL have declined any further help and suggest usign another browser - but it is clear that many of their users have the same problem Help!

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.91.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 21.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.4.194
  • 5.1.41212.0
  • Windows Activation Technologies Plugin for Mozilla
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • Firefox 38.8.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.8.0/WINNT/en-GB/

Extensions

  • Avast Online Security 10.3.3.44 (wrc@avast.com)
  • Classic Theme Restorer 1.5.1 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Classic Toolbar Buttons 1.5.0 (CSTBB@NArisT2_Noia4dev)
  • New Tab Homepage Focus 0.4.3.1-signed (new-tab-homepage-focus@lapllc.com)
  • Copernic Desktop Search - Search Firefox content 3.7.0.8 ({133B7132-EA16-42F0-9329-2F420F9EB1A1}) (Inactive)
  • DigitalPersona Extension 5.0.0.4503 (otis@digitalpersona.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0116
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 04b21028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 400
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 4-10-2011
  • driverDate2:
  • driverVersion: 8.15.10.2361
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4195 solutions 58554 answers

https://support.mozilla.org/en-US/kb/update-firefox-latest-version 46.0.1

As a test, disable your protection programs.

https://support.mozilla.org/en-US/kb/update-firefox-latest-version '''46.0.1''' As a test, disable your protection programs.

Question owner

FredMcD said

https://support.mozilla.org/en-US/kb/update-firefox-latest-version 46.0.1 As a test, disable your protection programs.

Fred - I have tried this (and again just now) and no joy. I'd agree this looks as if something is checking the page content, but manual diasbling does nto seem to work - why a full Safe Mode disabling deos I don't know. The task that goes to a high CPU % is the Firefox task, so it's either core Firefox or something such as a Plug-In which shows up as being Firefox task.

''FredMcD [[#answer-874576|said]]'' <blockquote> https://support.mozilla.org/en-US/kb/update-firefox-latest-version '''46.0.1''' As a test, disable your protection programs. </blockquote> Fred - I have tried this (and again just now) and no joy. I'd agree this looks as if something is checking the page content, but manual diasbling does nto seem to work - why a full Safe Mode disabling deos I don't know. The task that goes to a high CPU % is the Firefox task, so it's either core Firefox or something such as a Plug-In which shows up as being Firefox task.
FredMcD
  • Top 10 Contributor
4195 solutions 58554 answers

Just to be sure, you disabled Avast?

Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.

Just to be sure, you disabled Avast? Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox.

Question owner

Hi Fred

Yes, definitely disabled Avast - both using the method above or by stopping Web Shield, or even the whole Avast, from Avast's shield controls. Hardware Acceleration was on, but stopping it did nothing. Appearance was already default.

One thing of interest (perhaps) was that afterwards (once - but I have seen it occasionally before) the page did actually load fairly quickly (1-2 secs) but the CPU and Firefox task go high for a minute or so. Note that if you close firefox when the CPU is high, the task does not terminate until after it has finished whatever it is doing and the CPU drops back to background.

I've attached two screen grabs - firstly the "normal" issue behaviour, then a second one where hl.co.uk loaded quickly (visually) but the CPU stayed high and Firefox task did not quit until 50 secs or so after I quit (X'd) Firefox. (each square on the graphs is 5 seconds)

Hi Fred Yes, definitely disabled Avast - both using the method above or by stopping Web Shield, or even the whole Avast, from Avast's shield controls. Hardware Acceleration was on, but stopping it did nothing. Appearance was already default. One thing of interest (perhaps) was that afterwards (once - but I have seen it occasionally before) the page did actually load fairly quickly (1-2 secs) but the CPU and Firefox task go high for a minute or so. Note that if you close firefox when the CPU is high, the task does not terminate until after it has finished whatever it is doing and the CPU drops back to background. I've attached two screen grabs - firstly the "normal" issue behaviour, then a second one where hl.co.uk loaded quickly (visually) but the CPU stayed high and Firefox task did not quit until 50 secs or so after I quit (X'd) Firefox. (each square on the graphs is 5 seconds)

Modified by Cliff

FredMcD
  • Top 10 Contributor
4195 solutions 58554 answers

I've called the big guys to help you. Good luck.

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

I've called the big guys to help you. Good luck. Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Question owner

Will try the safe mode idea when I can.

In the meantime, I was contemplating moving to version 46 - and have found it looks unlikely to succeed since on another machine (and Linux Mint, not Windows) I have just updated from FF 28 to 46 and lo, the problem now occurs on that machine as well !

It confirms another behaviour - sometimes the page doesn't load visually until the high CPU ends, at other times, the page loads or part loads visually but the high CPU period still occurs and the page does not finish loading (the reload arrow has not appeared) (or follow a link on the page or load another page) until the high CPU period ends.

But again, starting FF in Safe Mode avoids the problem

Will try the safe mode idea when I can. In the meantime, I was contemplating moving to version 46 - and have found it looks unlikely to succeed since on another machine (and Linux Mint, not Windows) I have just updated from FF 28 to 46 and lo, the problem now occurs on that machine as well ! It confirms another behaviour - sometimes the page doesn't load visually until the high CPU ends, at other times, the page loads or part loads visually but the high CPU period still occurs and the page does not finish loading (the reload arrow has not appeared) (or follow a link on the page or load another page) until the high CPU period ends. But again, starting FF in Safe Mode avoids the problem

Modified by Cliff

Question owner

Have reported at Bugzilla, though has not appeared in the database yet

Have reported at Bugzilla, though has not appeared in the database yet
FredMcD
  • Top 10 Contributor
4195 solutions 58554 answers

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac=<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

Question owner

Fred

Thanks for the suggestions but I'm afraid I tried all that right at the start. That's the funny thing though, diasbling add-ons manually does not help but disabling them by starting FF in Safe Mode (Menu / ? / Restart with Add-ons Disabled) does work.

And it's not Avast since my Linux machine does not have Avast on it yet the new 46.0 install shows the problem.

Update - I also fully uninstalled the addons and that also makes no difference.

So, we therefore know that the problem is probably not the addons but somethign that is disabled / bypassed in FF's Safe Mode. Also, it's not Windows specific and is not gone in the latest Linux version of v 46

Fred Thanks for the suggestions but I'm afraid I tried all that right at the start. That's the funny thing though, diasbling add-ons manually does not help but disabling them by starting FF in Safe Mode (Menu / ? / Restart with Add-ons Disabled) does work. And it's not Avast since my Linux machine does not have Avast on it yet the new 46.0 install shows the problem. Update - I also fully '''uninstalled''' the addons and that also makes no difference. '''So, we therefore know that the problem is probably not the addons but somethign that is disabled / bypassed in FF's Safe Mode. Also, it's not Windows specific and is not gone in the latest Linux version of v 46'''

Modified by Cliff

FredMcD
  • Top 10 Contributor
4195 solutions 58554 answers

Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.

Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox.

Question owner

Did that. Didn't work.

Did that. Didn't work.

Question owner

Ah. There's an error in my logic as to whether starting FF in Safe Mode works to solve the problem - basically - this doesn't in fact work! The reason it looks like it works is that the problem only occurs on the first time hl.co.uk is loaded after startign a new instance of FF.

- If you start FF, then load hl.co.uk, wait to resolve the wait, then restart in Safe mode, load hl.co.uk, the problem apparently goes away. But in fact it doesn't as the page is still ?cached? and therefore loads OK as it's a second load, not because of Safe Mode, whereas....

- if you start FF, do not load hl.co.uk, restart in Safe Mode, then visit hl.co.uk, the problem is still there!

Doh.

Ah. There's an error in my logic as to whether starting FF in Safe Mode works to solve the problem - basically - this doesn't in fact work! The reason it looks like it works is that the problem only occurs on the first time hl.co.uk is loaded after startign a new instance of FF. - If you start FF, then load hl.co.uk, wait to resolve the wait, then restart in Safe mode, load hl.co.uk, the problem apparently goes away. But in fact it doesn't as the page is still ?cached? and therefore loads OK as it's a second load, not because of Safe Mode, whereas.... - if you start FF, do '''not''' load hl.co.uk, restart in Safe Mode, '''then''' visit hl.co.uk, the problem is still there! Doh.

Question owner

Have submitted to bugzilla: 1272465

Have submitted to bugzilla: 1272465
FredMcD
  • Top 10 Contributor
4195 solutions 58554 answers

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.