X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 46.0.1 not keeping me signed in to any webites, cookies are enabled but do not work - how do i fix this?

Posted

Just like the question says, cookies are on and all the settings are fine but websites are not keeping me signed in after I exit the browser. I have tried all the cookie troubleshooting and none of it works, what can I do? I don't want to switch over to Chrome because I've used firefox for some many years.

Just like the question says, cookies are on and all the settings are fine but websites are not keeping me signed in after I exit the browser. I have tried all the cookie troubleshooting and none of it works, what can I do? I don't want to switch over to Chrome because I've used firefox for some many years.

Additional System Details

Installed Plug-ins

  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 21.0 r0

Application

  • Firefox 46.0.1
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.7.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • FastestFox 5.2.1.1-signed.1-signed (smarterwiki@wikiatic.com)
  • Firefox Hello 1.2.6 (loop@mozilla.org)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • Reddit Enhancement Suite 4.6.1 (jid1-xUfzOsOFlzSOXg@jetpack)
  • Flashblock 1.5.20 ({3d7eb24f-2740-49df-8937-200b1cc08f8a}) (Inactive)
  • YouTube High Definition 46.0 ({7b1bf0b6-a1b9-42b0-b75d-252036438bdc}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 970
  • adapterDescription2:
  • adapterDeviceID: 0x13c2
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 4095
  • adapterRAM2:
  • adapterSubsysID: 31611462
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 7-22-2015
  • driverDate2:
  • driverVersion: 10.18.13.5362
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 970 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8777 solutions 71743 answers

Could we review your settings first?

"3-bar" menu button (or Tools menu) > Options

In the left column, click Privacy. On the right side:

(A) If the selector is set to "Firefox will: Remember history" change that to "Firefox will: Use custom settings for history" so we can see the details (and continue with "C" below)

(B) If the selector is set to "Firefox will: Never remember history" then most likely you are using automatic private browsing and it's normal for cookies to be destroyed between sessions. With this setting, you will always need to log in.

(C) If the selector is set to "Firefox will: Use custom settings for history" then there are a few things to check:

(i) Cookie lifetime - If "Keep until" is set to "I close Firefox" then Firefox will not keep cookies between sessions.

(ii) Clear history at shutdown - If this box is checked, click the Settings button to the right to make sure Cookies are not included in what is cleared at shutdown.

Everything okay so far?

Could we review your settings first? "3-bar" menu button (or Tools menu) > Options In the left column, click Privacy. On the right side: (A) If the selector is set to "Firefox will: Remember history" change that to "Firefox will: Use custom settings for history" so we can see the details (and continue with "C" below) (B) If the selector is set to "Firefox will: Never remember history" then most likely you are using automatic private browsing and it's normal for cookies to be destroyed between sessions. With this setting, you will always need to log in. (C) If the selector is set to "Firefox will: Use custom settings for history" then there are a few things to check: (i) Cookie lifetime - If "Keep until" is set to "I close Firefox" then Firefox will not keep cookies between sessions. (ii) Clear history at shutdown - If this box is checked, click the Settings button to the right to make sure Cookies are not included in what is cleared at shutdown. Everything okay so far?

Question owner

Yea I have all of those settings on and it still doesn't work, let me know if there are any other tips to fixing this issue. I imported all the old settings from my previous computer and never had problems there before.

Yea I have all of those settings on and it still doesn't work, let me know if there are any other tips to fixing this issue. I imported all the old settings from my previous computer and never had problems there before.
jscher2000
  • Top 10 Contributor
8777 solutions 71743 answers

Firefox stores cookies in your active profile folder in a database file named cookies.sqlite. It's rare that this file becomes corrupted, but sometimes it happens. You can delete it to force Firefox to create a fresh one -- assuming you haven't already tried this. Here's how:

From inside Firefox, open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then delete/rename/remove cookies.sqlite. If you see any of these files, also delete/remove these: cookies.sqlite-shm, cookies.sqlite-wal, cookies.sqlite.bak.

Start Firefox back up again and retest.


There are some utility/cleanup/privacy/security programs that clear browser cookies. These differ in how they operate: some run between Firefox sessions, other run at Windows startup. Can you think of any software you have that could be doing that?

Firefox stores cookies in your active profile folder in a database file named cookies.sqlite. It's rare that this file becomes corrupted, but sometimes it happens. You can delete it to force Firefox to create a fresh one -- assuming you haven't already tried this. Here's how: From inside Firefox, open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then delete/rename/remove '''cookies.sqlite'''. If you see any of these files, also delete/remove these: cookies.sqlite-shm, cookies.sqlite-wal, cookies.sqlite.bak. Start Firefox back up again and retest. ---- There are some utility/cleanup/privacy/security programs that clear browser cookies. These differ in how they operate: some run between Firefox sessions, other run at Windows startup. Can you think of any software you have that could be doing that?