X
Tap here to go to the mobile version of the site.

Support Forum

How do I get rid of Yahoo Search on Firefox 43.0.1? It automatically goes to Yahoo every time I search from Firefox.

Posted

I hate Yahoo for usurping my computer.

I hate Yahoo for usurping my computer.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.73.2 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • CANON iMAGE GATEWAY Mycamera Plugin
  • RealDownloader Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealPlayer Download Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

FredMcD
  • Top 10 Contributor
4254 solutions 59579 answers

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove Yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


After the problem is fixed, Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac=<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Remove Yahoo '''Anything.''' Now do the same in the computers Programs Folder. '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. ------------------ After the problem is fixed, Bookmark and use this; Download the '''[https://addons.mozilla.org/en-US/firefox/addon/searchreset/ Mozilla Search Reset]''' {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

This problem can be caused by numerous add-ons, not just official Yahoo add-ons.

You probably know how to change your default search engine: Change your default search settings in Firefox.

What happens:

  • Firefox ignores that
  • It works until you exit Firefox and start it up again
  • It works until you shut down Windows and start it up again

Could you take a look at the address of the search results page? The one you get with the built-in Yahoo search plugin looks like this:

https://search.yahoo.com/yhs/search?p=search+terms&ei=UTF-8&hspart=mozilla&hsimp=yhs-001

Does yours have different parameters? That usually indicates third party software is involved.

One possible culprit would be an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. All extensions are optional. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

This problem can be caused by numerous add-ons, not just official Yahoo add-ons. You probably know how to change your default search engine: [[Change your default search settings in Firefox]]. What happens: * Firefox ignores that * It works until you exit Firefox and start it up again * It works until you shut down Windows and start it up again Could you take a look at the address of the search results page? The one you get with the built-in Yahoo search plugin looks like this: https://search.yahoo''.''com/yhs/search?p=''search+terms''&ei=UTF-8'''&hspart=mozilla&hsimp=yhs-001''' Does yours have different parameters? That usually indicates third party software is involved. One possible culprit would be an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then cast a critical eye over the list on the right side. All extensions are optional. If in doubt, disable. Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Any improvement?
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Also, your Firefox identified itself to the forum as version 43. An update is available that you can install using the "About Firefox" dialog as described in this article: Update Firefox to the latest release.

Also, your Firefox identified itself to the forum as version 43. An update is available that you can install using the "About Firefox" dialog as described in this article: [[Update Firefox to the latest version]].