X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Need step by step install older version of firefox instructions for non techies

Posted

I know all the risks and I've read https://support.mozilla.org/en-US/kb/install-older-version-of-firefox

Unfortunately when I go to the link w/the older versions, it doesn't say how to install. I'm not a techie, so I have no idea what to do with the files.

I only want to go back to where I can still block 1st party cookies.

I've checked the add-ons. From what I've read, since ff took away this option, none of them have anything that works.

I know all the risks and I've read https://support.mozilla.org/en-US/kb/install-older-version-of-firefox Unfortunately when I go to the link w/the older versions, it doesn't say how to install. I'm not a techie, so I have no idea what to do with the files. I only want to go back to where I can still block 1st party cookies. I've checked the add-ons. From what I've read, since ff took away this option, none of them have anything that works.

Chosen solution

Hmm, if zag is being used by the current site, it should show on CM's third party cookies. If it's from a different site, you might find it fastest to enter it manually on the Preferences page, Privacy panel, using the Exceptions button to the right of the cookie settings.

When I type zag.com and click block, Firefox adds http://zag.com to the list. I guess https://zag.com would need to be entered manually? Not very convenient.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 15.007.20033
  • Coupons Inc., Coupon Printer
  • Provides information about the default web browser
  • Shockwave Flash 21.0 r0
  • zoom.us launcher plugin version 1.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:45.0) Gecko/20100101 Firefox/45.0

More Information

jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

Helpful Reply

I think you're referring to the pop-up which asked you in real time whether you wanted a cookie from a particular server before the cookie was set. The last version with that feature was 43.something. Firefox 44+ no longer have that option.

I'm a Windows person, so I can't explain the best approach for Mac. It might be that you download the DMG file you want, trash the old application and then install the DMG. But that's very second-hand...

In Firefox 46, to control cookies from sites you haven't visited before, I suggest:

(1) Select a default cookie policy among these options on the Preferences page, Permissions panel (set to "Firefox will: Use custom settings for history"):

  • Allow sites to set persistent cookies if they want ("Keep until: they expire")
  • Allow sites to set only session cookies ("Keep until: I close Firefox") (I use and recommend this)
  • Block sites from setting cookies (Uncheck the box for allowing sites to set cookies)

(2) Install an extension that makes it easy to make site-specific changes, such as Cookie Monster.

The Cookie Monster button on the toolbar allows you to see permissions for first party and third party cookies and to change them.

https://addons.mozilla.org/firefox/addon/cookie-monster/

Sample screen shot attached -- the option to "Apply cookie settings to both HTTP and HTTPS" is turned on, which streamlines the menu. With this option you don't have to set/modify permissions for both HTTP or HTTPS on the same site.

I think you're referring to the pop-up which asked you in real time whether you wanted a cookie from a particular server ''before'' the cookie was set. The last version with that feature was 43.something. Firefox 44+ no longer have that option. I'm a Windows person, so I can't explain the best approach for Mac. It might be that you download the DMG file you want, trash the old application and then install the DMG. But that's very second-hand... In Firefox 46, to control cookies from sites you haven't visited before, I suggest: (1) Select a default cookie policy among these options on the Preferences page, Permissions panel (set to "Firefox will: Use custom settings for history"): * Allow sites to set persistent cookies if they want ("Keep until: they expire") * Allow sites to set only session cookies ("Keep until: I close Firefox") (I use and recommend this) * Block sites from setting cookies (Uncheck the box for allowing sites to set cookies) (2) Install an extension that makes it easy to make site-specific changes, such as Cookie Monster. The Cookie Monster button on the toolbar allows you to see permissions for first party and third party cookies and to change them. https://addons.mozilla.org/firefox/addon/cookie-monster/ Sample screen shot attached -- the option to "Apply cookie settings to both HTTP and HTTPS" is turned on, which streamlines the menu. With this option you don't have to set/modify permissions for both HTTP or HTTPS on the same site.

Question owner

Thank you, jscher2000.

I am a new mac user and it's driving me crazy, lol. In windows, I always had my preferences set to block all 3rd party & ask me every time for 1st party cookies. Now I can't use IE (or whatever they call it now) and safari doesn't allow any real privacy settings. So I've stuck with FF.

I didn't realize that FF had done away w/that until yesterday when I checked the "show cookies" and found it full of stuff.

I just went to update to 46 and "about FF" says I am up to date at 45.0.1. So I shut it down and reopened it and it's still the same. Strange.

Is there a way I can download and not lose all my settings so I can then follow your suggestions?

Thank you, jscher2000. I am a new mac user and it's driving me crazy, lol. In windows, I always had my preferences set to block all 3rd party & ask me every time for 1st party cookies. Now I can't use IE (or whatever they call it now) and safari doesn't allow any real privacy settings. So I've stuck with FF. I didn't realize that FF had done away w/that until yesterday when I checked the "show cookies" and found it full of stuff. I just went to update to 46 and "about FF" says I am up to date at 45.0.1. So I shut it down and reopened it and it's still the same. Strange. Is there a way I can download and not lose all my settings so I can then follow your suggestions?
jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

Helpful Reply

Hi CallyCat, I think I will let a Mac person explain the options for updating Firefox, but my suggestions should work in Firefox 45 as well since I've been suggesting that since Firefox 44 came out.

Hi CallyCat, I think I will let a Mac person explain the options for updating Firefox, but my suggestions should work in Firefox 45 as well since I've been suggesting that since Firefox 44 came out.

Question owner

I just added Cookie Monster. But I don't see the same setup in my preferences as you listed.

I'm attaching a screen shot of my preferences.

Before adding Cookie Monster, I tried manually blocking cookies via the exceptions options & saving it. It doesn't let me do that. No error messages, but when I check the list, it isn't there.

So, I will play around with Cookie Monster and see how that works.

Thanks again jscher!

I just added Cookie Monster. But I don't see the same setup in my preferences as you listed. I'm attaching a screen shot of my preferences. Before adding Cookie Monster, I tried manually blocking cookies via the exceptions options & saving it. It doesn't let me do that. No error messages, but when I check the list, it isn't there. So, I will play around with Cookie Monster and see how that works. Thanks again jscher!

Question owner

Ok, I think I figured it out.  :-))

Each time I go to a new website and don't want cookies, I just go to CM and select "reject all."

After doing that w/the first website, I then checked my FF exceptions and it was in the list as blocked. This takes a little more effort, but I'm grateful to once again have the option to block 1st party cookies.

Ok, I think I figured it out. :-)) Each time I go to a new website and don't want cookies, I just go to CM and select "reject all." After doing that w/the first website, I then checked my FF exceptions and it was in the list as blocked. This takes a little more effort, but I'm grateful to once again have the option to block 1st party cookies.
jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

Yes, you're right, the way I described the three approaches to cookie preferences is not the same way they are laid out on the screen.

I think you have a viable approach now, and the one thing you might add is to use the CM "View Cookies" or "Third Party Cookies" menu to delete the cookies that were already set (if any).

Yes, you're right, the way I described the three approaches to cookie preferences is not the same way they are laid out on the screen. I think you have a viable approach now, and the one thing you might add is to use the CM "View Cookies" or "Third Party Cookies" menu to delete the cookies that were already set (if any).

Question owner

Thanks! I discovered a cookie that keeps coming back. I used view cookies and it took me to FF preferences show cookie list. It's there, but I can't figure out how to block it using cookie monster. The cookie is listed as "zag.com." I suspect its probably a tracking cookie from one of the websites I'm on right now. I'm attaching a screen shot so you can see the info.

Any suggestions as to how I can permanently get rid of it. I've tried manually blocking it in the exceptions, but it doesn't save it.

Thanks again.

Thanks! I discovered a cookie that keeps coming back. I used view cookies and it took me to FF preferences show cookie list. It's there, but I can't figure out how to block it using cookie monster. The cookie is listed as "zag.com." I suspect its probably a tracking cookie from one of the websites I'm on right now. I'm attaching a screen shot so you can see the info. Any suggestions as to how I can permanently get rid of it. I've tried manually blocking it in the exceptions, but it doesn't save it. Thanks again.
jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

Chosen Solution

Hmm, if zag is being used by the current site, it should show on CM's third party cookies. If it's from a different site, you might find it fastest to enter it manually on the Preferences page, Privacy panel, using the Exceptions button to the right of the cookie settings.

When I type zag.com and click block, Firefox adds http://zag.com to the list. I guess https://zag.com would need to be entered manually? Not very convenient.

Hmm, if zag is being used by the current site, it should show on CM's third party cookies. If it's from a different site, you might find it fastest to enter it manually on the Preferences page, Privacy panel, using the Exceptions button to the right of the cookie settings. When I type zag.com and click block, Firefox adds http://zag.com to the list. I guess https://zag.com would need to be entered manually? Not very convenient.

Question owner

I typed them as you suggested. This is bizarre. Of the four I tried (your two and the two I tried earlier, www.zag.com and zag.com), it only took them when I typed the full address. It always automatically adds the http:// and https:// w/o me having to type it. I went back and tested with a website that I allow and took it out, then added it w/o the http, etc. and it took it. hmmmmmm

I'll keep an eye on it and see if it comes back.

Thanks again for all of your help.

I typed them as you suggested. This is bizarre. Of the four I tried (your two and the two I tried earlier, www.zag.com and zag.com), it only took them when I typed the full address. It always automatically adds the http:// and https:// w/o me having to type it. I went back and tested with a website that I allow and took it out, then added it w/o the http, etc. and it took it. hmmmmmm I'll keep an eye on it and see if it comes back. Thanks again for all of your help.

Modified by CallyCat

Question owner

Well, "zag.com" is back in my cookies and no matter what I do, my exceptions will not accept "zag.com." The exceptions list has http://zag.com and https://zag.com. They are both set to "block." Yet, "zag.com" keeps showing up.  :-(

I wonder why FF won't accept me blocking "zag.com."

Well, "zag.com" is back in my cookies and no matter what I do, my exceptions will not accept "zag.com." The exceptions list has http://zag.com and https://zag.com. They are both set to "block." Yet, "zag.com" keeps showing up. :-( I wonder why FF won't accept me blocking "zag.com."
jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

Do you have any add-ons that access that address? Maybe add-ons can bypass the rules for web pages.

Do you have any add-ons that access that address? Maybe add-ons can bypass the rules for web pages.
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 solutions 40083 answers

removed the "Solved" tag for this thread

''removed the "Solved" tag for this thread''

Question owner

I don't know if I have any add-ons that use this. How can I tell?

The only one I've recently added is CM and that was after the zag.com showed up.

This all started after I updated to FF45. All of my add-ons except CM were pre v.45.

I don't know if I have any add-ons that use this. How can I tell? The only one I've recently added is CM and that was after the zag.com showed up. This all started after I updated to FF45. All of my add-ons except CM were pre v.45.
jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

Tough question to answer.

zag.com seems to be a site formerly used by TrueCar, and old addresses redirect to the new site: https://www.google.com/search?q=site%3Azag.com&ie=utf-8&oe=utf-8

Why would any add-on care about car discounts??

Tough question to answer. zag.com seems to be a site formerly used by TrueCar, and old addresses redirect to the new site: https://www.google.com/search?q=site%3Azag.com&ie=utf-8&oe=utf-8 Why would any add-on care about car discounts??

Question owner

I did a little more detective work and discovered what I think is the source. It's probably not going to give me a way to block it but at least I now know what it is.

My ins. co. has partnered with another company to provide a car buying service. And, apparently, even tho I have not ever gone to the car buying website until today, the ins. co. allows the partner company to drop cookies even when we don't go on their site.

When clicking on the car buying service, there is no mention of "zag" on the website except in the address It's all presented under the heading of my ins. co. Once I clicked on the car buying service website, I then looked at my cookies and found it loaded a bunch of other cookies that had my ins. co. and "zag" as part of the cookie name.

As a test, I've manually blocked all of the the ones that have "zag" in the cookie name. I then cleared all of the ins. co. & zag cookies. I'll wait a couple of days, during which time I will not go on their website. Then I'll check to see what cookies show up.

Will let you know what I find.

Thank you for all of your help!

I did a little more detective work and discovered what I think is the source. It's probably not going to give me a way to block it but at least I now know what it is. My ins. co. has partnered with another company to provide a car buying service. And, apparently, even tho I have not ever gone to the car buying website until today, the ins. co. allows the partner company to drop cookies even when we don't go on their site. When clicking on the car buying service, there is no mention of "zag" on the website except in the address It's all presented under the heading of my ins. co. Once I clicked on the car buying service website, I then looked at my cookies and found it loaded a bunch of other cookies that had my ins. co. and "zag" as part of the cookie name. As a test, I've manually blocked all of the the ones that have "zag" in the cookie name. I then cleared all of the ins. co. & zag cookies. I'll wait a couple of days, during which time I will not go on their website. Then I'll check to see what cookies show up. Will let you know what I find. Thank you for all of your help!

Question owner

I signed in to my insurance company's website today. And no zag cookies! Also, all the the zag cookies that I manually entered into the exceptions list are still there. So, it appears that the problem is solved.  :-)

Thanks again for all of your help.

I signed in to my insurance company's website today. And no zag cookies! Also, all the the zag cookies that I manually entered into the exceptions list are still there. So, it appears that the problem is solved. :-) Thanks again for all of your help.