X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

For the last 3days: 1) It takes a long time to star Firefox. 2) It takes a LONG time for pages to load. Internet connection is OK. MS Edge works fine. Help!

Posted

1) It takes a long time to star Firefox. 2) It takes a LONG time for pages to load. Internet connection is OK, and MS Edge works fine. But I really prefer Firefox!

I have the latest version of Firefox (46). It even takes a long time to change between open tabs. It just started behaving like this about 3 days ago (around April 29, 2016). I believe I downloaded the new version of Firefox around that time?

Please help. Thank you!

1) It takes a long time to star Firefox. 2) It takes a LONG time for pages to load. Internet connection is OK, and MS Edge works fine. But I really prefer Firefox! I have the latest version of Firefox (46). It even takes a long time to change between open tabs. It just started behaving like this about 3 days ago (around April 29, 2016). I believe I downloaded the new version of Firefox around that time? Please help. Thank you!

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • GEPlugin
  • Google Update
  • Next Generation Java Plug-in 11.73.2 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

More Information

Moses
  • Moderator
459 solutions 3608 answers

Please create only one thread per support issue. Please continue at copy https://support.mozilla.org/questions/1121095.

This thread will now be closed.

Please create only one thread per support issue. Please continue at copy https://support.mozilla.org/questions/1121095. This thread will now be closed.