X
Tap here to go to the mobile version of the site.

Support Forum

Firefox starts, but Firefox window doesn't open.

Posted

OS -Windows 7 SP1 x64 Ultimate. I have a last updated Firefox 45.0.2, installed over 2 years, with a very old profile (more than 2 years) and many extensions. Yesterday I tried to clean reinstall Firefox for better performance: saved all my extensions settings, Firefox settings and bookmarks, copied all profile folder, deleted Firefox with registry and folder cleaning and installed it again, but got a problem. After installing fresh Firefox 45.0.2 with default profile it starts only one time,the next launches are: Firefox starts in processes, but Firefox window doesn't appear. Tried to start Firefox in Safe Mode - no results: it starts in processes, but no window. Found that: when I copy my old profile folder to the fresh Firefox, it starts normally, So, I found that Firefox doesn't starts only after fresh install with a default profile. How can I solve this problem? Maybe some parameters in fresh Firefox prevent it to start normally. Need a technical help. Thanks.

OS -Windows 7 SP1 x64 Ultimate. I have a last updated Firefox 45.0.2, installed over 2 years, with a very old profile (more than 2 years) and many extensions. Yesterday I tried to clean reinstall Firefox for better performance: saved all my extensions settings, Firefox settings and bookmarks, copied all profile folder, deleted Firefox with registry and folder cleaning and installed it again, but got a problem. After installing fresh Firefox 45.0.2 with default profile it starts only one time,the next launches are: Firefox starts in processes, but Firefox window doesn't appear. Tried to start Firefox in Safe Mode - no results: it starts in processes, but no window. Found that: when I copy my old profile folder to the fresh Firefox, it starts normally, So, I found that Firefox doesn't starts only after fresh install with a default profile. How can I solve this problem? Maybe some parameters in fresh Firefox prevent it to start normally. Need a technical help. Thanks.

Chosen solution

I found a source of my problem: it's a conflict between Firefox and Actual Window Manager, even when I added Firefox window to exclusion list in AWM. I don't know why it does.

Also I found that Tab Groups extension (official Firefox Groups function replacement) slows the Firefox VERY!!! (After clean reinstall Firefox I installed Tab Groups again). It loses my RAM (memory consumption jumps over 2 GB per 150 links in Tab Groups from 500 MB without it). And Firefox with Tab Groups enabled closes very slow (window closes immedietly , but process is hanging over a 15-45 sec and only than closes). I wonder, why it does, because Tab Groups - it's only a links, not whole pages....This extension needs optimization VERY. Thanks for help and support.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 21.0 r0
  • 5.1.40416.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0

More Information

JoshNiesler 0 solutions 18 answers

Hello poddex,

Welcome and thanks for your post!

This is a strange issue. But don't worry, we'll get Firefox working again in no time! Could you try;

  1. Uninstall Firefox via Windows Control Panel
  2. Restart computer
  3. Install Firefox from www.firefox.com www.firefox.com

Let me know how you go :)

Best, Josh.

Hello poddex, Welcome and thanks for your post! This is a strange issue. But don't worry, we'll get Firefox working again in no time! Could you try; # Uninstall Firefox via Windows Control Panel # Restart computer # Install Firefox from [http://www.firefox.com www.firefox.com] www.firefox.com Let me know how you go :) Best, Josh.

Question owner

I also tried clean install with the OS restarts: uninstalled Firefox, cleaned folders and regs, restarted, installed Firefox, restarted, first run normal, but next launches are the same: process starts, but no window. Just when I copied old profile folder to a fresh Firefox, it starts normally without any OS restarts.

I also tried clean install with the OS restarts: uninstalled Firefox, cleaned folders and regs, restarted, installed Firefox, restarted, first run normal, but next launches are the same: process starts, but no window. Just when I copied old profile folder to a fresh Firefox, it starts normally without any OS restarts.
JoshNiesler 0 solutions 18 answers

Hmm. Very strange. It might because you modified the registry.

Could you try installing Firefox Beta and see if it runs normally?

Thanks!

Hmm. Very strange. It might because you modified the registry. Could you try installing [https://www.mozilla.org/en-US/firefox/channel/ Firefox Beta] and see if it runs normally? Thanks!

Question owner

Ok, wait, please, for some minutes.

Ok, wait, please, for some minutes.

Question owner

It works! Beta works and launches fine, again and again. But how can I solve the problem with Stub Firefox? Do you have any idea?

It works! Beta works and launches fine, again and again. But how can I solve the problem with Stub Firefox? Do you have any idea?
JoshNiesler 0 solutions 18 answers

That's awesome. If you like, you can continue to use BETA.

Or... you can continue to try and troubleshoot Stable :)

  1. Visit C:\Users\AppData\Mozilla and delete the "Firefox" folder
  2. Visit C:\Program Files (86x)\Mozilla and delete the "Firefox" folder
  3. Restart your PC
  4. Install Firefox from www.firefox.com

Let me know if this helps!

That's awesome. If you like, you can continue to use BETA. Or... you can continue to try and troubleshoot Stable :) # Visit C:\Users\AppData\Mozilla and delete the "Firefox" folder # Visit C:\Program Files (86x)\Mozilla and delete the "Firefox" folder # Restart your PC # Install Firefox from www.firefox.com Let me know if this helps!

Question owner

Ok, wanna to use stable, just wait for some minutes, I'll try your solve.

Ok, wanna to use stable, just wait for some minutes, I'll try your solve.

Question owner

( After trying your solve got the same problem. Firefox starts, but no window. Stable Firefox can't works normally.

What should I do?

:( After trying your solve got the same problem. Firefox starts, but no window. Stable Firefox can't works normally. What should I do?

Question owner

Hmmm, I'll try to copy default profile from BETA Firefox to Stable Firefox and see how it works. Wait a minute.

Hmmm, I'll try to copy default profile from BETA Firefox to Stable Firefox and see how it works. Wait a minute.

Question owner

=( After trying several times, still have a problem with stable 45.0.2 Firefox. Uninstall BETA clearly, then install Firefox 45.0.2 Stable, first normal run and, next launches - no window. When I copied default profile from BETA Firefox to Stable Firefox, Stable Firefox runs only one time after copy, but next launches are the same - no window. Trying reinstall BETA - all works fine. What shouild I do to find the solution? Maybe, it's an unknown bug?

=( After trying several times, still have a problem with stable 45.0.2 Firefox. Uninstall BETA clearly, then install Firefox 45.0.2 Stable, first normal run and, next launches - no window. When I copied default profile from BETA Firefox to Stable Firefox, Stable Firefox runs only one time after copy, but next launches are the same - no window. Trying reinstall BETA - all works fine. What shouild I do to find the solution? Maybe, it's an unknown bug?
JoshNiesler 0 solutions 18 answers

I'm not sure...

I'm labeling this thread "escalate", so we should be able to get some more support :)

I'm not sure... I'm labeling this thread "escalate", so we should be able to get some more support :)

Question owner

Ok, I'll be waiting for help, while waiting, I will use my "old" profile :) Thanks for your help :)

Ok, I'll be waiting for help, while waiting, I will use my "old" profile :) Thanks for your help :)
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158017 answers

Did you use the Profile Manager to create a new profile?

Did you recover any files from the old profile?

Try to start Firefox in Safe Mode to see if that works.

  • Windows: hold down the Shift key while starting Firefox
  • Mac: hold down the Options key while starting Firefox

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Did you use the Profile Manager to create a new profile? Did you recover any files from the old profile? Try to start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to see if that works. *Windows: hold down the Shift key while starting Firefox *Mac: hold down the Options key while starting Firefox You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

A have an old Firefox, which was updating over 2 years. But my old profile became dirty,Firefox slows and I decided to clean reinstall Firefox for a better performance. Note: Firefox with my old profile starts normally (slow, but stable). Last update of my old Firefox was 45.0.2 I reinstalled Firefox, but clean Firefox doesn't start: I see Firefox process, but there is no Firefox window and no error message, Clean Firefox runs only ONE time after install, but next times a the same as I described above: process starts, but no Firefox window. I can't run clean Firefox until new reinstall. When I put my old profile folder to the Firefox (instead it default profile), Firefox starts slow, as my old Firefox before reinstall, but starts normally, Firefox window appears normally. I tried reinstall Firefox several times, but no results. I tried to install Firefox BETA, and it works and starts normally with it clean profile after install. But stable Firefox doesn't start. Stable Firefox start only when I copied my old profile to it (copy the profile folder). So, there is no problem with graphics driver because Firefox starts normally with my old profile. I will try to load clean Firefox in safe mode and will post an answer a little later.

A have an old Firefox, which was updating over 2 years. But my old profile became dirty,Firefox slows and I decided to clean reinstall Firefox for a better performance. Note: Firefox with my old profile starts normally (slow, but stable). Last update of my old Firefox was 45.0.2 I reinstalled Firefox, but clean Firefox doesn't start: I see Firefox process, but there is no Firefox window and no error message, Clean Firefox runs only ONE time after install, but next times a the same as I described above: process starts, but no Firefox window. I can't run clean Firefox until new reinstall. When I put my old profile folder to the Firefox (instead it default profile), Firefox starts slow, as my old Firefox before reinstall, but starts normally, Firefox window appears normally. I tried reinstall Firefox several times, but no results. I tried to install Firefox BETA, and it works and starts normally with it clean profile after install. But stable Firefox doesn't start. Stable Firefox start only when I copied my old profile to it (copy the profile folder). So, there is no problem with graphics driver because Firefox starts normally with my old profile. I will try to load clean Firefox in safe mode and will post an answer a little later.

Question owner

I tried to start Firefox in Safe Mode after new clean reinstall, but result is te same: Firefox process starts, but there is NO Firefox window. I think, that my problem with Stable Firefox is much deeper than just a problem of install/reinstall of the Firefox app. I remind that my Stable Firefox runs stable with my "old" dirty profile and doesn't run normally with clean profile after clean reinstall. Also Firefox BETA runs stable after it clean install. Need for additional support! Thanks.

I tried to start Firefox in Safe Mode after new clean reinstall, but result is te same: Firefox process starts, but there is NO Firefox window. I think, that my problem with Stable Firefox is much deeper than just a problem of install/reinstall of the Firefox app. I remind that my Stable Firefox runs stable with my "old" dirty profile and doesn't run normally with clean profile after clean reinstall. Also Firefox BETA runs stable after it clean install. Need for additional support! Thanks.

Question owner

So can I get a techhelp for my issue? How can I use the debugger to find the problem with Stable Firefox launching? How can I trace what Firefox need when it starts???

Found that Actual Window manager prevents Firefox to show the Firefox window. Testing again...

So can I get a techhelp for my issue? How can I use the debugger to find the problem with Stable Firefox launching? How can I trace what Firefox need when it starts??? Found that Actual Window manager prevents Firefox to show the Firefox window. Testing again...

Modified by poddex

cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158017 answers

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.


You can try to copy some files like the cert8.db file to the new profile to see what file(s) you need to get it working.

Is hardware acceleration enabled with the old profile?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 ----- You can try to copy some files like the cert8.db file to the new profile to see what file(s) you need to get it working. *https://support.mozilla.org/kb/Recovering+important+data+from+an+old+profile *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Is hardware acceleration enabled with the old profile?

Chosen Solution

I found a source of my problem: it's a conflict between Firefox and Actual Window Manager, even when I added Firefox window to exclusion list in AWM. I don't know why it does.

Also I found that Tab Groups extension (official Firefox Groups function replacement) slows the Firefox VERY!!! (After clean reinstall Firefox I installed Tab Groups again). It loses my RAM (memory consumption jumps over 2 GB per 150 links in Tab Groups from 500 MB without it). And Firefox with Tab Groups enabled closes very slow (window closes immedietly , but process is hanging over a 15-45 sec and only than closes). I wonder, why it does, because Tab Groups - it's only a links, not whole pages....This extension needs optimization VERY. Thanks for help and support.

I found a source of my problem: it's a conflict between Firefox and Actual Window Manager, even when I added Firefox window to exclusion list in AWM. I don't know why it does. Also I found that Tab Groups extension (official Firefox Groups function replacement) slows the Firefox VERY!!! (After clean reinstall Firefox I installed Tab Groups again). It loses my RAM (memory consumption jumps over 2 GB per 150 links in Tab Groups from 500 MB without it). And Firefox with Tab Groups enabled closes very slow (window closes immedietly , but process is hanging over a 15-45 sec and only than closes). I wonder, why it does, because Tab Groups - it's only a links, not whole pages....This extension needs optimization VERY. Thanks for help and support.

Modified by poddex