Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

javascript will not work with FF version 45.0.2

  • 26 replies
  • 17 have this problem
  • Last reply by haapy

more options

The site that I go to is password protected. On one of the pages I try to access, a little box opens up in the lower left corner - "javascript:;" And nothing happens. No other error messages. This page works fine with Chrome and internet Explorer, both latest versions, similar configurations. I tried all the suggestions in the community, none worked. I uninstalled Firefox with Revo with max cleaning and reinstalled. Nogo.

All Replies (20)

more options

You have to upgrade to the newest firefox

more options

I just downloaded and installed 45.0.2

Where do I get a newer version?

more options

Hi Haapy, 45.0.2 is the current version. You can't update from there.

When you say

...a little box opens up in the lower left corner - "javascript:;"

is that the destination of a link you are hovering the mouse over? Or is it more of a persistent element in the page, or a separate window?

I assume that JavaScript is enabled. If it were disabled, numerous sites would tell you that they only work (or work best) with JavaScript enabled. So perhaps something else is interfering.


  • Do you use any content filtering/blocking extensions that might be modifying the page or how Firefox interacts with the page?
  • Are you using private browsing? By default, Firefox's tracking protection feature may block some page features imported from other sites. In that case, you should see a little shield icon to the left of the address in the address bar. This article has more information on how to make a temporary exception for the site: What happened to Tracking Protection?.
more options

Remember I did a clean install, no option changes. It is the destination link that I am hovering over that gives the - a little box opens up in the lower left corner - "javascript:;". Java script is enabled. No extensions/addins. I am not using private browsing. I did get another error from SDGE and SoCal Gas indication that Javascript was not enabled. Again, password protected site, again IE and Chrome work on these sites. Javascript is not working.

Modified by haapy

more options

Hello haapy!

Could you try;

  • Resetting Firefox (Learn how to at
  • Visiting the site in a Private Window and see if the issue occurs there
  • Check if Javascript is enabled by visiting this site.

Let us know how you go! :)

Best, Josh.

Modified by JoshNiesler

more options

Hi haapy, it's puzzling that JavaScript works for you on some sites and not others. Firefox only has one JavaScript setting, on or off. There must be some other factor. Have you noticed any other unusual behaviors, any imperfections in how Firefox works with sites?

more options

Let me be clear. I tried all the suggestions. Private browsing. Reset. Uninstall, with Revo, registry clean with CCleaner, reinstall. Nothing works.

Javascript is enabled, I also checked with the suggested website and it responds YES.

I DO NOT know if Javascript is working on some websites. I DO know that it does not work on at least three where I get some form of error message from the sites. On those same 3 sites, IE and Chrome do work.

I do not notice any other strange behavior with FireFox. As a matter of fact, on the one site with the little status box in the left corner as well as the other 2 sites that I get error messages, Firefox used to work. I do not know how long ago that these stopped working as I do not access them daily, but up to this point, for well over 1-2 years FireFox was the only browser that I used. Somewhere along the line something changed and I have to believe that it was FireFox as the other browsers that I have installed work just fine.

more options

Does your system have a touchscreen? Some users have reported that sites which have implemented newer script features specific to touch interfaces may no longer allow mouse interaction with some scripted elements such as drop-down menus, while those menus now can be operated by touch. These issues have been particularly reported on HP computers/laptops, but could happen on other systems. Not sure if that could be a factor here.

more options

Yes. It is a Dell all in one. I doubt that this is a factor here. The sites that FireFox does not work on do work with IE and Chrome. Also, on these sites, I am not using touch screen, just the mouse.

Modified by haapy

more options

So if you were to try using touch operation on the sites where mouse operation doesn't work, do the problem links work with touch?

If so, you could try setting Firefox not to inform sites about your touchscreen and see whether this helps:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste touch and pause while the list is filtered

(3) If the dom.w3c_touch_events.enabled preference is not set to 0, double-click it and set it to zero

more options

I do not understand the logic here: The web sites that require javascript do not work with FireFox. The same web sites do work with IE and Chrome What does the touch screen have to do with the problem? Javascript does not work with FireFox on my PC, the same PC that javascript works on with IE and FireFox.

How many time do I have to repeat the problem?

The only new thing that I did think of is that I used to run the Ad Block Plus add-on with FireFox but did not like the interference it caused and have uninstalled it. But this uninstall occurred before I tried all the solutions mentioned above to fix the FireFox javascript problem.

more options

To back up for a second: your inability to run JavaScript is not universal, right? It's limited to a few sites. For example, do scripts work on these pages on my site:

Can you give the addresses of the non-working pages so forum volunteers can test them?

The relevance of the touchscreen is that websites can test whether your browser has touch support and change the behavior of menus and other interactive elements. The best way to test whether the site is switching those elements from mouse interaction to touch interaction is to try touching them and see whether they respond. That's not something I would be able to test myself, since I don't have a touchscreen.

Note: On HP all-in-one-systems, unfortunately users have reported they needed to disable the "HID-compliant touch screen" in Device Manager. For example: and the threads links there.

more options

Your suggested sites do work. The two sites that previously that told me that javascript was disabled now work. I can not determine what has changed.

Again, not an HP system.

Disabling the HD compliant touch screen did nothing.

The one site that does not work is a financial site, is password protected and shows the attached screen shot, scroll down, look in the lower left corner see the "javascript :;" display in the lower left corner. I apologize for the poor size. I tried the touch screen with Chrome, it works. I tried the touch screen with FireFox, it does not work.

Again, keep in mind that this web site works with IE and Chrome.

Modified by haapy

more options

Hi haapy, unfortunately I can't debug why that particular link/button is not working from an image. Firefox can display script errors in its Web Console or Browser Console if you want to try that for further comment. Either:

  • To open the Web Console, press Ctrl+Shift+k or use the Developer menu -- this usually opens in the lower part of the tab
  • To open the Browser Console, press Ctrl+Shift+j or use the Developer menu -- this opens in a separate window

If the console is cluttered, it's usually helpful to click the Clear button at the top to start fresh. Then click the non-working button and look for any new errors in the console. You should be able to select the error message to copy/paste. However, I can't promise it will make sense without seeing the site's scripts...

more options

Unfortunately, your suggestions are beyond my ability. I have attached a screen shot of the error. Seems like this is a dead end problem for me with FireFox. I will help more if I can, but it looks like I am moving on to Chrome. I need a browser that works 24/7. This web site used to work with FF and now does not. Where do you think that the problem is?

more options

Haapy, after reviewing your screenshots, this is just how this site displays in Firefox.

Some pages display 'javascript;' when they've finished loading. This isn't an error, and it doesn't affect page performance. Its completely normal.

Often you'll see messages like the ones I've mentioned below in the lower left hand corner of Firefox, as well as in Google Chrome, Internet Explorer, and all other browsers:

  1. "Waiting..."
  2. "Waiting for"
  3. "Loading..."
  4. "Loading"
  5. "Connecting..."
  6. "Connecting to"
  7. "Waiting for cache..."
  8. "Uploading (12%)..."
  9. "javascript;"
  10. ""

I'll note that you won't see the "javascript;" message in Google Chrome because Chrome hides that particular message. Its still there, you just can't see it :)

I hope this answered your question!

Modified by JoshNiesler

more options

haapy said

Unfortunately, your suggestions are beyond my ability.

To be honest, I don't think they are, but I probably have not described them well enough.

I have attached a screen shot of the error.

If I understand correctly, that is the address of the link you are hovering over, and not an error message. However, to check that, you could right-click whatever your mouse is hovering over, and choose Copy Link Location, then paste somewhere to inspect the link.

This web site used to work with FF and now does not.
Where do you think that the problem is?

Sorry, working blind like this, this is the best I can do.

I can't tell whether you already tried "the usual" because we jumped right to JavaScript, but just in case "Revo with max cleaning" doesn't do these things:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that make any difference?

The only extension obvious from your screen shot is WOT. I don't think WOT blocks content, so it probably is not creating this problem. Do you have any other extensions running? You could double-check on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions.

more options

JoshNiesler said

Some pages display 'javascript;' when they've finished loading. This isn't an error, and it doesn't affect page performance. Its completely normal.

Josh, where have you ever seen that? Usually after a page finishes loading there won't be anything in the status message area unless/until the mouse pointer moves over a link.

more options

JoshNiesler, jscher2000, First off thank you both for trying to help with this problem.

More info.

Josh - #9 is what I am getting. Yes it shows in Chrome too. It is a link and here is the code from within FF and CH

<a href="javascript:;" class="toggleLink">Show Settings</a>

I am not an HTML expert, but I opened INSPECTOR to get the above line.

The difference that I see is in FireFox, it offers a debugger character at the end of the line, chrome does not.

The web page prompt is "show settings: Click in FF, nothing. Click in chrome I get the settings. Identical in both web pages FF does not execute this properly and Chrome does.

Jscher - cleared cache, cleared cookies - no change. No other extensions.

more options

haapy said

I am not an HTML expert, but I opened INSPECTOR to get the above line.

The difference that I see is in FireFox, it offers a debugger character at the end of the line, chrome does not.

The little EV icon show you any scripts attached to events on that object, such as a click. Unfortunately, it is very common for scripts to be "minified" by changing recognizable words into random letters. This usually makes them difficult to follow, so I don't know that anyone would benefit from digging into it.

Since you already have the Inspector open... if you click Console along the top line of that panel, and then click the problem link again, does any error message appear in the console?

  1. 1
  2. 2