X
Tap here to go to the mobile version of the site.

Support Forum

Icons showing as rectangles

Posted

Version 45.0.2

On Firefox Icons are appearing as little rectangles with numbers and letters in them. I have tried:

Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

and

check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true

and

I have restarted with all add-ons disabled

None of these worked for me. Is there any other suggestions? BTW, these sites where I am getting the rectangle boxes, display correctly on Chrome. So I know it is not the sites with the problem.

Version 45.0.2 On Firefox Icons are appearing as little rectangles with numbers and letters in them. I have tried: Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" and check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true and I have restarted with all add-ons disabled None of these worked for me. Is there any other suggestions? BTW, these sites where I am getting the rectangle boxes, display correctly on Chrome. So I know it is not the sites with the problem.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Citrix Online App Detector Plugin
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 21.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

More Information

jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Hmm, it seems you have dual Intel/Nvidia graphics. I'm not sure how best to approach that, but the end goal would be to get hardware acceleration running in Firefox.

Hmm, it seems you have dual Intel/Nvidia graphics. I'm not sure how best to approach that, but the end goal would be to get hardware acceleration running in Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17583 solutions 159079 answers

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use this button to go to the current Firefox profile folder:

You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

cor-el said

You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. You can use this button to go to the current Firefox profile folder:


I did this and no luck. :( I am getting frustrated. Two days ago I reset the whole thing back to the beginning. I had to redo all my preferences and add ons. Everything was fine and the rectangles were gone. Then I turn on my computer today and it back to the little rectangles. :(

''cor-el [[#answer-867356|said]]'' <blockquote> You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox </blockquote> I did this and no luck. :( I am getting frustrated. Two days ago I reset the whole thing back to the beginning. I had to redo all my preferences and add ons. Everything was fine and the rectangles were gone. Then I turn on my computer today and it back to the little rectangles. :(
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Oh... I wish we had been able to check the support page Graphics section during that time to see whether it shows anything different.

Could you check some of the other font settings in about:config:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste font_ and pause while the list is filtered

(3) Are any of the preferences indicating other than "default" for their status?

(4) Could you try forcing acceleration by double-clicking the gfx.font_rendering.directwrite.force-enabled preference to switch it from false to true

That change might not take effect until you exit Firefox and start it up again. If Firefox becomes unstable, you may need to start it up in Firefox's Safe Mode to undo that change.

Oh... I wish we had been able to check the support page Graphics section during that time to see whether it shows anything different. Could you check some of the other font settings in about:config: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''font_''' and pause while the list is filtered (3) Are any of the preferences indicating other than "default" for their status? (4) Could you try forcing acceleration by double-clicking the '''gfx.font_rendering.directwrite.force-enabled''' preference to switch it from false to true That change might not take effect until you exit Firefox and start it up again. If Firefox becomes unstable, you may need to start it up in Firefox's Safe Mode to undo that change.
cor-el
  • Top 10 Contributor
  • Moderator
17583 solutions 159079 answers

Current releases usually create a lot of gfx.crash-guard.* prefs if any graphics issues are detected.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.

Current releases usually create a lot of gfx.crash-guard.* prefs if any graphics issues are detected. Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

Question owner

jscher2000 said

Oh... I wish we had been able to check the support page Graphics section during that time to see whether it shows anything different. Could you check some of the other font settings in about:config: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste font_ and pause while the list is filtered (3) Are any of the preferences indicating other than "default" for their status? (4) Could you try forcing acceleration by double-clicking the gfx.font_rendering.directwrite.force-enabled preference to switch it from false to true That change might not take effect until you exit Firefox and start it up again. If Firefox becomes unstable, you may need to start it up in Firefox's Safe Mode to undo that change.

Everything was set to default.

I set the gfx.font_rendering.directwrite.force-enabled preference to switch it from false to true

I restarted and it did not fix the problem.

''jscher2000 [[#answer-867683|said]]'' <blockquote> Oh... I wish we had been able to check the support page Graphics section during that time to see whether it shows anything different. Could you check some of the other font settings in about:config: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''font_''' and pause while the list is filtered (3) Are any of the preferences indicating other than "default" for their status? (4) Could you try forcing acceleration by double-clicking the '''gfx.font_rendering.directwrite.force-enabled''' preference to switch it from false to true That change might not take effect until you exit Firefox and start it up again. If Firefox becomes unstable, you may need to start it up in Firefox's Safe Mode to undo that change. </blockquote> Everything was set to default. I set the '''gfx.font_rendering.directwrite.force-enabled''' preference to switch it from false to true I restarted and it did not fix the problem.

Question owner

cor-el said

Current releases usually create a lot of gfx.crash-guard.* prefs if any graphics issues are detected. Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.

I did this and I see no change :(

''cor-el [[#answer-867706|said]]'' <blockquote> Current releases usually create a lot of gfx.crash-guard.* prefs if any graphics issues are detected. Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 </blockquote> I did this and I see no change :(

Question owner

Are we out of ideas and I have to stay this way? :(

Are we out of ideas and I have to stay this way? :(
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

As I said much earlier, I don't understand how dual graphics systems work. I suspect Firefox is having a problem with some differences between Intel and Nvidia, but I don't have any new suggestions. Other than disabling one of your graphics adapters, but I don't know what consequences that would have for other programs.

As I said much earlier, I don't understand how dual graphics systems work. I suspect Firefox is having a problem with some differences between Intel and Nvidia, but I don't have any new suggestions. Other than disabling one of your graphics adapters, but I don't know what consequences that would have for other programs.

Question owner

The dual graphics is because I have a gaming computer with memory dedicated strictly for high graphic games. I cannot disable this because I need it for work.

Thanks for you help anyway. I appreciate everything you tried.

The dual graphics is because I have a gaming computer with memory dedicated strictly for high graphic games. I cannot disable this because I need it for work. Thanks for you help anyway. I appreciate everything you tried.