Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't remove url from firefox

  • 3 replies
  • 2 have this problem
  • 287 views
  • Last reply by cor-el

more options

I want to go to the following website:

https://finance.yahoo.com/q/h?s=T+Headlines

I can paste that URL into IE or Chrome with no problems. However, whenever I paste that URL into Firefox , it's always changed to:

https://beta.finance.yahoo.com/quote/T

I've tried clear the Cache ,started in Safe Mode and Cleared History but that hasn't helped.

How can I force Firefox to take me to https://finance.yahoo.com/q/h?s=T+Headlines  ?

Chosen solution

Hmm, beta test site.

When you used Clear History, did you delete your cookies? Sometimes websites randomly enroll users in "experiments" that are difficult to escape until you clear cookies for the site. To do that only for Yahoo, you can use this method:

While viewing a page on the site, try either:

  • right-click a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, you can remove the site's cookies individually.

Then try loading the normal URL. Any improvement?

If that doesn't make any difference, do you have Firefox log you into Yahoo automatically? In that case, maybe it's some setting in your account.

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Hmm, beta test site.

When you used Clear History, did you delete your cookies? Sometimes websites randomly enroll users in "experiments" that are difficult to escape until you clear cookies for the site. To do that only for Yahoo, you can use this method:

While viewing a page on the site, try either:

  • right-click a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, you can remove the site's cookies individually.

Then try loading the normal URL. Any improvement?

If that doesn't make any difference, do you have Firefox log you into Yahoo automatically? In that case, maybe it's some setting in your account.

more options

Also, your Firefox identified itself to the forum as version 41. Is that correct?

Version 41 is not secure; Mozilla discloses security flaws after each new release. Is something holding you back from upgrading to Firefox 45? Please let us know so we can suggest solutions or workarounds. Or you can update now using the steps in this article: Update Firefox to the latest release.

If Help > About Firefox shows Firefox 45.0.2, you may need to clear the preference that is misreporting your version number. See: Websites say that Firefox is outdated or incompatible even though it's the latest version.

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History").

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.