X
Tap here to go to the mobile version of the site.

Support Forum

When Firefox loads it also loads www.twoo.com. How to STOP?

Posted

This site "www.twoo.com" loads every time Firefox starts. I have tried every way possible to block twoo to no avail. Why is Firefox letting this site load?

This site "www.twoo.com" loads every time Firefox starts. I have tried every way possible to block twoo to no avail. Why is Firefox letting this site load?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Version 5.41.3.0
  • Google Update
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Picasa plugin
  • Shockwave Flash 21.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

More Information

jscher2000
  • Top 10 Contributor
8762 solutions 71700 answers

Three common explanations:

(1) It is saved as a second "home tab." If the page also loads when you launch a new window (Ctrl+n) or click the Home button, you can update your home page setting. More detail on that below.

(2) It is added to your desktop shortcut or pinned taskbar icon. If the problem happens only when you use one of those, you can check for a hijacked shortcut. More detail on that below.

(3) You may have a bad add-on. As a test, you can start Firefox in its Safe Mode, which disables extensions, the most common kind of add-on responsible for opening pages. Again, more on that below.

For #1:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste home and pause while the list is filtered

(3) Double-click the browser.startup.homepage preference and edit out the unwanted domain, and the vertical bar separator. I suggest deleting the bar last so things don't accidentally get mushed together.

For #2:

This is based on how Windows 7 works, but hopefully Windows 10 is similar. Either:

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

The Target line should not have anything after this part:

  • 32-bit Firefox on 64-bit Windows: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
  • Otherwise: "C:\Program Files\Mozilla Firefox\firefox.exe"

If anything is listed after that, clear it out and save your change. To test, you can either:

  • Desktop shortcut: double-click the icon to launch a new window
  • Pinned taskbar icon: right-click the icon, click Mozilla Firefox to launch a new window

If you get your home page, it worked.

For #3:

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Three common explanations: (1) It is saved as a second "home tab." If the page also loads when you launch a new window (Ctrl+n) or click the Home button, you can update your home page setting. More detail on that below. (2) It is added to your desktop shortcut or pinned taskbar icon. If the problem happens only when you use one of those, you can check for a hijacked shortcut. More detail on that below. (3) You may have a bad add-on. As a test, you can start Firefox in its Safe Mode, which disables extensions, the most common kind of add-on responsible for opening pages. Again, more on that below. '''For #1:''' (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''home''' and pause while the list is filtered (3) Double-click the '''browser.startup.homepage''' preference and edit out the unwanted domain, and the vertical bar separator. I suggest deleting the bar last so things don't accidentally get mushed together. '''For #2:''' ''This is based on how Windows 7 works, but hopefully Windows 10 is similar.'' Either: * Desktop shortcut: right-click the icon, choose Properties * Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab. The Target line should not have anything after this part: * ''32-bit Firefox on 64-bit Windows:'' "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" * ''Otherwise:'' "C:\Program Files\Mozilla Firefox\firefox.exe" If anything is listed after that, clear it out and save your change. To test, you can either: * Desktop shortcut: double-click the icon to launch a new window * Pinned taskbar icon: right-click the icon, click Mozilla Firefox to launch a new window If you get your home page, it worked. '''For #3:''' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?