Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

SAYS SITES ARE UNSECURE WON'T LET ME CONNECT

  • 8 replies
  • 9 have this problem
  • 98 views
  • Last reply by ratpacker

more options

SUDDENLY all sorts of websites I try to connect to say the site is not secure. Even ones I know are secure such as my bank.

Sometimes it "LETS ME" add an exception and sometimes I just can't connect and it is really really really annoying that my browsing is constantly interfered with.

How do I fix this problem. There is no way 5 sites a day or more are unsecure.

All Replies (8)

more options

There is security software like Avast and Kaspersky and BitDefender and ESET that intercepts secure connections and sends their own certificate or that incorporates special web shielding features that can block content.

You can retrieve the certificate and check details like the issuer of the certificate and the certificate chain.

  • click "Advanced" to expand the error message
  • click "Add Exception" to open "Add Security Exception"

If this isn't possible then open "Add Security Exception" by pasting this URL in the location/address bar and paste the URL of the website (https://xxx.xxx) in it's location field.

  • chrome://pippki/content/exceptionDialog.xul

Let Firefox retrieve the certificate -> "Get Certificate"

  • click the "View" button and inspect the certificate

You can see details like the issuer of the certificate and intermediate certificates that are used in the Details tab.

Who is the issuer of the certificate?

more options

If you have an "Old Firefox Data" folder on the desktop then you can try to copy the cert8.db file from that folder to the current profile folder.

You can use this button to go to the current Firefox profile folder:

more options

I don't always have the option to Add Security Exception - sometimes I can and sometimes I can't so that doesn't solve anything.

more options

Can I just delete Firefox and reinstall it I don't have time for looking for old profile - I don't understand how to do that

more options

I don't have an Old Firefox Folder on my desktop.

more options

Did you check the issuer of the certificate by using the above posted Chrome URL to open "Add Security Exception" via the location/address bar?

  • chrome://pippki/content/exceptionDialog.xul

Firefox uses the "chrome://" protocol to access its own internal files and also access files from extensions (no relation with Google Chrome).

more options

Hi KC, uninstalling/reinstalling is not likely to help.

Note that you should NEVER need to add an exception for a well-run website, so it's important to sort out why your Firefox thinks the site certificates are invalid.

When you get untrusted connection errors for pretty much all secure sites, the problem usually is one of the following:

(1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem.

(2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, Bullguard, ESET, and Kaspersky; AVG LinkScanner / SurfShield can cause this error on search sites.

(3) On Windows 10 (and for some users Windows 8.1), Firefox not being set up to work with the parental control software Microsoft Family Safety. (To test by turning it off, see: http://windows.microsoft.com/en-us/wi.../turn-off-microsoft-family-settings)

(4) Malware on your system intercepting secure connections.

If you have any of those specific security products:

That would be the first thing to check. This support article will walk you through it: How to troubleshoot security error codes on secure websites.

If none of those ring a bell:

You could inspect a sample certificate to see whether that points to the culprit. If you want to try that now, here's how I suggest starting:

Load my test page at: https://jeffersonscher.com/res/jstest.php

You likely will get an error page. Expand the "Advanced" button and look for an Add Exception button.

Note: You don't need to complete the process of adding an exception -- I suggest not adding one until we know this isn't a malware issue -- but you can use the dialog to view the information that makes Firefox suspicious.

Click Add Exception, and the certificate exception dialog should open.

Click the View button. If View is not enabled, try the Get Certificate button first.

This should pop up the Certificate Viewer. Look at the "Issued by" section, and on the Details tab, the Certificate Hierarchy. What do you see there? I have attached a screen shot for comparison.

more options

jscher2000: I tried to copy an old version of cert8.db to my profile but that changed nothing.

That last solution where you mention "You likely will get an error page. Expand the "Advanced" button and look for an Add Exception button." and then look at the certificates was the most helpful. I looked at the list and my yahoo mail bookmark that I used was not on the list. So I Googled Yahoo, clicked on mail, and a new URL came up (only the very last part of the URL was different). I clicked on that new URL and could login and see my mail. Yahoo might have changed the format of the last part of its URL (it uses a random number generator, but there is a difference in the code just before that number). That URL is not listed in the list of accepted certifications, however, but Firefox allowed it to open. So the question may be settled now, but not tomorrow or one hour from now.