Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have google.com set as my home page but whenever click my home page icon or type google.com in the address field, facebook.com comes on, not google.

  • 4 replies
  • 2 have this problem
  • 36 views
  • Last reply by FredMcD

more options

I can't get to google.com, facebook.com comes up instead. What's wrong?

Chosen solution

Could you try the full secure address:

https://www.google.com/

Does that work?

Also, what is your default search engine set to? If you search from in the address bar, the results should load in your default search engine, so one way to test is to put a couple words there and press Enter and see what site shows up.

Read this answer in context 👍 0

All Replies (4)

more options

Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.


If the above does not work, https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Adobe Shockwave for Director Netscape plug-in, version 12.2.4.194 Adobe Shockwave for Director Netscape plug-in, version 12.1.4.154 5

more options

I tried the add-on and it did work. It reset my home page back to the original mozilla firefox start page. But, when I went to set it back to Google it went to facebook again and when I tried putting googlle.com in URL field of the browser it again goes to facebooke.com.

Please help. Thanks

more options

Chosen Solution

Could you try the full secure address:

https://www.google.com/

Does that work?

Also, what is your default search engine set to? If you search from in the address bar, the results should load in your default search engine, so one way to test is to put a couple words there and press Enter and see what site shows up.

more options

FredMcD said

Adobe Shockwave for Director Netscape plug-in, version 12.2.4.194
Adobe Shockwave for Director Netscape plug-in, version 12.1.4.1545

Forgot to add,
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Shockwave Director: Shockwave Standalone Installer / Uninstaller{web link} Shockwave Director Version Version 12.2.3.183 http://get.adobe.com/shockwave/