Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How Do I Stop Bookmarks Toolbar from Starting Each Time I Start FireFox

  • 13 replies
  • 1 has this problem
  • 34 views
  • Last reply by John99

more options

Hello All,

I am having a very aggravating problem with Firefox. It is the latest version that has been updated and only has the AdBlock add on installed. Each time I start Firefox the Bookmarks Toolbar appears at the top under the browsing tabs.

I have tried unchecking the box in the "VIEW" menu, that doesn't work. I have tried clicking the 3 horizontal black lines in the right corner and customizing where I click the "Show/Hide Toolbars" and that doesn't work. I have just done the REFRESH of FireFox and that didn't work. I checked and I DO NOT have a USER PROFILE so there is nothing there to change. I have Googled it and went thru 5 or 6 pages of results and tried any of them that looked promising only to see that no matter what I do, the BOOKMARKS TOOLBAR is still showing up in it's usual place.

This is really annoying. I am on a laptop and I don't have the screen real estate to spare. If I had a HUGE desktop monitor, I wouldn't care, but I don't. I can't believe that this is such a problem. Something this simple should be something that can be taken care of with ease, but it is proving far different than that.

Can anyone out there help me out? Surely there are more users than me that are irritated by this problem. Hopefully someone can chime in and tell me how to stop this toolbar from appearing any more.

PLEASE....help if you can.

Thank you for your time and any help you can give me.

All Replies (13)

more options

Firefox creates a user profile for each user on the computer. The profile stores everything like settings, passwords, history . . . . . .

You may have a corrupt xulstore.json file.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the xulstore.json file. Then rename or delete it. Restart Firefox.

more options

Nalajr said

Each time I start Firefox the Bookmarks Toolbar appears at the top under the browsing tabs.

Normally the Bookmarks Toolbar appears below the address bar, between the address bar and the page. Is that where it appears?

Are you able to close the Bookmarks Toolbar during your session, but it comes back at the next startup, or can you never close it?

Modified by jscher2000

more options

I misspoke. It is UNDER the web address bar, where it's supposed to be.

Yes, I am able to close it each and every time while I use it, but when I close Firefox and then re-open it, no matter what I do, it comes right back.

FredMcD, thank you for your help. I'll try it here in a little bit when my company leaves and I have some quiet time.

Will post the results.

more options

NO CHANGE!

Deleted my profile and restarted and the BOOKMARKS Toolbar was still there.

I went thru and told it to hide it again, and then restarted it, no change.

Is there any frigging way to get rid of this damned Bookmarks toolbar?

This is really irritating.

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

What do you mean with "Deleted my profile"?

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use this button to go to the current Firefox profile folder:


There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

This is a band new system, a Toshiba laptop, and I don't even know what Advanced System Care is.

I don't think that's the reason. I like the MENU BAR displayed at all times and I turned it on right after install and it still shows. At the same time I turned OFF the Bookmarks Toolbar and it still remains despite all these efforts to get rid of it.

So why would 1 change stay in effect and the other not? They are both toolbars, turned on and off the exact same way, yet one refuses to behave like the other.

more options

There is NO User.js file

I don't know what you are talking about when you start your reply with "Deleted my profile"

I DO NOT have a User.js file on my system.

more options

Type about:customizing<enter> in the address bar. Look for Show / Hide Toolbars at the bottom left.

There is also a Restore Defaults button at the bottom middle.

more options

Hi Nalajr, you're right, this --

I like the MENU BAR displayed at all times and I turned it on right after install and it still shows. At the same time I turned OFF the Bookmarks Toolbar and it still remains despite all these efforts to get rid of it.

So why would 1 change stay in effect and the other not? They are both toolbars, turned on and off the exact same way, yet one refuses to behave like the other.

-- is not logical. Your on/off preference for both toolbars is stored in the same file (xulstore.json, mentioned before), which I believe you removed so Firefox should have defaulted back to not showing either until you changed the setting.

Are there any other buttons or controls on the Bookmarks Toolbar other than bookmarks? In Customize mode, the bookmarks are consolidated into a single item called Bookmarks Toolbar Items. Is there anything else on the bar? (Customize Firefox controls, buttons and toolbars)

more options

Have you tried using your bookmarks, are you for instance able to add new bookmarks and see them once you restart Firefox ?

You say

 ... It is the latest version that has been updated ... 

However the forum seems to list it as version 42. Please check to see what version you re using ? If necessary allow it to update, restart and check again. Use

Menu {thee bar icon) -> Help { (?) icon)  -> About Firefox

See

Is there any possibility your Firefox profile is locked, or is being recreated, by say, some third party security or backup software.

more options

FredMcD,

I've tried turning it off using that method you list, although I don't type in the commands into the web address bar like you listed. I get to it in the other way, with the 3 horizontal bars, then CUSTOMIZE. It hasn't worked in the past when I tried it that way. I just tried it your way and will see what happens when I restart it. I have several windows open now and am busy, so it'll be a bit before I can start FF over and see the results.

jscher2000, whether logical or not, that's exactly what is going on. Right after I instal Firefox, no matter what machine it's on or what version, I ALWAYS turn the MENU BAR to ON. The checkmark is ALWAYS next to it meaning I WANT it displayed at all times. I like it that way.

If you look in the VIEW submenu for TOOLBARS there is a check next to MENU BAR and a BLANK space next to BOOKMARKS TOOLBAR, because I just done what McD told me to do to see what happens. In EVERY other instance that I have tried to resolve this, the check mark remains next to MENU BAR and it remains visible, but despite me removing the check from the BOOKMARKS TOOLBAR, upon restart it will be right back there just like I never touched it.

That's what I am saying. Why will the changes I make to the MENU BAR take, where the default setting is for them to be turned OFF, but the exact same changes I make to the BOOKMARKS TOOLBAR won't despite trying every one of these methods you all are trying to help me with? They are the same thing and should behave in the same way, but they don't.

John99, The version I have now is 43.0.1.

Just last night I loaded my bookmarks from my old laptop and am able to fully use them and the features that are available in that area. I did notice that the number of items that appeared in the BOOKMARKS TOOLBAR, right under my wweb address window, has decreased. Now there are only 2 items I can click whereas before I loaded the bookmarks into this system there were 5 or so items that were available to click. It looked cluttered, in my view. It doesn't look that bad now. I'd still like to get them to work the way I want it to, but if I can't get them to disappear like I want, I'll be able to live with the results I guess.

I'll report back later on the results of this latest attempt.

Thank you all for your continued attempts to help me.

more options

Please try to update to the latest version of Firefox. What happens when you try that and what version are you now using ? (Fx43.0.1 is old and no longer supported )

Obviously we cannot see your computer, so to make sure we are all understanding one another and talking about the same thing it may help if you are able to attach screenshot of your problem

I also asked

Have you tried using your bookmarks, 
are you for instance able to add new bookmarks 
and see them once you restart Firefox ? 
....
Is there any possibility your Firefox profile is locked, 
or is being recreated, by say, some third party security 
or backup software.