X
Tap here to go to the mobile version of the site.

Support Forum

The checkbox in reCAPTCHA does not load/appear

Posted

Using Firefox v45.0 and Windows 10 Home version 1511 I cannot get the reCAPTCHA check box to display/appear. I have installed the latest version of Java but it still does not display. I have trying to log into Virgin Media web mail. I got it to work for a short while but not any more. I did notice that the missing check box appeared a millisecond later than the rest of the page.

It all works fine using the same version of Firefox and Windows 7.

This has been a problem for some time and is driving me mad.

Using Firefox v45.0 and Windows 10 Home version 1511 I cannot get the reCAPTCHA check box to display/appear. I have installed the latest version of Java but it still does not display. I have trying to log into Virgin Media web mail. I got it to work for a short while but not any more. I did notice that the missing check box appeared a millisecond later than the rest of the page. It all works fine using the same version of Firefox and Windows 7. This has been a problem for some time and is driving me mad.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Picasa plugin
  • Shockwave Flash 21.0 r0
  • VLC media player Web Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

More Information

FredMcD
  • Top 10 Contributor
4248 solutions 59413 answers

On the 'sick' computer;

Use this link to check that your plugins are up-to-date. If any are listed as unknown or research, do not worry about them.


Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

On the 'sick' computer; '''[https://www.mozilla.org/en-US/plugincheck/ Use this link to check that your plugins are up-to-date.]''' If any are listed as unknown or research, do not worry about them. --------- Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins.''' Make sure the ones you want to use are set to '''Ask''' or '''Allow.''' -------------- Go to the web page. Once the page is loading, mouse to the address bar and '''Left''' click the icon. Select '''Permissions.''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow.'''

Question owner

The permissions settings were set to default, but setting them to 'allow' made no difference. I am comparing the settings in Firefox to those that I have on my desktop machine, which is running Windows 7

I still have the problem, but thanks for your prompt reply.

The permissions settings were set to default, but setting them to 'allow' made no difference. I am comparing the settings in Firefox to those that I have on my desktop machine, which is running Windows 7 I still have the problem, but thanks for your prompt reply.
FredMcD
  • Top 10 Contributor
4248 solutions 59413 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

I have tried both your suggestions but unfortunately without success. I am using Firefox version 45.0.1

The problem is aggravated because sometimes reCAPTCHA does not trigger, so I don't know if any changes have fixed the problem.

Interestingly ISP consistently says to try deleting the cookies and cache.

'''''''For clarity, can I add that I am using the above version of Firefox on my Desktop machine running Windows 7 with no problem at all, ie, the reCAPTCHA checkbox always appears.''''''' The only difference is that the Laptop is running Windows 10

I have tried both your suggestions but unfortunately without success. I am using Firefox version 45.0.1 The problem is aggravated because sometimes reCAPTCHA does not trigger, so I don't know if any changes have fixed the problem. Interestingly ISP consistently says to try deleting the cookies and cache. ''''''''''''For clarity, can I add that I am using the above version of Firefox on my Desktop machine running Windows 7 with no problem at all, ie, the reCAPTCHA checkbox always appears.'''''''''''' The only difference is that the Laptop is running Windows 10

Modified by Enduser

Phoxuponyou 51 solutions 517 answers

I saw Plugins mentioned, but how about Extensions? Do you have content blockers like AdBlock Plus or NoScript? Antivirus extensions? Do you use PeerBlock or other traffic filtering software?

I saw Plugins mentioned, but how about Extensions? Do you have content blockers like AdBlock Plus or NoScript? Antivirus extensions? Do you use PeerBlock or other traffic filtering software?

Question owner

I do use 'no script' Are there settings there which may be causing me a problem ? I have had reCAPTCHA working correctly but only for a short time. It's just the check box that does not load.

I do use 'no script' Are there settings there which may be causing me a problem ? I have had reCAPTCHA working correctly but only for a short time. It's just the check box that does not load.
Phoxuponyou 51 solutions 517 answers

NoScript might be blocking the domain or the element (since it's an interactive scripted one) that is needed to render the box. Check the NoScript permissions on the page(s) you're having trouble on. Reload the page without cache after you change permissions; https://en.wikipedia.org/wiki/Wikipedia:Bypass_your_cache#Firefox_and_other_related_browsers.

I think the widget also requires Javascript, so make sure Java is allowed to run: go to about:addons > Plugins and view the permissions of the page in question, https://support.mozilla.org/en-US/kb/page-info-window-view-technical-details-about-page.

NoScript might be blocking the domain or the element (since it's an interactive scripted one) that is needed to render the box. Check the NoScript permissions on the page(s) you're having trouble on. Reload the page without cache after you change permissions; https://en.wikipedia.org/wiki/Wikipedia:Bypass_your_cache#Firefox_and_other_related_browsers. I think the widget also requires Javascript, so make sure Java is allowed to run: go to '''about:addons''' > ''Plugins'' and view the permissions of the page in question, https://support.mozilla.org/en-US/kb/page-info-window-view-technical-details-about-page.

Modified by Phoxuponyou

Question owner

As I am not too sure about how to use No Script I have uninstalled it. [ no improvement] I do not have Java or JavaScript installed, which one do I need or is it both, also is there a particular one for use with Windows 10

As I am not too sure about how to use No Script I have uninstalled it. [ no improvement] I do not have Java or JavaScript installed, which one do I need or is it both, also is there a particular one for use with Windows 10
Phoxuponyou 51 solutions 517 answers

Helpful Reply

Visit http://www.java.com/en/download/windows_xpi.jsp to install Java; "Java" just refers to the whole shebang, scripts and all.

Visit http://www.java.com/en/download/windows_xpi.jsp to install Java; "Java" just refers to the whole shebang, scripts and all.

Question owner

I have installed Java 8 update 73, on the Laptop, is this correct ?

I have just compared the 'permissions' settings for the rouge page in both the Desktop machine and the Laptop and in the Desktop machine 'Java' is not listed !, where it is on the Laptop.

I have installed Java 8 update 73, on the Laptop, is this correct ? I have just compared the 'permissions' settings for the rouge page in both the Desktop machine and the Laptop and in the Desktop machine 'Java' is not listed !, where it is on the Laptop.

Modified by Enduser

Phoxuponyou 51 solutions 517 answers

Helpful Reply

Alright, I assumed based on https://developers.google.com/recaptcha/docs/display that the widget requires Java - apparently it may not, if your desktop can render the widget without having Java installed.

If Java is present and the permissions are set to Allow, the only thing that comes to mind is something blocking access to gstatic.com (the domain where Recaptcha operates from). You said you uninstalled NoScript, but what is left running? What is listed in bold in about:plugins? What antivirus program do you use?

Alright, I assumed based on https://developers.google.com/recaptcha/docs/display that the widget requires Java - apparently it may not, if your desktop can render the widget without having Java installed. If Java is present and the permissions are set to Allow, the only thing that comes to mind is something blocking access to gstatic.com (the domain where Recaptcha operates from). You said you uninstalled NoScript, but what is left running? What is listed in '''bold''' in '''about:plugins'''? What antivirus program do you use?

Question owner

The only extensions I have on the Laptop are Flag-fox, and Skype. I have also noticed that Java is disabled in the Desktop, but enabled on the Laptop.

Since removing No Script, and installing Java, I get all sorts of pop ups, and also messages that Firefox is not responding.

The only extensions I have on the Laptop are Flag-fox, and Skype. I have also noticed that Java is disabled in the Desktop, but enabled on the Laptop. Since removing No Script, and installing Java, I get all sorts of pop ups, and also messages that Firefox is not responding.
Phoxuponyou 51 solutions 517 answers

Are these website pop-ups or system/program dialogue boxes? In either case this sounds like malware. What antivirus solution are you using?

To check for malware and rectify the situation, see https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware#w_how-do-i-get-rid-of-malware.

Are these website pop-ups or system/program dialogue boxes? In either case this sounds like malware. What antivirus solution are you using? To check for malware and rectify the situation, see https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware#w_how-do-i-get-rid-of-malware.

Question owner

They are from websites, currently I am using AVG, which is automatically kept up to date.

They are from websites, currently I am using AVG, which is automatically kept up to date.
Phoxuponyou 51 solutions 517 answers

Alright, you have antivirus capability and AVG should update its databases regularly. When was the last update, though, and could you update manually right now?

For certainty's sake, which version (product and number) of "AVG" do you have installed? Do you use the AVG toolbar or other add-ons? Do AVG components show up when you go to about:plugins or about:addons? Does a full system scan with AVG indicate any problems?

I would still recommend running the other scanners to achieve maximum coverage in results.

Java is standard technology, so it should not cause instability or inaccessibility - even the official AVG support site uses Java. These are more symptomatic of malware or antivirus interference.

Do other browsers suffer like this, or just Firefox?

If it's not malware, I am guessing AVG is blocking Firefox's access to gstatic.com or the widget code and now with Java it is stopping execution altogether, crashing or hanging Firefox. AVG has caused issues with Recaptcha in the past (most search hits are from 2010 and refer to the toolbar as the problem) and can cause problems for Firefox (see search hits for reference); they are also infamous for selling user data and making software that is potentially harmful and difficult to remove effectively, see https://en.wikipedia.org/wiki/AVG_%28software%29#Controversy.

You can define an exception for gstatic.com in AVG like so, https://support.avg.com/SupportArticleView?l=en_US&urlname=How-to-exclude-file-folder-or-website-from-AVG-scanning, but I would first like to make sure we're malware free and no AVG components exist in Firefox.

Alright, you have antivirus capability and AVG should update its databases regularly. When was the last update, though, and could you update manually right now? For certainty's sake, which version (product and number) of "AVG" do you have installed? Do you use the AVG toolbar or other add-ons? Do AVG components show up when you go to '''about:plugins''' or '''about:addons'''? Does a full system scan with AVG indicate any problems? I would ''still'' recommend running the other scanners to achieve maximum coverage in results. Java is standard technology, so it should not cause instability or inaccessibility - even the official AVG support site uses Java. These are more symptomatic of malware or antivirus interference. Do other browsers suffer like this, or just Firefox? If it's not malware, I am guessing AVG is blocking Firefox's access to gstatic.com or the widget code and now with Java it is stopping execution altogether, crashing or hanging Firefox. AVG has caused issues with Recaptcha in the past (most search hits are from 2010 and refer to the toolbar as the problem) and can cause problems for Firefox (see search hits for reference); they are also infamous for selling user data and making software that is potentially harmful and difficult to remove effectively, see https://en.wikipedia.org/wiki/AVG_%28software%29#Controversy. You can define an exception for gstatic.com in AVG like so, https://support.avg.com/SupportArticleView?l=en_US&urlname=How-to-exclude-file-folder-or-website-from-AVG-scanning, but I would first like to make sure we're malware free and no AVG components exist in Firefox.

Question owner

Thank you for all your help with this. There is a lot to absorb in your last reply, and I'll be looking into it.

I have the full version of AVG installed on the Desktop, [which automatically updates, very frequently] and the free version on the Laptop.

I have uninstalled the free version to see if that was the problem, but it made no difference. It's a real head scratcher, as I said before I have had it all working OK, but only for a while.

I have now uninstalled Java from the Laptop, [as the desktop was not using it on the problem page, and have reinstalled No Script, which has stabilized the Laptop.

Thank you for all your help with this. There is a lot to absorb in your last reply, and I'll be looking into it. I have the full version of AVG installed on the Desktop, [which automatically updates, very frequently] and the free version on the Laptop. I have uninstalled the free version to see if that was the problem, but it made no difference. It's a real head scratcher, as I said before I have had it all working OK, but only for a while. I have now uninstalled Java from the Laptop, [as the desktop was not using it on the problem page, and have reinstalled No Script, which has stabilized the Laptop.
John99 971 solutions 13138 answers

I am not sure I follow this correctly. Are you trying to

  • Add the reCAPTCHA widget to a website
  • Or use a reCAPTCH widget on a website

Most importantly is that website publicly accessible

  • What is that website ?

You are mentioning Virgin Media web mail . This page has a reCaptcha when I look at it

Do you see that ?

I am not sure I follow this correctly. Are you trying to *Add the reCAPTCHA widget to a website * Or use a reCAPTCH widget on a website Most importantly is that website publicly accessible * What is that website ? You are mentioning Virgin Media web mail . This page has a reCaptcha when I look at it * https://my.virginmedia.com/create-profile/register Do you see that ?

Question owner

Yes, it is the Virgin Media Web-mail log in page, and yes, that's what I see except that the 'I'm not a robot' checkbox is missing. Therefore I can never log in.

Yes, it is the Virgin Media Web-mail log in page, and yes, that's what I see except that the 'I'm not a robot' checkbox is missing. Therefore I can never log in.
Phoxuponyou 51 solutions 517 answers

The case is starting to spill a bit, I'll grant you that. The possibility of something simple getting overlooked or not done properly increases with complexity and the amount of steps taken.

If something first works and then stops working, it's usually one of the following:

  • Bad cache. Website tries to use older local information that has become corrupted or otherwise unusable. Solved by clearing cache+cookies (reported as done) and loading new data from website.
  • Change in settings or environment. A previously Allowed thing is now Forbidden; automatic update to antivirus or content blocker rules, browser settings changed by version update or user (especially caching and site permissions, both reported explored), certificate expiration, etc. Solved by removing, repairing or resetting factors, see https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings for a Firefox reset.
  • Incompatible software. You tried new Java and you have had working results with Firefox 45.0 (or 45.0.1) even without Java, so we should be in the clear in that regard. Even tried without AVG (always make sure you have SOME antivirus installed; in Windows 10 you can turn on Windows Defender if you have nothing else installed). Still worried about malware though.
  • A fluke. Turn computer off, then back on again?

Just out of curiosity, what are your laptop specs? Some web content can be hard on low-power mobile chips and wireless connections (one reason for perceived program instability, compounded by antivirus scanning), and the checkbox may just be taking a very long time to load or render.

PS. Now that you have NoScript back, is gstatic.com allowed in it? Hover over the "S" icon to see if it's Untrusted or hasn't been Allowed yet, see attached image for reference.

The case is starting to spill a bit, I'll grant you that. The possibility of something simple getting overlooked or not done properly increases with complexity and the amount of steps taken. If something first works and then stops working, it's usually one of the following: * Bad cache. Website tries to use older local information that has become corrupted or otherwise unusable. Solved by clearing cache+cookies (reported as done) and loading new data from website. * Change in settings or environment. A previously Allowed thing is now Forbidden; automatic update to antivirus or content blocker rules, browser settings changed by version update or user (especially caching and site permissions, both reported explored), certificate expiration, etc. Solved by removing, repairing or resetting factors, see https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings for a Firefox reset. * Incompatible software. You tried new Java and you have had working results with Firefox 45.0 (or 45.0.1) even without Java, so we should be in the clear in that regard. Even tried without AVG (always make sure you have SOME antivirus installed; in Windows 10 you can turn on ''Windows Defender'' if you have nothing else installed). Still worried about malware though. * A fluke. Turn computer off, then back on again? Just out of curiosity, what are your laptop specs? Some web content can be hard on low-power mobile chips and wireless connections (one reason for perceived program instability, compounded by antivirus scanning), and the checkbox may just be taking a very long time to load or render. PS. Now that you have NoScript back, is gstatic.com allowed in it? Hover over the "S" icon to see if it's Untrusted or hasn't been Allowed yet, see attached image for reference.
John99 971 solutions 13138 answers

So do you get a reCAPTCH on the create-profile/register page

That at least shows you sometimes see those.

I won't pretend to understand the code but I see

<span aria-labelledby="recaptcha-anchor-label" class="recaptcha-checkbox goog-inline-block recaptcha-checkbox-unchecked rc-anchor-checkbox" role="checkbox" aria-checked="false" id="recaptcha-anchor" tabindex="0" dir="ltr"><div class="recaptcha-checkbox-border" role="presentation"></div><div class="recaptcha-checkbox-borderAnimation" role="presentation"></div><div class="recaptcha-checkbox-spinner" role="presentation"></div><div class="recaptcha-checkbox-spinnerAnimation" role="presentation"></div><div class="recaptcha-checkbox-checkmark" role="presentation"></div></span>

What is the page you are trying to use ? I presume it is the initial login page and that it is public and anyone will be able to see it and test for the presence of a reCAPCHA. For instance this is some sort of login page I can find

That page has no reCAPTCHA on it. I have no idea whether it should have, and it is not relevant to me as I have no Virgin Media account with which to test. It may be of interest to see what happens if you try to use that link. I think I got that from trying https://mail.virginmedia.com/ I also see http://www.virginmedia.com/myvirginmedia that has a button that generates a sign in option.

So do '''you''' get a reCAPTCH on the create-profile/register page * https://my.virginmedia.com/create-profile/register That at least shows you sometimes see those. I won't pretend to understand the code but I see <nowiki><span aria-labelledby="recaptcha-anchor-label" class="recaptcha-checkbox goog-inline-block recaptcha-checkbox-unchecked rc-anchor-checkbox" role="checkbox" aria-checked="false" id="recaptcha-anchor" tabindex="0" dir="ltr"><div class="recaptcha-checkbox-border" role="presentation"></div><div class="recaptcha-checkbox-borderAnimation" role="presentation"></div><div class="recaptcha-checkbox-spinner" role="presentation"></div><div class="recaptcha-checkbox-spinnerAnimation" role="presentation"></div><div class="recaptcha-checkbox-checkmark" role="presentation"></div></span></nowiki> What is the page you are trying to use ? I presume it is the initial login page and that it is public and anyone will be able to see it and test for the presence of a reCAPCHA. For instance this is some sort of login page I can find * [https://identity.virginmedia.com/vm_sso/idp/requestAssertion.action?SAMLRequest=eJx9kc1OwzAQhF8l8j2%2FSAisOlUBISq1KGrTHrg59iaxSOzgdSJ4e9yGSoUDBx%2FW3hnPfrtYfvZdMIFFZTQjaZSQALQwUumGkUP5HN6RZb5A3ncDXY2u1Tv4GAFd4HUa6fmBkdFqajgqpJr3gNQJul9tNzSLEjpY44wwHQlWiGCd%2F%2BjRaBx7sHuwkxJw2G0YaZ0bkMZx%2FxVNyjZK9yAVj4TpYy7wdEiwfmIEatm8d20lvaXhEriUVV01jdGiFapupR5qqGrlu7HgiGoCRmreIZxucIS1Rse1YyRL0tswuQnT%2BzJLaJrRNHkjQfET90HpGcKf2aLr2aq5CelLWRbhzie2INzZZFIS7KtXMHLcFsY67gkcL6C9mMxY6TmUveL5P05%2BgUjyi%2B8ivjLK5%2Br3tvJv3Emqqg%3D%3D&RelayState=https%3A%2F%2Fmy.virginmedia.com%2Fhome%2Findex link] That page has no reCAPTCHA on it. I have no idea whether it should have, and it is not relevant to me as I have no Virgin Media account with which to test. It may be of interest to see what happens if you try to use that link. I think I got that from trying https://mail.virginmedia.com/ I also see http://www.virginmedia.com/myvirginmedia that has a button that generates a sign in option.