Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox changed language after update

  • 3 replies
  • 0 have this problem
  • 32 views
  • Last reply by panuma

more options

Hi,

McAfee was installing some updates on my pc and asked me to close firefox. When I restarted it firefox was in german! I don't speak german so I've never installed this language package. My pc is from switzerland so the original language might have been german, although I've installed windows in french and spanish, not german.

How can I make firefox to be in english again?

Many thanks

All Replies (3)

more options

Hey Panuma,

Not sure what you mean by firefox is in german so I'm going to try both answers here.

If webpages are in German: Paste this into your URL bar: about:preferences#content Then select the "Choose..." option next to Language, then click the box immediately to the right and you should be able to choose the language. Choose the dropdown option that say [en-us] or [en] the right of the language and then click the box that says "Add" and then click "Ok". Restart your browser and you should be good to go!

If the actual application is in German: You'll have to re-install the browser using this link: https://www.mozilla.org/en-US/firefox/new/

Please let me know if this fixed the issue for you.

more options

If you are still having problems; Download Firefox For All languages And Systems {web link}

more options

Hi Kyle,

I meant the app is in german. So I'll have to re-install it. But how can I make sure this doesn't happen again?

Thanks!