Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox and Thunderbird not responding when attempting to manage files

  • 5 replies
  • 1 has this problem
  • Last reply by indebu

more options

when I try to download a file, from a web link, with firefox, I see a flashing of the icons on the desktop wallpaper and then firefox hangs until I click on the application windows and appears the "not responding" message on the upper blue bar . The only thing left is to close the application by clicking on the x or by ctrl-alt-del and terminating. Same thing happens if clicking on "menù file --> open file" or it trying to Open file from the "Import and backup" button of the bookmarks library window. In addition, Firefox hangs also when clicking on the Menù "Options" tab.

A very similar thing happens with thunderbird when I try to attach files to new messages that I am composing: desktop flashing and software hangs and I have to terminate it. If i open preferences to browse the

I have tried many solutions for Firefox and for Thunderbird, including safe mode, OS safe mode, Refreshing, uninstalling both of them and reinstalling after deleting every profile folder to be sure to reinstall from schratch. I tried portable versions, uninstalled antivirus (at the moment I am running no antivirus at all ! ), updated video card NVidia quadro NVS440 drivers.

I posted a similar question about thunderbird on this forum here but I am getting convinced that the problem is about how mozilla products interact with explorer file dialog window since I essentially get the same problem when trying to work with files.

I saw a similar question here exept for the fact that I have thunderbird out of order too.

So far I couldn't figure out how to solve all this. Hope someone can help me because I have been using firefox and mozilla for more than 10 years now and would like to continue.

Thanks in advance. Bye

All Replies (5)

more options

As to Firefox, try this;

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
key, and then starting Firefox. Is the problem still there?

While still in Safe Mode,

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

more options

thanks for your reply FredMcD, here is my configuration collected as you requested

Application Basics

Name: Firefox Version: 43.0.1 Build ID: 20151216175450 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0 Multiprocess Windows: 0/1 (default: false) Safe Mode: false

Crash Reports for the Last 3 Days

All Crash Reports


Name: ADB Helper Version: 0.8.7 Enabled: true ID:

Name: Copy Extensions to Clipboard Version: 4.0.1-signed Enabled: true ID: jid1-yaYZ8QXoULbGtw@jetpack

Name: Valence Version: 0.3.5 Enabled: true ID:

Name: Microsoft .NET Framework Assistant Version: 1.0 Enabled: false ID: {20a82645-c095-46ed-80e3-08825760534b}


Adapter Description: NVIDIA Quadro NVS 440 Adapter Drivers: nv4_disp Adapter RAM: Unknown Asynchronous Pan/Zoom: none Device ID: 0x014a DirectWrite Enabled: false ( Driver Date: 11-6-2012 Driver Version: GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 9 (OMTC) Subsys ID: 023410de Supports Hardware H264 Decoding: No; Failed to create H264 decoder Vendor ID: 0x10de WebGL Renderer: Google Inc. -- ANGLE (NVIDIA Quadro NVS 440 Direct3D9 vs_3_0 ps_3_0) windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Important Modified Preferences

browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 3 true browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20151216175450 browser.startup.homepage_override.buildID: 20151216175450 browser.startup.homepage_override.mstone: 43.0.1 dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 43.0.1 gfx.crash-guard.d3d11layers.appVersion: 43.0.1 gfx.crash-guard.d3d11layers.deviceID: 0x014a gfx.crash-guard.d3d11layers.driverVersion: gfx.crash-guard.d3d11layers.feature-d2d: true gfx.crash-guard.d3d11layers.feature-d3d11: true gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle: true gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle: true gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11: false gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp: false gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11: true gfx.crash-guard.status.d3d11layers: 2 gfx.crash-guard.status.glcontext: 2 media.gmp-gmpopenh264.abi: x86-msvc media.gmp-gmpopenh264.lastUpdate: 1457534437 media.gmp-gmpopenh264.version: 1.5.3 media.gmp-manager.buildID: 20151216175450 media.gmp-manager.lastCheck: 1457534437 media.hardware-video-decoding.failed: true network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.history.expiration.transient_current_max_pages: 53668 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.npdeployjava: 0 privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 0

Important Locked Preferences


Incremental GC: true


Activated: false Prevent Accessibility: 0

Library Versions

NSPR Expected minimum version: 4.10.10 Version in use: 4.10.10

NSS Expected minimum version: 3.20.1 Basic ECC Version in use: 3.20.1 Basic ECC

NSSSMIME Expected minimum version: 3.20.1 Basic ECC Version in use: 3.20.1 Basic ECC

NSSSSL Expected minimum version: 3.20.1 Basic ECC Version in use: 3.20.1 Basic ECC

NSSUTIL Expected minimum version: 3.20.1 Version in use: 3.20.1

Experimental Features

more options

I found a previous reported bug on bugzilla

bug 1046958

which is quite similar to my problem except for the operating system

unfortunately it is yet to be solved

more options

Some of the things you mention as issues are related to malware... Please follow all below: I note everything is outdated in programs and updates for you. I am asking you to please update all of your programs and add-ons, pluggins and other expired vulnerable software. Suggest a program you can run as is a stand alone program Patch My PC and hope it supports XP and it covers a range of programs.

I note that you are using version 43.01 of Firefox Can you please update to Version 45 released Tuesday if compatable to XP. Please update Adobe Acrobat released Tuesday that had multiple vulnerabilities or uninstall it and just run a current Foxit Reader Plugin for Mozilla, if keep Adobe make sure both are current.

Please uninstall your Java ver 8 .65 and go to and get version 8.73

Please update your VLC Player to version 2.2.2

Running XP Pro I must ask you to please run these scans as some of the things you have mentioned are or can be related to malware and since XP is not supported and is a security risk along with not keeping your browser updated before any further looking into this is please follow below:

o a malware check with several malware scanning programs on the Windows computer. 

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

   Malwarebytes' Anti-Malware:
   Spybot Search & Destroy:
   Kasperky Free Security Scan:

You can also do a check for a rootkit infection with TDSSKiller.

   Anti-rootkit utility TDSSKiller:
more options

after all this time I decided to give up searching a solution I began to use another mail client while waiting to migrate to Windows 7