X
Tap here to go to the mobile version of the site.

Support Forum

I'm using firefox as an 'appliance' - and it MUST be locked to a specifc version. How do I prevent ALL updates to the browser?

Posted

I've tried all of the 'usual' advice - and yet, my appliance still got a forced update over the weekend.

I need to disable all updates to the Firefox browser in this particular (internal) appliance setup.

I've tried all of the 'usual' advice - and yet, my appliance still got a forced update over the weekend. I need to disable all updates to the Firefox browser in this particular (internal) appliance setup.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Citrix Online App Detector Plugin
  • Version 5.41.3.0
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.73.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Picasa plugin
  • Shockwave Flash 20.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

More Information

FredMcD
  • Top 10 Contributor
4269 solutions 59841 answers

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select Update. Check the settings.

Note that some security updates are known to bypass this setting. I've called the big guys to help you. Good luck.

Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced,''' Select '''Update.''' Check the settings. Note that some security updates are known to bypass this setting. I've called the big guys to help you. Good luck.

Question owner

FredMcD said

Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update. Check the settings.

I had already done this ... no help.

''FredMcD [[#answer-850668|said]]'' <blockquote> Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced,''' Select '''Update.''' Check the settings. </blockquote> I had already done this ... no help.
FredMcD
  • Top 10 Contributor
4269 solutions 59841 answers

Did you read the last paragraph? Please describe the issue in detail.

Did you read the last paragraph? Please describe the issue in detail.

Question owner

FredMcD said

Did you read the last paragraph? Please describe the issue in detail.

The issue - in spite of having the advance/update setting "Never check for updates" checked, the browser on this 'appliance' updated sometime in the past couple of weeks.

It took me almost 2 hours to get the browser version I require re-installed - while defeating the 'auto-update on install' feature of Firefox.

I want to prevent this from EVER happening on this machine, ever.

''FredMcD [[#answer-851094|said]]'' <blockquote> Did you read the last paragraph? Please describe the issue in detail. </blockquote> The issue - in spite of having the advance/update setting "Never check for updates" checked, the browser on this 'appliance' updated sometime in the past couple of weeks. It took me almost 2 hours to get the browser version I require re-installed - while defeating the 'auto-update on install' feature of Firefox. I want to prevent this from EVER happening on this machine, ever.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40297 answers
See this: https://support.mozilla.org/en-US/kb/what-mozilla-maintenance-service

Question owner

the-edmeister said

See this: https://support.mozilla.org/en-US/kb/what-mozilla-maintenance-service

I do not have the 'mozilla maintenance service' in the uninstall programs section of control panel. I do NOT have an option (to uncheck) the 'install updates in the background.

''the-edmeister [[#answer-851105|said]]'' <blockquote> See this: https://support.mozilla.org/en-US/kb/what-mozilla-maintenance-service </blockquote> I do not have the 'mozilla maintenance service' in the uninstall programs section of control panel. I do NOT have an option (to uncheck) the 'install updates in the background.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

You can set the app.update.url pref to an empty string on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can set the <b>app.update.url</b> pref to an empty string on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Question owner

cor-el said

You can set the app.update.url pref to an empty string on the about:config page.

I just did that ... I'll have to wait-n-see if that makes a difference.

''cor-el [[#answer-851118|said]]'' <blockquote> You can set the <b>app.update.url</b> pref to an empty string on the <b>about:config</b> page. </blockquote> I just did that ... I'll have to wait-n-see if that makes a difference.
guigs 1072 solutions 11697 answers

Hi opa6x57, How did that change go?

Hi opa6x57, How did that change go?
ideato 893 solutions 6250 answers

Hello

opa6x57 said

cor-el said
You can set the app.update.url pref to an empty string on the about:config page.

I just did that ... I'll have to wait-n-see if that makes a difference.

IF the issue persist then try to lock the next preferences :

app.update.auto - false app.update.enabled - false app.update.silent - false

http://kb.mozillazine.org/Locking_preferences

thank you

Hello ''opa6x57 [[#answer-851122|said]]'' <blockquote> ''cor-el [[#answer-851118|said]]'' <blockquote> You can set the <b>app.update.url</b> pref to an empty string on the <b>about:config</b> page. </blockquote> I just did that ... I'll have to wait-n-see if that makes a difference. </blockquote> '''IF the issue persist''' then try to lock the next preferences : app.update.auto - false app.update.enabled - false app.update.silent - false http://kb.mozillazine.org/Locking_preferences thank you