X
Tap here to go to the mobile version of the site.

Support Forum

Setting Firefox as the default browser does not work - What to do in Windows 8.1?

Posted

The 'Setting Firefox as the default browser does not work - What to do' article identifies the problem but does not give instructions for Windows 8.1. I've tried following equivalent process for Win 7 but it doesn't work. I still get asked if I want Firefox to be default program every time it opens.

The 'Setting Firefox as the default browser does not work - What to do' article identifies the problem but does not give instructions for Windows 8.1. I've tried following equivalent process for Win 7 but it doesn't work. I still get asked if I want Firefox to be default program every time it opens.

Additional System Details

Installed Plug-ins

  • Intel AppUp Hyperlink Plugin
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 20.0 r0
  • 5.1.41212.0

Application

  • Firefox 45.0b6
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
  • Support URL: https://support.mozilla.org/1/firefox/45.0/WINNT/en-US/

Extensions

  • Avast Online Security 10.3.3.13 (wrc@avast.com)
  • Firefox Hello Beta 0.1 (loop@mozilla.org)
  • PriceBlink 4.5 (info@priceblink.com)
  • Avast SafePrice 10.3.5.13 (sp@avast.com) (Inactive)
  • Wondershare Video Converter Ultimate 7.1.0 (WSVCU@Wondershare.com) (Inactive)
  • zonealarm.com 1.6.0 (ffxtlbr@zonealarm.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 8330
  • adapterDescription2:
  • adapterDeviceID: 0x9832
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterSubsysID: 368717aa
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.18123
  • driverDate: 8-21-2013
  • driverDate2:
  • driverVersion: 13.151.1.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 8330 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Helpful Reply

Open Windows Internet Explorer. Have it declared as the default browser. But turn off the option to check this when the browser opens (If you want).

Now do the same thing using Firefox.

Open Windows Internet Explorer. Have it declared as the default browser. But turn off the option to check this when the browser opens (If you want). Now do the same thing using Firefox.

Question owner

Many thanks. I couldn't find the off button or checkbox to stop IE checking it is default, but the dialogue box allowed the option to select 'Windows', 'Non-Windows' or 'Custom' browser choices. The Non-Windows option listed Firefox as the default browser, and removed internet access for IE. Seems to have sorted the problem. Thanks again.

Many thanks. I couldn't find the off button or checkbox to stop IE checking it is default, but the dialogue box allowed the option to select 'Windows', 'Non-Windows' or 'Custom' browser choices. The Non-Windows option listed Firefox as the default browser, and removed internet access for IE. Seems to have sorted the problem. Thanks again.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.