Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Upgraded Firefox; now can't load Yahoo.com and Google Calendar

  • 4 replies
  • 4 have this problem
  • 12 views
  • Last reply by davecahn

more options

Upgraded to 44.0.2. I get error message "Your connection is not secure" for yahoo.com (see screenshot) and the secure Google Calendar site. They were working OK before upgrade. They work on IE. What now?

Attached screenshots

Chosen solution

thanks, this might be caused by something on your system/network intercepting secure connections. please refer to How to troubleshoot security error codes on secure websites for the most common solutions for this issue.

Read this answer in context 👍 3

All Replies (4)

more options

hi, what kind of error code is shown when you click on the "advanced" button?

more options

"www.google.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)"

Note that the original (non-advanced) error message says that an exception is not allowed.

Except for the site name, Yahoo and Google error messages are identical.

This also affects my gmail account. I am guessing it applies to all secure (https) sites.

more options

Chosen Solution

thanks, this might be caused by something on your system/network intercepting secure connections. please refer to How to troubleshoot security error codes on secure websites for the most common solutions for this issue.

more options

Thanks, philipp! That took care of the problem.