X
Tap here to go to the mobile version of the site.

Support Forum

When I try to activate my account, I get an error "Cookies and local storage must be enabled." My preferences are Always accept cookies, keep until they expire

Posted

I keep being asked to activate my account. My preferences on cookies always accept them. So I don't know how to resolve the issue.

Occasionally other sites also say I must enable cookies.

Cookies are enabled. I don't know what else to do since my settings say they are already enabled.

I keep being asked to activate my account. My preferences on cookies always accept them. So I don't know how to resolve the issue. Occasionally other sites also say I must enable cookies. Cookies are enabled. I don't know what else to do since my settings say they are already enabled.

Additional System Details

Installed Plug-ins

  • aliedit for cocoa
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Provides information about the default web browser
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • RealPlayer Plugin
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 20.0 r0
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0

More Information

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Hi Alex, what are your current settings under Privacy Preferences? You can check here:

"3-bar" menu button (or Firefox menu) > Preferences

In the left column, click Privacy. On the right side, if you see "Firefox will: Remember history" please change that to "Firefox will: Use custom settings for history".

The defaults are:

[X] Accept cookies from sites Accept third-party cookies: Always Keep until: They expire (I close Firefox also should work fine)

Regarding local storage, could you check whether the following preference has its default value:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste stora and pause while the list is filtered

(3) If the dom.storage.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

Any changes so far?

Hi Alex, what are your current settings under Privacy Preferences? You can check here: "3-bar" menu button (or Firefox menu) > Preferences In the left column, click Privacy. On the right side, if you see "Firefox will: Remember history" please change that to "Firefox will: Use custom settings for history". The defaults are: [X] Accept cookies from sites Accept third-party cookies: Always Keep until: They expire (I close Firefox also should work fine) Regarding local storage, could you check whether the following preference has its default value: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''stora''' and pause while the list is filtered (3) If the '''dom.storage.enabled''' preference is bolded and "user set" to false, double-click it to restore the default value of true Any changes so far?

Question owner

Thank you for trying to help so promptly.

My privacy settings are as you suggested: Accept all cookies, Keep until they expire.

With local storage, the dom.storage.enabled status is default, value is true.

Any other ideas?!

Thank you for trying to help so promptly. My privacy settings are as you suggested: Accept all cookies, Keep until they expire. With local storage, the dom.storage.enabled status is default, value is true. Any other ideas?!
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Some add-ons may modify how cookies and local storage work. Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option key when starting Firefox. (On Windows, hold down the Shift key)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

Some add-ons may modify how cookies and local storage work. Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the option key when starting Firefox. (On Windows, hold down the Shift key) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? (More info: [[Troubleshoot Firefox issues using Safe Mode]])