Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Videos do not play from several sites, but YouTube does play.

  • 29 replies
  • 2 have this problem
  • 175 views
  • Last reply by BartZorn

more options

I do not play video's often, so I am not sure since when this problem exists. YouTube works OK, but, for instance, video's on cnn.com only show a black rectangle. I have update both Firefox and Adobe Flash player to the latest version. Disabling AdblockPlus does not help.

In addition to the detected data: Windows 10 Pro x64 build 14257.1000 Core i7-2670M, 20 GB memory

All Replies (20)

more options

delete the folders and let me know if it works:

%AppData%\Roaming\Macromedia\Flash Player %AppData%\Local\Macromedia\Flash Player

more options

Two thoughts:

(1) If the sites use Flash, is Firefox waiting for you to approve it? Check the left end of the address bar for a plugin notificaiton icon, which usually looks like a small gray Lego block. If you see the icon, click that to see whether the site needs approval to use Flash.

(2) This could be a side effect of using Adblock Plus: many videos have "pre-roll" advertising. If you temporarily turn off ABP on a site where video is not playing, does that make any difference?

more options

orvi said

delete the folders and let me know if it works: %AppData%\Roaming\Macromedia\Flash Player %AppData%\Local\Macromedia\Flash Player

Thanks, but no, it does not make a difference.

more options

jscher2000 said

Two thoughts: (1) If the sites use Flash, is Firefox waiting for you to approve it? Check the left end of the address bar for a plugin notificaiton icon, which usually looks like a small gray Lego block. If you see the icon, click that to see whether the site needs approval to use Flash. (2) This could be a side effect of using Adblock Plus: many videos have "pre-roll" advertising. If you temporarily turn off ABP on a site where video is not playing, does that make any difference?

Thanks, but:

(1) The Lego block is present, but it says that Flash is enabled and gives me the option to continue enabling it.

(2) Disabling AdblockPlus does not make a difference, like I said in my original posting.

more options

I sampled a video and the stream was served from the Akamai content distribution network:

http://cnn-f.akamaihd.net/cnn/big/world/2016/02/13/stephen-curry-nba-digital.cnn_291427_,512x288_55,640x360_90,768x432_130,896x504_185,1280x720_350,0k.mp4.csmil/bitrate=2?v=3.4.1&p=aasp-3.4.1.1.1&fp=WIN%2020,0,0,286&r=AMISJ&g=TTQUTYKSZYON

This showed up in the Network Monitor. You can check that as follows: press Ctrl+Shift+k to open the Web Console in the lower part of the tab. Click Network along its top bar to see the files Firefox is retrieving. Then reload the page in the top part of the tab and at the bottom of the network monitor, click Flash. Then try to play the video to see whether the main file is retrieved or generates an error. See attached screen shot for comparison. Any new info?

more options

I am not sure what to see. The last flash file downloaded is cvp_main_container.swf. It's size is 3.68 KB, which looks very small for a video, even a short one. In the left most column is a orange triangle with "304"

Thanks for your reply!

Bart

more options

Hi Bart, a small SWF usually is a container that retrieves streaming video. Another video I checked pulled an MP4 file, which shows up on the Media list instead of the Flash list (attached screen shot). But still there should be a bunch of other files in between if the SWF is operating normally.

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates all extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

In safe mode, two or three more files are received (in the media and flash categories), but nothing more. No video.

Bart

more options

One more observation: When I turn off the Windows firewall, it also makes no difference.

Bart

more options

Hmm, in the Web Console (Console section), do you see any error messages related to the inability to load video or other files for that page?

By default, the Flash plugin will launch external processes with lower privileges as a security measure. This "protected mode" feature doesn't seem to work correctly on all systems, but usually if there is an incompatibility, the symptoms are more severe (e.g., crashes, freezes). Still, you could try disabling it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Note: All Flash needs to be unloaded for several minutes before the plugin changes modes. Or you can exit Firefox and start it up again to force the change.

more options

Protected mode off makes no difference.

I checked to see if there is something outside Firefox that could cause this. I first tried Microsoft Edge, and surprise: it also does not show video's. Then I tried Google Chrome and it displays video's without problem. I don't know what is wrong with Edge, but it looks like it is not something outside Firefox.

Bart

more options

Firefox, Chrome and IE use three different flavors of the Flash player, but I suspect that's not relevant because I can't replicate this problem in Firefox. I have a decade of accumulated customizations, so it could be a settings difference between our browsers, unrelated to what Safe Mode changes.

Do you want to try this three-minute experiment:

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Don't delete anything here!

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like TEST2016, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile.

Any difference?

When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

more options

Indeed, with a fresh new profile, video's do play without problem.

So it is something in my profile that corrupts things. Should I start from scratch, or is there an intelligent way to clean it up?

Thank you for your patience!

more options

You might try selectively knocking out a settings file in your main profile to see whether that has the same effect.

Back in your regular profile, open the profile folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename prefs.js to something like prefs-old.js (so you can reverse this if it's more painful than helpful).

Start Firefox back up again and, if necessary, use History > Restore Previous Session. Do the videos play?

more options

No, they do not. I am still using cnn.com as test site.

more options

Hmm, I'm struggling to think of what else it could be. If you decide to build a new profile, this article describes what the main settings files are that you may want to copy over: Recovering important data from an old profile.

more options

I created a new profile and like before, video's did play. Then I copied over my places.sqlite file, and video's did not play any more.

I did nothing else to my new profile! And I did not login to my Firefox sync account, so nothing was restored from that source.

more options

Experimenting further. Now, with a freshly created profile, video's do not play any more. With Google Chrome no problem.

Should I really abandon Firefox?

more options

I can't replicate the problem myself (running Windows 7) and can't think of what else could be interfering with Flash retrieving the video. Are there other sites where Flash doesn't work or only CNN? Maybe the pattern would reveal something.

more options

With the fresh profile, I have tried cnn, bbc, imdb, national geographic and youtube. Only the last one works normal (HTML5?).

  1. 1
  2. 2