X
Tap here to go to the mobile version of the site.

Support Forum

enable javascript

Posted

I have read all of the FAQs and none of them work to enable javascript in Firefox 44 on my macbook. I have no extensions on the system so that is not the problem. Please provide a solution?

I have read all of the FAQs and none of them work to enable javascript in Firefox 44 on my macbook. I have no extensions on the system so that is not the problem. Please provide a solution?

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 15.010.20056
  • Amazon MP3 Downloader Plugin 1.0.17
  • Provides information about the default web browser
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Version 5.41.3.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Picasa plugin.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 20.0 r0
  • 5.1.30514.0
  • zoom.us launcher plugin version 1.0
  • iPhoto6

Application

  • Firefox 44.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0
  • Support URL: https://support.mozilla.org/1/firefox/44.0/Darwin/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x0166
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'quartz', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'none', u'AzureSkiaAccelerated': 1}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: No;
  • webglRenderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4341 solutions 61037 answers

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins.''' Make sure the ones you want to use are set to '''Ask''' or '''Allow.''' -------------- Go to the web page. Once the page is loading, mouse to the address bar and '''Left''' click the icon. A window for displaying site information should come up. Select '''More Information.''' Now select '''Permissions.''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow.'''
cor-el
  • Top 10 Contributor
  • Moderator
17774 solutions 160751 answers

You can check that JavaScript is enabled and isn't blocked.

  • javascript.enabled should be true on the about:config page

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

If you use extensions (3-bar Menu button/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions do not block content. There is security software that can block content, so check that as well.


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can check that JavaScript is enabled and isn't blocked. *javascript.enabled should be true on the <b>about:config</b> page *http://kb.mozillazine.org/JavaScript *https://support.mozilla.org/kb/JavaScript You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config If you use extensions (3-bar Menu button/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions do not block content. There is security software that can block content, so check that as well. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
jscher2000
  • Top 10 Contributor
8886 solutions 72699 answers

Do lots of sites give you this error, or just a couple sites? If it's just a couple sites, you could post the addresses of those pages and indicate where you see the message (if there is a particular action you took before they showed up). That might point us toward the source of the problem if the above general troubleshooting steps do not help.

Do lots of sites give you this error, or just a couple sites? If it's just a couple sites, you could post the addresses of those pages and indicate where you see the message (if there is a particular action you took before they showed up). That might point us toward the source of the problem if the above general troubleshooting steps do not help.

Question owner

javascript is enabled in about:config, but it won't work on my Group Health website

javascript is enabled in about:config, but it won't work on my Group Health website
jscher2000
  • Top 10 Contributor
8886 solutions 72699 answers

mariellec2 said

javascript is enabled in about:config, but it won't work on my Group Health website

Hi mariellec2, since that sounds like a site involving personal information, you might want to check with the site provider on whether they know what is causing the problem, and use a different browser there for the time being.

''mariellec2 [[#answer-841304|said]]'' <blockquote> javascript is enabled in about:config, but it won't work on my Group Health website</blockquote> Hi mariellec2, since that sounds like a site involving personal information, you might want to check with the site provider on whether they know what is causing the problem, and use a different browser there for the time being.

Question owner

I went to about:addons as FredMcD suggested but there is nothingabout javascript on the plugins page. I have no addons or extensions. And when he says "go to the web page" I don't know what web page he is referring to.

I went to about:addons as FredMcD suggested but there is nothingabout javascript on the plugins page. I have no addons or extensions. And when he says "go to the web page" I don't know what web page he is referring to.
jscher2000
  • Top 10 Contributor
8886 solutions 72699 answers

Hi mariellec2, changing how plugins are activated (automatically, upon your approval, or never) doesn't affect whether JavaScript runs, but some pages give a JavaScript error if a plugin they want to use is not enabled.

Since this presumably is a password-protected page, we can't look at it ourselves. However, you can check the address bar for a plugin notification icon, which looks like a small gray Lego block. If you see that, click it to see whether the page needs permission to run a plugin.

Hi mariellec2, changing how plugins are activated (automatically, upon your approval, or never) doesn't affect whether JavaScript runs, but some pages give a JavaScript error if a plugin they want to use is not enabled. Since this presumably is a password-protected page, we can't look at it ourselves. However, you can check the address bar for a plugin notification icon, which looks like a small gray Lego block. If you see that, click it to see whether the page needs permission to run a plugin.