X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Spellchecker problem (/questions/967628)

Posted

Firefox is not switching dictionaries. I have installed Finnish dictionary and Firefox is using only that now. If I right click and try to change dictionary to US or any of the English dictionaries, it won't change it.

I have version 44.0 Mozilla Firefox for Ubuntu canonical - 1.0.

Firefox is not switching dictionaries. I have installed Finnish dictionary and Firefox is using only that now. If I right click and try to change dictionary to US or any of the English dictionaries, it won't change it. I have version 44.0 Mozilla Firefox for Ubuntu canonical - 1.0.

Additional System Details

Installed Plug-ins

  • DivX Web Player version 1.4.0.233
  • The Videos 3.10.1 plugin handles video and audio streams.
  • Shockwave Flash 11.2 r202
  • 5.1.40416.0
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • Firefox 44.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
  • Support URL: https://support.mozilla.org/1/firefox/44.0/Linux/en-US/

Extensions

  • Adblock Plus 2.7.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Ant Video Downloader 2.4.7.34 (anttoolbar@ant.com)
  • Flash Video Downloader - YouTube HD Download [4K] 9.1.0 (artur.dubovoy@gmail.com)
  • Personas Plus 1.7.4 (personas@christopher.beard)
  • Suomen kielen oikoluku 2.0.1-signed (fi@dictionaries.addons.mozilla.org)
  • Ubuntu Modifications 3.2 (ubufox@ubuntu.com)
  • User Agent Switcher 0.7.3.1-signed ({e968fc70-8f95-4ab9-9e79-304de2a71ee1})
  • Web Developer 1.2.5.1-signed ({c45c406e-ab73-11d8-be73-000a95be3b12})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Bay Trail
  • adapterDeviceID: Mesa DRI Intel(R) Bay Trail
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 3.0 Mesa 10.5.9
  • info: {u'CairoUseXRender': 1, u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No;
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Bay Trail
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4393 solutions 61637 answers

Type about:preferences#content<enter> in the address bar.

On the bottom of the page, find Languages. To its right, press the Choose button. Make sure the correct language and district is selected.

Type '''about:preferences#content'''<enter> in the address bar. On the bottom of the page, find '''Languages.''' To its right, press the '''Choose''' button. Make sure the correct language and district is selected.
cor-el
  • Top 10 Contributor
  • Moderator
17857 solutions 161589 answers

Start Firefox in Safe Mode to check if one of the extensions (3-bar Menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: 3-bar Menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Are you using the Firefox version from the official Mozilla servers or the version from the repositories of your Linux distribution?

Try the version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

You can find the full version of the current Firefox release (44.0) in all languages and all operating systems here:

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (3-bar Menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: 3-bar Menu button/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Are you using the Firefox version from the official Mozilla servers or the version from the repositories of your Linux distribution? Try the version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution. You can find the full version of the current Firefox release (44.0) in all languages and all operating systems here: *https://www.mozilla.org/en-US/firefox/all/

Question owner

I am using the canonical version firefox 44.0+build3-0ubuntu0.14.04.1. How else would I get automatic updates?

The problem doesn't exist on safe mode, because the addons are disabled - including the Finnish dictionary - so it defaults to US English. Here's a pic - as you can see the Finnish(Finland) is selected - if I try to select any of the other dictionaries, it won't switch to them.

It used to work fine, maybe the problem came with the latest SW update. I may have to post this problem to the Ubuntu forums.

Thanks for your responses!

P.S. This problem is only related to spell check. I am using an English version of the Firefox.

I am using the canonical version firefox 44.0+build3-0ubuntu0.14.04.1. How else would I get automatic updates? The problem doesn't exist on safe mode, because the addons are disabled - including the Finnish dictionary - so it defaults to US English. Here's a pic - as you can see the Finnish(Finland) is selected - if I try to select any of the other dictionaries, it won't switch to them. It used to work fine, maybe the problem came with the latest SW update. I may have to post this problem to the Ubuntu forums. Thanks for your responses! P.S. This problem is only related to spell check. I am using an English version of the Firefox.

Modified by kaaleppi

cor-el
  • Top 10 Contributor
  • Moderator
17857 solutions 161589 answers

Sometimes there can be a problem with the separator that is used in the language code: an underscore (en_US) instead of a dash (en-US) that could cause this to happen in case globally installed dictionaries are detected and not dictionaries installed in the Firefox profile folder. You can check the spellchecker.dictionary pref on the about:config page.

Sometimes there can be a problem with the separator that is used in the language code: an underscore (en_US) instead of a dash (en-US) that could cause this to happen in case globally installed dictionaries are detected and not dictionaries installed in the Firefox profile folder. You can check the spellchecker.dictionary pref on the <b>about:config</b> page.

Question owner

spellchecker.dictionary shows en-US with a dash, no underscore.

How come, there's no Finnish- Fi shown at all, even when it is installed?

I removed the Finnish dictionary and English worked after that. Then I re-installed the Finnish dictionary and the same thing happens, only Finnish spell checker works, none of the English!

I don't want to frequently remove and install languages when I respond to posts in different languages. What's going on here?

spellchecker.dictionary shows en-US with a dash, no underscore. How come, there's no Finnish- Fi shown at all, even when it is installed? I removed the Finnish dictionary and English worked after that. Then I re-installed the Finnish dictionary and the same thing happens, only Finnish spell checker works, none of the English! I don't want to frequently remove and install languages when I respond to posts in different languages. What's going on here?
John99 971 solutions 13138 answers

Have you tried to check is it ONLY Firefox that is affected ? I have had issues for a while with Linux spellcheckers. They either do not work, or switch unexpectedly.

For me it is a minor issue as I end up using en-US instead of en-GB and can just add the odd word where spellings differ. I have see issues on Debian and Ubuntu.

The reason I post is that my problems are not Firefox only, they may occurs on Mozilla Firefox, Debian Iceweasel & Canonical Firefox, even more importantly I also seen issue in Gedit and LibreOffice.

( /questions/967628 was specific to fx22-23 )

Have you tried to check is it ONLY Firefox that is affected ? I have had issues for a while with Linux spellcheckers. They either do not work, or switch unexpectedly. For me it is a minor issue as I end up using en-US instead of en-GB and can just add the odd word where spellings differ. I have see issues on Debian and Ubuntu. The reason I post is that my problems are not Firefox only, they may occurs on Mozilla Firefox, Debian Iceweasel & Canonical Firefox, even more importantly I also seen issue in Gedit and LibreOffice. ( [/questions/967628] was specific to fx22-23 )

Question owner

It's Firefox only, well - I haven't checked Iceweasel, it's on my Raspberry Pi and I haven't installed extra dictionaries there. I just checked with LibreOffice and both English and Finnish dictionaries are working just fine and I can switch in between them.

It's Firefox only, well - I haven't checked Iceweasel, it's on my Raspberry Pi and I haven't installed extra dictionaries there. I just checked with LibreOffice and both English and Finnish dictionaries are working just fine and I can switch in between them.
John99 971 solutions 13138 answers

OK I will leave it to those looking at a Firefox issue.

Sorry, Because I have unresolved issues myself with Fx spellchecking I am not in a position to try to help you myself.

I keep thinking about Raspberry Pi. I'm permanently skint! but they are so cheap they were even given away as cover gifts with magazines & I like playing with code and electronics so it seems a cheap pastime even if they are only aimed at for schoolkids. Guess I am young at heart.

OK I will leave it to those looking at a Firefox issue. Sorry, Because I have unresolved issues myself with Fx spellchecking I am not in a position to try to help you myself. I keep thinking about Raspberry Pi. I'm permanently skint! but they are so cheap they were even given away as cover gifts with magazines & I like playing with code and electronics so it seems a cheap pastime even if they are only aimed at for schoolkids. Guess I am young at heart.

Question owner

John99 said

I keep thinking about Raspberry Pi. I'm permanently skint! but they are so cheap they were even given away as cover gifts with magazines & I like playing with code and electronics so it seems a cheap pastime even if they are only aimed at for schoolkids.

Don't be fooled about the cheapness of the Raspberry Pi. After buying that and all the necessities, like keyboard, display, wireless adapter, power supply and battery (not essential), I ended up paying over $200.

What's good about it is that it came with a free Mathematica! I installed Apache, PHP and MySql on it and it now serves as a webserver for me.

''John99 [[#answer-841319|said]]'' <blockquote> I keep thinking about Raspberry Pi. I'm permanently skint! but they are so cheap they were even given away as cover gifts with magazines & I like playing with code and electronics so it seems a cheap pastime even if they are only aimed at for schoolkids. </blockquote> Don't be fooled about the cheapness of the Raspberry Pi. After buying that and all the necessities, like keyboard, display, wireless adapter, power supply and battery (not essential), I ended up paying over $200. What's good about it is that it came with a free Mathematica! I installed Apache, PHP and MySql on it and it now serves as a webserver for me.