Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox loads no websites displays no error messages

  • 7 replies
  • 14 have this problem
  • 917 views
  • Last reply by Breakman

more options

I just updated Firefox today to 44.0. I was using it just fine for the hours before that but right after the update no websites would load. Firefox gives no error message. All I see is the little spinning wheel with "Connecting..." beside it. I've tried multiple sides like Reddit, Youtube, Google and Twitter to no avail. I've tried removing and adding Firefox to the exclusions list on my antivirus with no results and running as admin. Disabling my antivirus didn't seem to affect it at all except I noticed one of the help pages on the forums here mentioned it sometimes doesn't actually disable. I left Firefox running while writing this to see if an error message will show up. It still says connecting and it's been around 15 minutes. I'm starting to get a headache so if anyone could lend me a hand that'd be great.

Chosen solution

hi, can you please see if uninstalling firefox 44 first and then installing the 64bit version from https://www.mozilla.org/en-US/firefox/all/ does solve this issue for you?

Read this answer in context 👍 2

All Replies (7)

more options

Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

FredMcD said

Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;
  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see
Configure firewalls so that Firefox can access the Internet. {web link}

Sorry, I've tried this already and it didn't work. I believe I mentioned this in the main post.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

This did work but it doesn't seem I can delete the add-ons on Firefox. It's the Avast Safeprice and Avast Online Security.

more options

If an add-on does not have a "remove" button, it is a plugin.

Add-ons are options you install into Firefox, They can be remove at will. Plugins are from programs that Firefox finds already on your system. The only way to remove a plugin is to remove its program from your system.

more options

Chosen Solution

hi, can you please see if uninstalling firefox 44 first and then installing the 64bit version from https://www.mozilla.org/en-US/firefox/all/ does solve this issue for you?

more options

philipp said

hi, can you please see if uninstalling firefox 44 first and then installing the 64bit version from https://www.mozilla.org/en-US/firefox/all/ does solve this issue for you?

This did work, thanks very much! It didn't have the plug-ins installed but I'm positive that was what was causing the issue in the first place anyways. Thanks again for the help.