X
Tap here to go to the mobile version of the site.

Support Forum

Clicking to open a link downloads instead

Posted

Clicking to open a link downloads instead of simply opening. It is very annoying. I am just wanting to open it and read it not download or download and save. What has changed this started yesterday????

Clicking to open a link downloads instead of simply opening. It is very annoying. I am just wanting to open it and read it not download or download and save. What has changed this started yesterday????

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 20.0 r0
  • Shockwave Flash 15.0 r0
  • VLC media player Web Plugin 2.1.3

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

Wesley Branton
  • Top 10 Contributor
649 solutions 5259 answers

Does this occur for all links or just links pointing to a specific file type (ex. PDF or Word Document)?

Some files need to be downloaded and viewed in another piece of software. You can set how Firefox handles these files from the application panel in the options tab.

For more information on the application panel, please refer to this Mozilla support article:

Does this occur for all links or just links pointing to a specific file type (ex. PDF or Word Document)? Some files need to be downloaded and viewed in another piece of software. You can set how Firefox handles these files from the application panel in the options tab. For more information on the application panel, please refer to this Mozilla support article: *[[Applications panel - Set how Firefox handles different types of files]]

Question owner

Again this is not the issue, your answer. This is not all the time but it is a new problem. In the past I could click on a pdf and it would simply open. Now it immediately asks where I want to save it. I have to save and then open. Very time consuming considering this wasn't happening until a couple of days ago.

Again this is not the issue, your answer. This is not all the time but it is a new problem. In the past I could click on a pdf and it would simply open. Now it immediately asks where I want to save it. I have to save and then open. Very time consuming considering this wasn't happening until a couple of days ago.
Wesley Branton
  • Top 10 Contributor
649 solutions 5259 answers

Helpful Reply

In order to change the default reader for PDF files (to not open PDF files with Firefox's internal PDF reader), follow these steps:

  1. Click the menu button New Fx Menu and click Options (Preferences for Linux and Mac).
  2. In the Options (Preferences for Linux and Mac) tab (window for previous than 38.0 firefox version), select the Applications panel.
  3. In the Search field, type PDF. You should find Portable Document Format (PDF).
  4. On the right hand side you should find an Action column. Use that to select your favorite PDF reader. In order to view PDF files in Firefox, choose Preview in Firefox.

Did this fix your problems? Please report back to us!

In order to change the default reader for PDF files (to not open PDF files with Firefox's internal PDF reader), follow these steps: #Click the menu button [[Image:New Fx Menu]] and click Options (Preferences for Linux and Mac). #In the Options (Preferences for Linux and Mac) tab (window for previous than 38.0 firefox version), select the ''Applications'' panel. #In the ''Search'' field, type ''PDF''. You should find ''Portable Document Format (PDF)''. #On the right hand side you should find an ''Action'' column. Use that to select your favorite PDF reader. In order to view PDF files in Firefox, choose ''Preview in Firefox''. Did this fix your problems? Please report back to us!