X
Tap here to go to the mobile version of the site.

Support Forum

This browser does not support video playback error

Posted

If I try and watch a video on the BBC news site I get the above error. I also get a similar error with videos on Twitter and Ask FM. These used to work. I am running Firefox 43.0.4 on Windows 7 SP3.

If I try and watch a video on the BBC news site I get the above error. I also get a similar error with videos on Twitter and Ask FM. These used to work. I am running Firefox 43.0.4 on Windows 7 SP3.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Amazon MP3 Downloader Plugin 1.0.17
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Shockwave Flash 20.0 r0
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

Question owner

I've just tried toggling the media.directshow.enabled - I've tried it as true and false and it made no difference. All these used to work so it's obviously something that Firefox have brought in in a revised version.

I've just tried toggling the media.directshow.enabled - I've tried it as true and false and it made no difference. All these used to work so it's obviously something that Firefox have brought in in a revised version.

Question owner

I'm now on Firefox 44.0.2 using XP Windows 7 SP3. I cannot view videos on Instagram, twitter, ask fm, or some BBC videos. Is there a simple solution to this, apart from leaving Firefox?

I'm now on Firefox 44.0.2 using XP Windows 7 SP3. I cannot view videos on Instagram, twitter, ask fm, or some BBC videos. Is there a simple solution to this, apart from leaving Firefox?
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156710 answers

Windows XP doesn't have built-in support for playing MP4 files and Firefox relies on built-in OS support to play media files via the HTML5 media player, so you are likely out-of-luck when only the HTML5 media player can be used to play the media file and not a plugin based player like the Shockwave Flash plugin.

For the YouTube website you can use an extension to switch between the Flash player and the HTML5 media player.

Windows XP doesn't have built-in support for playing MP4 files and Firefox relies on built-in OS support to play media files via the HTML5 media player, so you are likely out-of-luck when only the HTML5 media player can be used to play the media file and not a plugin based player like the Shockwave Flash plugin. For the YouTube website you can use an extension to switch between the Flash player and the HTML5 media player. *YouTube Flash Video Player:<br />https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/
jscher2000
  • Top 10 Contributor
8568 solutions 70052 answers

dave61 said

I'm now on Firefox 44.0.2 using XP Windows 7 SP3.

There is Windows XP, an operating system released in 2002, and there is Windows 7, an operating system released in 2009. Big difference in media capability, so it really matters which version you run.

''dave61 [[#answer-848169|said]]'' <blockquote> I'm now on Firefox 44.0.2 using XP Windows 7 SP3. </blockquote> There is Windows XP, an operating system released in 2002, and there is Windows 7, an operating system released in 2009. Big difference in media capability, so it really matters which version you run.

Helpful Reply

Sorry, just to clarify I'm on Windows XP SP3 on Firefox 44.02. I used to be able to play these videos. What has changed? Have Firefox deliberately done this or is it a bug that may be fixed? There must be some simple solution.

Sorry, just to clarify I'm on Windows XP SP3 on Firefox 44.02. I used to be able to play these videos. What has changed? Have Firefox deliberately done this or is it a bug that may be fixed? There must be some simple solution.
FireFoxFan1 0 solutions 284 answers

I'm not having this exact problem, but I have been noticing Youtube videos not downloading in full as quickly using Firefox 44.0.2. Didn't have this problem until updating the browser to the latest version.

I'm not having this exact problem, but I have been noticing Youtube videos not downloading in full as quickly using Firefox 44.0.2. Didn't have this problem until updating the browser to the latest version.
jscher2000
  • Top 10 Contributor
8568 solutions 70052 answers

Hi dave61, in order to maintain open source status, Firefox does not include the patented code to decode MP4/H.264 video and relies on the operating system to provide it. Windows Vista and later, Linux, and the current MacOS X have the necessary bits, but XP does not, and so far I haven't seen anyone recommend a way to add it that Firefox can use.

Websites can check the video formats that Firefox supports and serve an alternate format. To assist with that, you can turn off MP4 support in your preferences. Steps for that at the end.

Still, some sites (BBC for example) either don't check or don't offer an alternate format. Unfortunately, I am not aware of a general solution for that. An add-on might be able to redirected the video to a plugin. I posted a workaround for Twitter here: https://support.mozilla.org/questions/1082494#answer-781059 (Greasemonkey userscript).

It would be convenient if someone were to develop a more general workaround, either as an extension or userscript.


* To force Firefox to report that it can't decode MP4:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste mp4 and pause while the list is filtered

(3) If the media.mediasource.mp4.enabled preference is set to true, double-click it to switch it to false

(4) Double-click the media.mp4.enabled preference to switch it from true to false

(5) In the search box above the list, type or paste directs and pause while the list is filtered

(6) Double-click the media.directshow.enabled to switch it from true to false

(7) In the search box above the list, type or paste wmf and pause while the list is filtered

(8) If the media.wmf.enabled preference is set to true, double-click it to switch it to false (this should be set true on later Windows)

Then reload the problem page bypassing the cache (Ctrl+Shift+r).

Edit: Added the directshow preference in case others are using this list.

Hi dave61, in order to maintain open source status, Firefox does not include the patented code to decode MP4/H.264 video and relies on the operating system to provide it. Windows Vista and later, Linux, and the current MacOS X have the necessary bits, but XP does not, and so far I haven't seen anyone recommend a way to add it that Firefox can use. Websites can check the video formats that Firefox supports and serve an alternate format. To assist with that, you can turn off MP4 support in your preferences. Steps for that at the end. Still, some sites (BBC for example) either don't check or don't offer an alternate format. Unfortunately, I am not aware of a general solution for that. An add-on might be able to redirected the video to a plugin. I posted a workaround for Twitter here: https://support.mozilla.org/questions/1082494#answer-781059 (Greasemonkey userscript). It would be convenient if someone were to develop a more general workaround, either as an extension or userscript. ---- ''* To force Firefox to report that it can't decode MP4:'' (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''mp4''' and pause while the list is filtered (3) If the '''media.mediasource.mp4.enabled''' preference is set to true, double-click it to switch it to false (4) Double-click the '''media.mp4.enabled''' preference to switch it from true to false (5) In the search box above the list, type or paste '''directs''' and pause while the list is filtered (6) Double-click the '''media.directshow.enabled''' to switch it from true to false (7) In the search box above the list, type or paste '''wmf''' and pause while the list is filtered (8) If the '''media.wmf.enabled''' preference is set to true, double-click it to switch it to false (this should be set true on later Windows) Then reload the problem page bypassing the cache (Ctrl+Shift+r). ''Edit: Added the directshow preference in case others are using this list.''

Modified by jscher2000

Question owner

Thanks for the reply. Forgive my ignorance but what will that mp4 change actually do?

Thanks for the reply. Forgive my ignorance but what will that mp4 change actually do?
jscher2000
  • Top 10 Contributor
8568 solutions 70052 answers

dave61 said

Forgive my ignorance but what will that mp4 change actually do?

Your Firefox already can't decode MP4. All this will do is make sure that Firefox doesn't misinform sites that it can decode MP4. The idea is that sites set up with a fallback will serve you other media or switch to using a plugin.

''dave61 [[#answer-848817|said]]'' <blockquote> Forgive my ignorance but what will that mp4 change actually do? </blockquote> Your Firefox already can't decode MP4. All this will do is make sure that Firefox doesn't misinform sites that it can decode MP4. The idea is that sites set up with a fallback will serve you other media or switch to using a plugin.

Question owner

Thanks - but would that mess up sites that do currently work such as Youtube?

Thanks - but would that mess up sites that do currently work such as Youtube?
jscher2000
  • Top 10 Contributor
8568 solutions 70052 answers

Hi dave61, sorry but I don't have Windows XP, so I can't test how YouTube would or would not be affected.

Hi dave61, sorry but I don't have Windows XP, so I can't test how YouTube would or would not be affected.
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156710 answers

Helpful Reply

I assume that YouTube will switch to WebM if you disable MP4. You would have to test that. You can also consider to use the Shockwave Flash plugin for YouTube to have more playing settings.

YouTube Flash Video Player:

I assume that YouTube will switch to WebM if you disable MP4. You would have to test that. You can also consider to use the Shockwave Flash plugin for YouTube to have more playing settings. YouTube Flash Video Player: *https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/