X
Tap here to go to the mobile version of the site.

Support Forum

browser.startup.homepage (about:config) is Locked. How can I unlock it? Ubuntu 14.04 based distro

Posted

Peach-OSI. - a Ubuntu 14.04 based distro. I've uninstalled & reinstalled. The OS apparently has this locked to:

locked. to: http://www.peachosi.com/Doors/GoogleSearchT.html. 

How can I unlock it? Ubuntu. Thanks

Peach-OSI. - a Ubuntu 14.04 based distro. I've uninstalled & reinstalled. The OS apparently has this locked to: locked. to: http://www.peachosi.com/Doors/GoogleSearchT.html. How can I unlock it? Ubuntu. Thanks
Attached screenshots

Chosen solution

Check if there is a mozilla.cfg file present in the Firefox program folder to initialize or lock prefs.

This also involves the presence of a .js (JScript) file in the "defaults\pref" folder that specifies to process this mozilla.cfg file.

If there are .js files present in the "defaults\pref" folder apart from the channel-prefs.js file that sets app.update.channel then open this file in a plain texteditor like Notepad (Mac: TextEdit) and please post its content. Also please post the content of the mozilla.cfg file.

There shouldn't be a mozilla.cfg file present unless you've created it yourself to initialize some prefs.

If you have this mozilla.cfg file then best is to do a clean reinstall and delete the Firefox program folder before reinstalling a fresh copy of Firefox.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
16712 solutions 151149 answers

Chosen Solution

Check if there is a mozilla.cfg file present in the Firefox program folder to initialize or lock prefs.

This also involves the presence of a .js (JScript) file in the "defaults\pref" folder that specifies to process this mozilla.cfg file.

If there are .js files present in the "defaults\pref" folder apart from the channel-prefs.js file that sets app.update.channel then open this file in a plain texteditor like Notepad (Mac: TextEdit) and please post its content. Also please post the content of the mozilla.cfg file.

There shouldn't be a mozilla.cfg file present unless you've created it yourself to initialize some prefs.

If you have this mozilla.cfg file then best is to do a clean reinstall and delete the Firefox program folder before reinstalling a fresh copy of Firefox.

Check if there is a mozilla.cfg file present in the Firefox program folder to initialize or lock prefs. This also involves the presence of a .js (JScript) file in the "defaults\pref" folder that specifies to process this mozilla.cfg file. If there are .js files present in the "defaults\pref" folder apart from the channel-prefs.js file that sets app.update.channel then open this file in a plain texteditor like Notepad (Mac: TextEdit) and please post its content. Also please post the content of the mozilla.cfg file. There shouldn't be a mozilla.cfg file present unless you've created it yourself to initialize some prefs. If you have this mozilla.cfg file then best is to do a clean reinstall and delete the Firefox program folder before reinstalling a fresh copy of Firefox. *http://kb.mozillazine.org/Preferences_not_saved#Other_solutions

Question owner

Thank you. There was a file named: syspref.js in /etc/firefox/, contents listed below: // This file can be used to configure global preferences for Firefox // Example: Homepage //pref("browser.startup.homepage", "http://www.weebls-stuff.com/wab/"); //user_pref("browser.startup.homepage", "http://www.peachosi.com/Doors/GoogleSearchT.html"); //lockPref("browser.startup.homepage", "http://www.peachosi.com/Doors/GoogleSearchT.html");

I changed the last two lines to comments with //, as below: //user_pref("browser.startup.homepage", "http://www.peachosi.com/Doors/GoogleSearchT.html"); //lockPref("browser.startup.homepage", "http://www.peachosi.com/Doors/GoogleSearchT.html"); Now changing my homepage works like it should.

P.S. This also fixed three other problems as well. 1. "Undo Closed Tab" did not work. 2. Add "New Tab" only opened blank- did not show recent sites. 3. Saved passwords did not auto fill. After making the above change these problems disappeared as well. Thank you

Thank you. There was a file named: syspref.js in /etc/firefox/, contents listed below: // This file can be used to configure global preferences for Firefox // Example: Homepage //pref("browser.startup.homepage", "http://www.weebls-stuff.com/wab/"); //user_pref("browser.startup.homepage", "http://www.peachosi.com/Doors/GoogleSearchT.html"); //lockPref("browser.startup.homepage", "http://www.peachosi.com/Doors/GoogleSearchT.html"); I changed the last two lines to comments with //, as below: //user_pref("browser.startup.homepage", "http://www.peachosi.com/Doors/GoogleSearchT.html"); //lockPref("browser.startup.homepage", "http://www.peachosi.com/Doors/GoogleSearchT.html"); Now changing my homepage works like it should. P.S. This also fixed three other problems as well. 1. "Undo Closed Tab" did not work. 2. Add "New Tab" only opened blank- did not show recent sites. 3. Saved passwords did not auto fill. After making the above change these problems disappeared as well. Thank you

Modified by apeman