X
Tap here to go to the mobile version of the site.

Support Forum

Firefox-pages won't load properly and it doesn't recognize Twitter's certificate.

Posted

I'm not great with computers, so please help me if anyone can. I've been searching for a solution for 5 hours now and I'm desperate...

My Firefox has been running a little slow the last couple of days, and sometimes temporarily stops working a couple of seconds when I'm trying to load a page. So I tried to refresh firefox through the Troubleshooting-page. After doing that, I was gonna reinstall my Addblock Plus, but when visiting about:addons, the page looked weird. The text was all in the Time New Roman-font, and there were no pictures. It was like the page hadn't loaded properly. I refreshed Firefox again, but this time I deleted all Cache and Cookies and the saved internet information. But the problem remained. I tried to install Adblock anyway, but it didn't work.

I then uninstalled Firefox from the computer and downloaded the latest version. The problem still remained.

I was now suspecting that maybe I had picked up some nasty virus or something, so I reset the computer two weeks to a date where I was pretty sure it didn't have these problems. But instead of solving my problem, it gave me another one: I couldn't access Twitter. According to Firefox, the certificate wasn't correct and the only option available was "Get me out of here". The technical information said that this was the problem: sec_error_unknown_issuer

At one point, even Google got the same certificate error, and another time I could access Twitter, but it was in the same "Times New Roman"-view with only basic text and no images. And ALL Firefox related pages were like that too.

I have temporarily fixed the problem by asking my antivirus software (ESET NOD 32) to deactivate its HTTP Control, but that doesn't seem like a safe solution to me. I'd just like to know WHAT THE HECK is going on, and how can I properly fix this?

Info: -I'm using Windows 7

I have tried: -Deleting all Cache and Cookies (together with all other internet history) -Refreshing Firefox -Uninstalling and re-installing Firefox -Deleting the Cert8 file -Restarting the computer (multiple times) -Scanning my computer for virus (Using ESET NOD32)

I don't understand what could cause Firefox to not being able to load its own sites properly... Or why Google and Twitter's certificates suddenly stopped working after reinstalling Firefox. Any ideas or help are appreciated. Especially if you keep it simple, since I'm not awesome at computers and English is not my native language .

I'm not great with computers, so please help me if anyone can. I've been searching for a solution for 5 hours now and I'm desperate... My Firefox has been running a little slow the last couple of days, and sometimes temporarily stops working a couple of seconds when I'm trying to load a page. So I tried to refresh firefox through the Troubleshooting-page. After doing that, I was gonna reinstall my Addblock Plus, but when visiting about:addons, the page looked weird. The text was all in the Time New Roman-font, and there were no pictures. It was like the page hadn't loaded properly. I refreshed Firefox again, but this time I deleted all Cache and Cookies and the saved internet information. But the problem remained. I tried to install Adblock anyway, but it didn't work. I then uninstalled Firefox from the computer and downloaded the latest version. The problem still remained. I was now suspecting that maybe I had picked up some nasty virus or something, so I reset the computer two weeks to a date where I was pretty sure it didn't have these problems. But instead of solving my problem, it gave me another one: I couldn't access Twitter. According to Firefox, the certificate wasn't correct and the only option available was "Get me out of here". The technical information said that this was the problem: sec_error_unknown_issuer At one point, even Google got the same certificate error, and another time I could access Twitter, but it was in the same "Times New Roman"-view with only basic text and no images. And ALL Firefox related pages were like that too. I have temporarily fixed the problem by asking my antivirus software (ESET NOD 32) to deactivate its HTTP Control, but that doesn't seem like a safe solution to me. I'd just like to know WHAT THE HECK is going on, and how can I properly fix this? Info: -I'm using Windows 7 I have tried: -Deleting all Cache and Cookies (together with all other internet history) -Refreshing Firefox -Uninstalling and re-installing Firefox -Deleting the Cert8 file -Restarting the computer (multiple times) -Scanning my computer for virus (Using ESET NOD32) I don't understand what could cause Firefox to not being able to load its own sites properly... Or why Google and Twitter's certificates suddenly stopped working after reinstalling Firefox. Any ideas or help are appreciated. Especially if you keep it simple, since I'm not awesome at computers and English is not my native language .

Chosen solution

Try:

ESS 9: Advanced Setup -- Web and Email --- SSL/TLS

Root certificate then uncheck "Add the root certificate to know browsers"
SSL protocol: Do not scan SSL protocol

HTTPS websites fail to load or you receive the error message "Connection is untrusted" when using your web browser with ESET products:

http://support.eset.com/kb3126/
Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; MAPB; .NET4.0E; rv:11.0) like Gecko

More Information

FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

Let's start with a clean re-install

Download Firefox For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.


Look for, and rename any Mozilla or Firefox folders by adding .old to them.

After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.


This will disable add-on signature enforcement; Enter about:config into your Firefox address bar Click the I'll be careful button Find xpinstall.signatures.required in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox

https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47”

Let's start with a clean re-install '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems]''' {web link} Save the file. Then; Using your file browser, open the '''Programs Folder''' on your computer. '''Windows:''' C:\Program Files C:\Program Files (x86) '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. Look for, and rename any Mozilla or Firefox folders by adding '''.old''' to them. After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done. ------------- This will disable add-on signature enforcement; Enter '''about:config''' into your Firefox address bar Click the ''I'll be careful'' button Find '''xpinstall.signatures.required''' in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47”
cor-el
  • Top 10 Contributor
  • Moderator
17523 solutions 158449 answers

Chosen Solution

Try:

ESS 9: Advanced Setup -- Web and Email --- SSL/TLS

Root certificate then uncheck "Add the root certificate to know browsers"
SSL protocol: Do not scan SSL protocol

HTTPS websites fail to load or you receive the error message "Connection is untrusted" when using your web browser with ESET products:

http://support.eset.com/kb3126/
Try: ESS 9: Advanced Setup -- Web and Email --- SSL/TLS Root certificate then uncheck "Add the root certificate to know browsers" SSL protocol: Do not scan SSL protocol HTTPS websites fail to load or you receive the error message "Connection is untrusted" when using your web browser with ESET products: http://support.eset.com/kb3126/

Question owner

cor-el said

Try: ESS 9: Advanced Setup -- Web and Email --- SSL/TLS Root certificate then uncheck "Add the root certificate to know browsers" SSL protocol: Do not scan SSL protocol HTTPS websites fail to load or you receive the error message "Connection is untrusted" when using your web browser with ESET products: http://support.eset.com/kb3126/

...Dude, I think that did the trick!! I had no idea my antivirus software could mess with Firefox this bad... Thank you so much for your help!<3

''cor-el [[#answer-832289|said]]'' <blockquote> Try: ESS 9: Advanced Setup -- Web and Email --- SSL/TLS Root certificate then uncheck "Add the root certificate to know browsers" SSL protocol: Do not scan SSL protocol HTTPS websites fail to load or you receive the error message "Connection is untrusted" when using your web browser with ESET products: http://support.eset.com/kb3126/ </blockquote> ...Dude, I think that did the trick!! I had no idea my antivirus software could mess with Firefox this bad... Thank you so much for your help!<3