Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have to reset my Firefox settings when I reboot; I have to sign in to all my websites (didn't used to).

  • 5 replies
  • 2 have this problem
  • 18 views
  • Last reply by FredMcD

more options

1) I have to tell it I want to use Google. I've deleted ALL the other search engines, hoping that would solve the problem. It didn't. They were reinstalled when I rebooted. 2) I have to reset the Google search settings 3) I have to reset the Add-ons (either reinstall them or reset the activation settings)

There are probably some other things I haven't noticed because I haven't tried to use the affected feature.

Chosen solution

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Read this answer in context 👍 0

All Replies (5)

more options

Chosen Solution

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

more options

A detail like a website remembering you (log you in automatically) is stored in a cookie.

You can use these steps to make a website recognize and remember you:

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

If you use "Clear history when Firefox closes" to clear Cookies then exclude cookies and instead let cookies expire when Firefox is closed to make them session cookies.

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Keep until: "I close Firefox"

Create a cookie 'allow' exception for cookies that you want to keep.

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions
more options

cor-el said

A detail like a website remembering you (log you in automatically) is stored in a cookie. You can use these steps to make a website recognize and remember you:
  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions
If you use "Clear history when Firefox closes" to clear Cookies then exclude cookies and instead let cookies expire when Firefox is closed to make them session cookies.
  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Keep until: "I close Firefox"
Create a cookie 'allow' exception for cookies that you want to keep.
  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

This is more hassle than logging in to every site.

more options

FredMcD said

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Sorry it took so long to get back to you. I wanted to make sure it worked. I only needed to download the first of your suggestions and that cleared up the matter. Several reboots, with visits to my favorite websites have me logged in as I left it. Thanks for the help.

more options

Glad to help. Safe Surfing.