Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I keep getting error messages about unresponsive scripts

  • 7 replies
  • 55 have this problem
  • Last reply by jscher2000

more options

When I'm browsing on Firefox (always different websites) I often get error messages that say "A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue." The script identified is nearly always something different.

Frequently I'll be on one website and it will suddenly slow down or freeze, and I will get a series of these error messages - often a minute or more apart from one another - and I will be unable to do anything else on my computer (on or off firefox) until the issue has resolved itself, because things will move so incredibly slowly. Even just minimizing firefox may take up to five minutes. Sometimes I stop the script, sometimes I let it continue, and I always check "don't ask me again," but it doesn't do anything.

This situation happens perhaps eight times a day and I'm easily losing 15 minutes PER HOUR to it. This can't possibly continue, and I'm not sure what to do.

All Replies (7)

more options

We need to know the full message to know how to act. Write down the whole message and post it. If you get another one, post that too.

more options

Does it mention the name of the script?

If the file starts with the chrome:// protocol then this usually means a problem with built-in files or an installed extension.

Firefox uses the "chrome://" protocol to access its own internal files and access files from extensions (no relation with Google Chrome).

more options

Thanks. The scripts are all identified by the website I'm on, and will say something like "Script:"

Here's an example I just got:

"A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue.


The other messages I get are similar but identify different scripts, of course. I could look for more examples but I'm not having as much trouble this morning.

I will mention that the problem is much worse with certain websites than with others, and the general issue tends to get worse as the day goes on.

more options

I am having exactly the same problem, since it upgraded to the latest version of FF, having checked its exactly the same problem as the gentleman who started the thread. I would love to know how to get around the problem, as I am having to use a different browser to post.

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

This problem has become so persistent since W10 that FF will lose users until there is no FF. A permanent, no user hassle software fix is needed. So much verbiage; zero Mozilla action.

more options

Hi cleartheroomband, I replied to your new question here:

For anyone reading here, did you check the suggestions in this help article:

Warning Unresponsive script - What it means and how to fix it

On Windows 10 (and all the way back to Vista), you also may want to try disabling the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.