Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Embedded Tweets don't show up unless themes are disabled entirely in safe mode

  • 5 replies
  • 1 has this problem
  • 17 views
  • Last reply by risc80x86

more options

I have a very similar problem to this one (https://support.mozilla.org/en-US/questions/1081873) but I'm suspecting, in my case, it's Firefox's theme add-on (not just any particular theme, the system that enables them) that is causing the issue. Running in safe mode where all extensions are disabled, the browser shows embedded Tweets with no problem. Realizing this, I disabled all add-ons in my browser and restarted again. However, even when all of them disabled, the problem still persisted. The only difference is that in normal mode, Firefox enables the theme feature. How do I work around this issue?

All Replies (5)

more options

risc80x86 said

... but I'm suspecting, in my case, it's Firefox's theme add-on (not just any particular theme, the system that enables them) that is causing the issue.

Have you disabled that "theme add-on" to verify that is the actual cause?

If it is the cause, you'll have to keep it disabled or live without the "embedded Tweets". Or contact the developer of that add-on to make him aware of your problem and hope that he is willing to fix the issue.

more options

It's the theme system itself that seems to be causing the problem. I haven't really used any theme other than the default, which is disabled in safe mode, but can't be disabled in normal mode.

more options

There is no "theme system". Firefox allows the selection of an alternate "Appearance" - which are now known as "lightweight themes", formerly known as "Personas".

If you were running in the SafeMode and it worked properly with the default "Appearance" showing (as it does in the Firefox SafeMode) and that problem was fixed, start disabling extensions one at a time to locate the culprit.

IMO, it sounds like a "Personas Rotator" extension type issue.

more options

Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. When you are in private browsing mode then Firefox can show a shield icon at the left end of the location/address bar that some content is affected.

You can disable this feature in "Options/Preferences > Privacy" or via the about:privatebrowsing page that get when you open a New Private Window.

  • Options/Preferences > Privacy: "Use Tracking Protection in Private Windows"
more options

Like I said, I've already tried running the browser with all extensions disabled, and the problem still persisted. In safe mode, all themes are disabled including the default one, but in normal mode there's no way for me to disable it.