Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have been using Firefox for 2 years on my Mac, then about 2 weeks ago, it became VERY slow and didn't display properly. Please help.

  • 3 replies
  • 3 have this problem
  • 11 views
  • Last reply by FredMcD

more options

I have been using Firefox on my Mac ever since I purchased it, which was 2 years ago. Then, all of a sudden, about 2 weeks ago, it became VERY slow and didn't display properly (i.e. can't see the minimize and exit buttons). I don't know what happened, because I just opened it up one day and it stopped working on me. I uninstalled it and reinstalled it many times, hoping it would help, but the same problem still exists. Please help me fix this. I hate using Safari.

All Replies (3)

more options

What is your computer system and Firefox? There are several possibilities to your problem. Did you install new programs or upgrade something?


Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

I am using OX El Capitan, version 10.11.2. I am using Firefox 43.0.3. I have not installed any new programs. I upgraded to OX El Capitan about a month ago, but my problem started occurring a couple weeks after upgrading...so I don't think OX El Capitan is the problem.

I am hesitant to adjust any settings with my firewall because I don't want to mess up anything else.

I have attached a screenshot of what Firefox looks like when I open it up. You'll notice in the upper left corner, I cannot access the red exit button, yellow minimize button, and the green expand button.

In addition, as I mentioned earlier, it is also VERY, PAINFULLY slow.

I appreciate the help!

more options

Open the firewall to the page that lists all the programs. Remove/delete all Mozilla and Firefox entries. Nothing else.

Modified by FredMcD