Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since the last 2 Firefox updates my new computer seems to hang or crash a lot

  • 27 replies
  • 4 have this problem
  • Last reply by Debrajean

more options

Hi, I was just wondering if this was only happening to me or not. I always update when told by my plug-ins, or virus protection and when Firefox says there's a new update. I've now got the latest 43.0.2 and since this and one or 2 updates before my computer hangs or crashes, whatever you want to call it and I will sometimes get the icon telling me Firefox has crashed, report, etc. I wanted to know what is causing it. It's a brand new computer with all the updates, including Microsoft, etc. I never used to have this problem before with Firefox. I tried to read some others that posted similar things but I didn't understand anything that was told to them to do. I'm not techy. I just know enough to get around. I'm going to probably use Internet Explorer more until Firefox fixes or updates again. It's pretty frustrating when you're in the middle of something and this happens. Like I said I wondered if it was because of the last few updates Firefox did. I was always told you need to keep it updated but if it causes problems like this perhaps I shouldn't. Thanks from the clueless, Debbie

All Replies (20)

more options

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste those IDs into the "Post a Reply" box.

Note: If a recent Report ID does not start with bp- click on it to submit the report.

(Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.)


Thank you for your help!

More information and further troubleshooting steps can be found in the Troubleshoot Firefox crashes (closing or quitting unexpectedly) article.

more options

You can check in the the Windows Control Panel if you can find "NVIDIA Network Access Manager" or "NVIDIA ForceWare Network Access Manager" and uninstall this software.

more options

Thanks for replying cor-el but what would I be uninstalling? I don't know what it is you just told me. I don't want to start uninstalling things I don't know about. I just wanted to know if this was because of the latest Firefox updates.

more options

Hi ed-meister, I copied the latest crash reports. Don't know how this helps me but here it is. Thanks! Debbie ++++ Report ID Date Submitted bp-b40f095e-af4f-49b0-a43b-4a2a52151226 12/26/2015 1:01 PM bp-72bdaed0-f108-4dbf-a503-826452151225 12/25/2015 10:43 AM bp-06456b1a-9c10-472c-94cb-578dc2151219 12/19/2015 2:06 PM bp-bb149836-0f70-4dc1-baa0-6b77d2151219 12/19/2015 2:02 PM deb84fdf-f0b7-45b3-a34e-b0273ca376b9 12/19/2015 1:24 PM

more options

Hi Debbie.

The crash reports show that you do not have this program, so you can ignore that.

The crash reports are some kind of shutdown hang where closing Firefox takes too long.

  • Firefox 43.0.2 Crash Report [@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_Wait | nsThread::ProcessNextEvent | NS_ProcessNextEvent | mozilla::SharedThreadPool::SpinUntilEmpty ]

Can you reproduce these crashes like they happen after you have visited specific web pages?

You can try to use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

  • "3-bar" menu button > Exit (Power button)
  • Windows: File > Exit
  • Mac: Firefox > Quit Firefox
  • Linux: File > Quit

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for issues caused by plugins and set plugins to "Ask to Activate" on the "Firefox menu button/Tools > Add-ons > Plugins" page.

  • plugins are not affected by Firefox Safe Mode
more options

msmpeg2vdec.dll = Microsoft DTV-DVD Video Decoder

Perform a System File Check to fix corrupted system files Win 7, 8, 10, Vista:

See if there are updates for your graphics drivers

more options

Hi Cor-el, Uh, I pretty much don't understand anything you told me to do. Sorry, but when you said if I could re-produce it after I've visited specific pages, that would be a bit hard because when it hangs it happens off and on and sometimes when I'm just on my homepage and I haven't gone anywhere. Also get that stupid warning about the script being unresponsive.

Also to FredMcD, Thanks much for responding but my new computer was having a few issues having nothing to do with Firefox and I already had a computer tech that does our library computers where I work do diagnostic and other checks on it and he said it was clean. No hardware, software issues or malware. All drivers are up to date and no corrupted files. So that rules all your suggestions out. And like I told cor-el I'm not techy and do not know how to do a file check anyway. But since this computer was re-set back to factory via HP support suggestion and after the tech checked it out for me there really shouldn't be any issues that way.

Apparently this is a Firefox issue as I have been using IE with no problem. All I really wanted to know if this was because of the latest Firefox updates which have been known to cause these problems.

Thank you both for your suggestions. Later I'll print them out and hold onto them just in case.

more options

Every one of those crashes showed msmpeg2vdec.dll as the file that precipitated those "shutdownhang" crashes. I believe that is a Microsoft MPEG-2 Video Decoder file.

For reference purposes only:

There is a "related" Bug report filed, but it was filed on Windows 7, not the Windows 8.1 that you posted here with, and no progress has been reported towards a solution.

Sorry, I have no definitive solution.

more options

Thanks the-edmeister. Like I said it happens off and on and so far not in IE. I saw something on the internet over a week ago and wished I had read it but just saw the subject header. It was something about Firefox and Microsoft doing something together that was causing havoc with Firefox users. Perhaps this is it. Well I hope they get their act together. Thanks for trying though. Debbie

more options

Modified by the-edmeister

more options

Thanks FredMcD, That must have been the article I only saw the heading on and never read it. I went to see what it referred too and to tell you the truth I don't even know what they're talking about. Whatever it is I don't know if that's what's causing the hanging issue or not. But that was the thing I saw about Microsoft and Firefox working together. What it didn't state was the part I saw that it was creating havoc with Firefox users. Now that part is what I'd like to read about. But thanks so much for at least finding this for me.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
key, and then starting Firefox. Is the problem still there?

While still in Safe Mode,

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

more options

Hi FedMcD, I never used safe mode before and not sure if I want to try that or not. Might not get it out of safe mode. Didn't know you could work in safe mode. I think I'll just let this be for now. What happened again last night was Firefox worked fine and I closed out normally. Went to do some stuff on word pad and what do I see but the crash report box and this time nothing happened at all. I think I'll stick to IE for a bit and use Firefox off and on. Though I just updated it again. Seems like Firefox has been updating quite a bit lately. I want to thank you again for trying to help me. It's just I'm all by myself and if I do something wrong on this computer I have no idea how to correct it. I'll also print out what you told me just in case I decide to do it. Debbie

more options

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
key, and then starting Firefox. Is the problem still there? While still in Safe Mode, Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.
more options

Hi again FredMcD, I had turned off hardware acceleration before in my older computer I used to have and even one I use at work. If I don't use safe mode and I now have windows 8.1 where would I go to manually turn hardware acceleration off. I'm still getting used to where things are on my new computer. Thanks! Debbie

more options

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

After, restart the browser. Are there any problems?

more options

Okay, will do. Thanks again, FredMcD! Debbie

more options

I also have similar problems, here are my recent crashes:

Report ID Date Submitted bp-a2680a34-3fca-41e7-8e57-f335a2160119 1/19/2016 1:28 AM bp-a3291f05-3c59-4f9e-aa6f-f83872160118 1/18/2016 6:52 PM bp-cda1c1cc-4471-49fe-ab8a-136712160117 1/17/2016 10:41 PM bp-10d99d22-dc50-4d12-9f9b-3927c2160117 1/17/2016 7:00 PM bp-ef60565a-b487-447b-bb79-ab3d62160116 1/16/2016 4:13 PM

more options

Product Firefox Version 43.0.4 Build ID 20160105164030 Release Channel release OS Windows NT OS Version 10.0.10586

Signature wcsnlen

TmFFExt2.dll = 趨勢科技 OfficeScan 用戶端 = Trend Micro OfficeScan Client

TmBpFfCore.dll = Browser Exploit Prevention - Trend Micro Browser Plug-In

Nvwgf2um.dll = NVIDIA Compatible D3D10 Driver = NVIDIA Corporation

This is for Sumo's Related Bugs 1196899 NEW --- crash in wcscpy_s with Trend Micro Browser Plug-In

Disable / update Trend Micro

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

  • disable hardware acceleration in the Flash plugin See also:

more options

Hi Black_rose_hime! Thanks for the response. I almost hate to say anything but Firefox has updated again since all that happened and I haven't seen any crash boxes popping or had hanging issues. Keeping fingers crossed it's fixed itself with that latest update. Then again I'll have to worry on the next updates if that's what's happening.

  1. 1
  2. 2