Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

All my extensions were randomly disabled even though they all worked fine two hours ago.

  • 9 replies
  • 3 have this problem
  • 302 views
  • Last reply by AggiePilot

more options

And I was only to re-enable three. This happened with NO changes to my browser or extensions; nothing was updated, and I didn't tweak any settings. One of the ones I can't enable is by the same creator as the ones I can (TrendMicro; others I can't re-enable include RealPlayer and Yahoo toolbar). I'm a bit concerned as it is a security measure I can't re-enable. While the one I'm most concerned is a Tumblr add-on/extension (XKit, The Extension Framework For Tumblr), because I don't want to install 500 new extensions to deal with one problem at a time, when I had a perfectly good extension that deals with all of them and already has my settings saved (including some important things archived). From what I've seen, the creator has to get the extension "signed" or whatever, which presents a problem as the last available xkit update I saw was from last year (2014). Is there ANYTHING that can be done to fix this???

Chosen solution

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select Update. Check the settings.


Install an older version of Firefox {web link}

Read this answer in context 👍 3

All Replies (9)

more options

Did you just update to Firefox 43?

more options

My browser says that's the version I have, but the last time I updated it, that wasn't the version I got if I remember correctly. And as I said, I haven't knowingly updated anything in a while, probably a couple months now.

more options

Similar problem here and yes I got the problem after an auto update to 43. Specifically the following extensions no longer work as they "could not be verified" Xmarks (disabled) this is one of the most used add ons there is. Kaspersky Protection (disabled) now I have a real problem here E-Web Print (disabled) allows printing to my epson xp-850 via my phone

I did not allow Firefox to update on my other two computers and all three of these still work on those machines. I would like to know how to go back to 42, Thanks

more options

I agree with AggiePilot. Going back to 42 would be nice.

more options

Chosen Solution

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select Update. Check the settings.


Install an older version of Firefox {web link}

more options

Thank you! I downgraded and everything seems to be in working order!

more options

itsame, How did you downgrade? I tried to find the file to do that but could not figure it out. I am running Win 7 64 bit. Would appreciate link or exact file to download and install. Thanks

more options

itsame

Glad to help. Safe Surfing.

AggiePilot

Go to this page, and find your sysem, https://ftp.mozilla.org/pub/firefox/releases/42.0/

more options

Thanks, got it and also been reading forum over on "Kaspesky" here is link for anyone who might be interested. This is the first of 3 pages go to last page and read. "Kaspesky" is behind http://forum.kaspersky.com/index.php?showtopic=329476&st=0