Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Please make firefox browser support for older android devices like android 2.3. because i love firefox please. please. please.

  • 3 replies
  • 1 has this problem
  • 11 views
  • Last reply by James

more options

Please make firefox browser support for older android devices like android 2.3. because i love firefox please. please. please. its not running on my device which is LG p690 android 2.3.4.

All Replies (3)

more options

hi, firefox for android also supports 2.3 - however it needs certain minimal hardware requirements (like a certain amount of RAM and type of cpu architecture). more details about that are available at: Will Firefox work on my mobile device?

more options

Yes as Phillipp mentioned Firefox will run on on Android 2.3. However your device runs a CPU that is unsupported.

more options

Yes the old LG p690 phone from 2011 has a ARMv6 type of cpu and not say ARMv7 or better.

Android 2.3 has been a minimum since mobile Firefox 31.0 Release and support for the old ARMv6 was dropped then.

Modified by James