Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't load pages with high RAM usage

  • 4 replies
  • 1 has this problem
  • 6 views
  • Last reply by cor-el

more options

Hi all!

I've been experiencing this problem for quite some time (≈1.5 years) and have finally decided to speak up, since it seems like either the team hasn't solved this bug yet or no one else experiences this.

Every so often, while browsing, pages will stop loading and the error, "Server not found," appears. The trigger seems to be a high-ish amount of RAM use, about 1GB. This happens every couple days if I don't open too many tabs with high RAM use (e.g. YouTube, NYT, etc.) or every couple hours if I'm browsing heavily! Refreshing and/or clearing cache have no effect. Only restarting Firefox (starting RAM use is ≈350 MB) allows me to load pages again—annoying if I fill out a long form, click "Next", and have to start all over again because the next screen doesn't load. This issue frustrates enough that I've finally decided to give Chrome another go (gasp!) and surprisingly, no niggles yet.

I'm on the latest version of Firefox on Windows 7 Pro x64. Hardware: Intel Core i5-2500K, 12GB RAM, 128GB SSD, AMD ATI 5850 Series. Internet connection is perfect at 20Mbps and other browsers run well even when Firefox doesn't. I've tried un- and reinstalling, starting with a new profile (syncing only bookmarks), and even deleting my %appdata% folder to try anew. As you can see, it's quite frustrating and time-consuming!

I'd love to keep Firefox as my primary browser—its customizability and design are the main draws. Any help much appreciated!

Thanks, vinging

Attached screenshots

All Replies (4)

more options

See if there is any change by using this,.

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

more options

FredMcD said

See if there is any change by using this,. Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

Thanks for the suggestion! I may have confused you, though.

It's not that I don't want to load sites that use high amounts of RAM. It's that when I've got tabs already open, total RAM used by Firefox approaches 1GB, the next tab/page I open pushes use to >1GB, and the next tab after that I try to load doesn't load.

more options
more options

You can try the free memory buttons on the about:memory page.