Search Support

I am using Firefox - and - sometimes all of a sudden, it hangs and after a few minutes, it says "unresponsive and script running .. stop this script, etc.

  • 15 replies
  • 2 have this problem
  • 57 views
  • Last reply by cor-el

more options

I am using the latest Version of Firefox. Sometimes while using the web - it all of a sudden hangs and I cannot use anything. After a few minutes, sometimes half a minute -- a small window pops up and says - Warning, Unresponsive script. A script may be running etc. I click on stop and then everything is fine.

The weird thing is that it happens Infrequently and Not specifically on a certain webpage. Sometimes it happens on google and sometimes it happens on wikipedia, etc -- and then it does that on different pages and Not on the ones it did that before.

Tried to uninstall and re-install, etc

Would appreciate anyone's help on this.

All Replies (15)

more options

Weirdly, your Firefox identified itself as Firefox 26 running on Windows XP. Is that accurate, because that isn't close to the latest version of Firefox.

Probably you've already gone through this article but, if not: Warning Unresponsive script - What it means and how to fix it.

Two other things:

(1) When users post screen shots of unresponsive script errors, they very often point to the Skype Click-to-Call extension. If you ever installed Skype, try disabling that extension on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find Skype on the right side and disable it. If Firefox indicates that you need to restart for the change to take effect, you can use the link provided for that purpose.

(2) A common cause of unresponsive script errors on Windows Vista+ (does not apply to Windows XP) is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

more options

Hi - I had the latest version. Then, I tried this one - V26. It is doing the same thing. I uninstalled the flash -- and it is doing the same thing. I don't have skype or anything of skype nature.

This problem is - Infrequent -- sometimes it happens and sometimes days go by and nothing happens.

I read the article -- Another article said - to get "yes script and add specific websites" would that be a solution?

Hope you can help

more options

When next you get the error, copy the whole message here.

more options

The YesScript extension allows you to block scripts from specific sites. But... at this point we don't know what site(s) you need to block, so that's not going to be useful for prevention.

more options

I was on Yahoo Mail now -- And the same thing happened. It happened on Yahoo mail long time ago -- and - now again.

I am copying the script - as requested by the previous person.

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: https://s.yimg.com/zz/combo?/nq/s/php/mail/js/darla-base_5_3494.js&/rq/darla/2-8-9/js/g-r-min.js&nq/s/templates/js/minty/module/ads/spritz-leave-behind_5_2169.js&nq/s/mail/ui/darla/neodarla_5_3339.js:8

Hope this info helps. When I click on the close -- everything returns to normal -- and I can use the Yahoo mail and it is Not hanging -- But while I was using mail -- everything froze / hangs -- until that message comes

more options

s.yimg.com is a Yahoo server, so it's not really practical to block everything from that server.

Due to the way the script is "minified", line 8 has over 6000 characters, so it's more than I could do to sort out what exactly is causing the slowness. There could be something in the script which is waiting on something else, or a programming error which causes something to repeat endlessly, or ...

more options

It is possible that Anti-Virus software is causing problems. Try to disable Anti-Virus software temporarily to see if that makes a difference.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

Modified by cor-el

more options

Sorry for late reply - I was not on the Internet.

My airtime for data ran out.

I will try that - as said above.

Another thing -- Recently -- some program got onto my pc -- and it was annoying and took some time to uninstall. I uninstalled everything associated with that. BUT - When I open firefox -- It defaults to - "istartsurf" I click - reset to default and everything -- And when i reopen firefox, it still opens "istartsurf"

Could that be also a linked problem to the scripts, etc

more options

Added Info -- I was on Yahoo Mail again -- And - the same thing happened - THREE times BUT with Different script readings.

1. A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: https://s.yimg.com/zz/combo?/nq/s/php/mail/js/darla-base_2_65.js&/rq/darla/2-8-9/js/g-r-min.js&nq/s/templates/js/minty/module/ads/spritz-leave-behind_5_2169.js&nq/s/mail/ui/darla/neodarla_2_64.js:2

2. A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: https://s.yimg.com/rq/darla/2-8-9/js/sfext-min.js:1

3. A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: https://s.yimg.com/rq/darla/2-8-9/js/sfext-min.js:1

Do they ALL mean the same thing? Kindly Advise

more options

newusermozila said

When I open firefox -- It defaults to - "istartsurf"

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

more options

Does iStartSurf take over the following as well:

  • New window: Ctrl+n
  • Home button on the toolbar

If it only appears at startup and not in new windows or when you click the Home button, you might also check for a modified desktop/quick launch shortcut.

To check for that, right-click the icon, and choose Properties. Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

The Target line should not have anything after this part:

(Windows XP) "C:\Program Files\Mozilla Firefox\firefox.exe"

If any URLs are listed after that, clear them out and save your change.

To test, you can double-click the icon to launch a new window. If you only get your home page, it worked.

more options

Hello -- Sorry, was Not on Internet to reply.

When I open Firefox - it opens istartsurf If I click on the - Home button - it goes to Istartsurf On tools , options -- I click restore to default and then ok and then if I click home button, it brings the home page and not istartsurf. But - If I close firefox and restart it -- it Again brings istartsurf.

I checked the target line thing, as above -- and it is as you wrote it -- nothing extra

more options

You can check if you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can use this button to go to the current Firefox profile folder:

If you do not keep changes after a restart or otherwise have problems with preferences, see:

more options

Hello Co-rel --

I checked the profile folder - and opened it with notepad. And it had the -- istartsurf stuff inside.

So - As u said -- I deleted it.

Thanks so much for the help.

If I may ask - what is your name -- R u a girl or a guy

more options

You're welcome

I'm curious if you missed this in my reply further up where I also included a suggestion to check for issues with the preferences?