Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox update messed up my toolbar.

  • 12 replies
  • 1 has this problem
  • 201 views
  • Last reply by James

more options

I updated my firefox through apt-get update on Ubuntu and my toolbar is now completely messed up as you see from the screenshot.

Chosen solution

I agree that it was likely the complete Theme you were using on Firefox that needs to be updated.

Read this answer in context 👍 0

All Replies (12)

more options

The screenshot didn't get uploaded. Here it is.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

No, there is no problem in safe mode. In safe mode the toolbar is as it should be. But in safe the theme is gone. I want that 'Simple White' theme, like before.

more options

So you are using a third-party complete Theme from addons.mozilla.org ?

It may need updating by author.

more options

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

more options

Even with all the add-ons disabled (except for Ubuntu Modifications add-on, which cannot be disabled), the toolbar problem is still there. So, I guess James is probably right, the author of the third party should update the theme.

more options

That can be disabled. Look to the far right.


Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

After, restart Firefox. Are there any problems?

more options

ayatana said

Even with all the add-ons disabled (except for Ubuntu Modifications add-on, which cannot be disabled), the toolbar problem is still there. So, I guess James is probably right, the author of the third party should update the theme.

The Theme is in the Appearance section and not Extensions.

more options

I found the culprit. It's called 'Hello'. I removed that button and everything is back to the way it should. By the way, does anyone know what 'Hello' is? I have never seen it before.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

Send instant messages on Firefox Hello https://support.mozilla.org/en-US/kb/send-instant-messages-firefox-hello

more options

This is likely a problem with the theme that you use and that doesn't support all toolbar button that are included in the current releases. You would have to contact its developer for support or try to find another theme that you like.

more options

Chosen Solution

I agree that it was likely the complete Theme you were using on Firefox that needs to be updated.