Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since I upgraded to FF 41X, my "bookmark current page" in firefox does not work....how can I fix that

more options

No details...it just stopped working

Chosen solution

Did you skip over Firefox 40? This could be a problem with your IE Tab add-on -- your Question Details > More System Details shows an IE Tab plugin, so probably you have an IE Tab extension. Try disabling those.

Past threads on this problem from Firefox 40 days:

If you are not familiar with the Add-ons page, you can open it using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins, and set the IE Tab plugin to "Never Activate".

In the left column, click Extensions. Then disable (or remove) any IE Tab extensions, and anything else nonessential or unrecognized.

Often a link will appear above at least one disabled/removed extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that help?

Read this answer in context 👍 0

All Replies (7)

more options

Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox.

Open the Add-ons Manager. Locate the add-on and press the Options button. Select All of the tests. Then press Execute on the bottom.

more options

I installed "Places Maintenance" and went to options and I don't see anything listed as "Places Maintenance" nor do I see a drop down menu like the one you show on you add-on page.

So I still can't fix the problem

more options

OK, I found the “Places Maintenance” menu and I executed “Maintenance” and it stated “Executing maintenance tasks...” and then did nothing for 45 mins and finally closed the window and it still did not fix the problem. I even restarted FF and the problem is still not fixed.

I repeated the operation (this time only for 30 mins) and restarted FF and the problem still persists.

more options

Problems with bookmarks and history not working properly can be caused by a corrupted places.sqlite database file.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the places.sqlitefile. Then rename or delete it. Restart Firefox.

more options

Chosen Solution

Did you skip over Firefox 40? This could be a problem with your IE Tab add-on -- your Question Details > More System Details shows an IE Tab plugin, so probably you have an IE Tab extension. Try disabling those.

Past threads on this problem from Firefox 40 days:

If you are not familiar with the Add-ons page, you can open it using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins, and set the IE Tab plugin to "Never Activate".

In the left column, click Extensions. Then disable (or remove) any IE Tab extensions, and anything else nonessential or unrecognized.

Often a link will appear above at least one disabled/removed extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that help?

more options

FredMcD said

Problems with bookmarks and history not working properly can be caused by a corrupted places.sqlite database file. Type about:support in the address bar and press enter. Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox. Locate the places.sqlitefile. Then rename or delete it. Restart Firefox.

I tried this and all it did was take away my "icons" on my bookmark menu.

Thanks anyway, but it didn't work

more options

jscher2000 said

Did you skip over Firefox 40? This could be a problem with your IE Tab add-on -- your Question Details > More System Details shows an IE Tab plugin, so probably you have an IE Tab extension. Try disabling those. Past threads on this problem from Firefox 40 days: If you are not familiar with the Add-ons page, you can open it using either:
  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Plugins, and set the IE Tab plugin to "Never Activate". In the left column, click Extensions. Then disable (or remove) any IE Tab extensions, and anything else nonessential or unrecognized. Often a link will appear above at least one disabled/removed extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Does that help?

Hallelujah!!!!!!!!!!!!!!

YES, YES, this worked...I now have my "Bookmark Current Page" feature back again.

Thank you VERY much!!!!!!!!!!!