X
Tap here to go to the mobile version of the site.

Support Forum

How do I turn off Private Browsing?

Posted

I found an answer in another thread:

Tools > Preferences > Privacy > History > Firefox will > deselect the "Never remember history" and you are out of private browsing..........

But I do not have Preferences under Tools. I have Tools > Downloads, Add-Ons, Apps, Set up your sync... , Web Developer, Page Info, and options.

I don't use Firefox that often so please bare/bear ?  :)) with me.

Windows 7 Home Premium.  Just updated to Firefox 42.0

Thanks.

I found an answer in another thread: Tools > Preferences > Privacy > History > Firefox will > deselect the "Never remember history" and you are out of private browsing.......... But I do not have Preferences under Tools. I have Tools > Downloads, Add-Ons, Apps, Set up your sync... , Web Developer, Page Info, and options. I don't use Firefox that often so please bare/bear ? :)) with me. Windows 7 Home Premium. Just updated to Firefox 42.0 Thanks.

Additional System Details

Installed Plug-ins

  • Coupons, Inc. Coupon Printer 5.0.2.3
  • Google Update
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.65.2 for Mozilla browsers
  • MSN® Toolbar
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Nitro PDF Plug-In For Firefox and Netscape
  • Nokia Suite Enabler Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.1.171
  • 5.1.40728.0
  • WildTangent Games App V2 Presence Detector
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

More Information

FredMcD
  • Top 10 Contributor
4254 solutions 59582 answers

Type about:preferences#privacy <enter> in the address bar.

The button next to History, select Use Custom Settings.

Type '''about:preferences#privacy''' <enter> in the address bar. The button next to '''History,''' select '''Use Custom Settings'''.

Question owner

Hi FredMcD,

Thank you for your reply. I did this, clicked Custom Settings, and clicked Never Remember History. I closed Firefox and reopened it but that Private Browsing Shield is still there. If I re-enter what you gave me in the address bar, it is reverted back to Custom Settings. How do I make the change stick?

Thanks.

Hi FredMcD, Thank you for your reply. I did this, clicked Custom Settings, and clicked Never Remember History. I closed Firefox and reopened it but that Private Browsing Shield is still there. If I re-enter what you gave me in the address bar, it is reverted back to Custom Settings. How do I make the change stick? Thanks.
FredMcD
  • Top 10 Contributor
4254 solutions 59582 answers

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

'''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save''' Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

Helpful Reply

Never remember history means that you switch to Private Browsing mode and stay in that mode until you you disable PB mode. If you want to leave PB mode then you need to remove the tick.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

"Use custom settings for history" allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings. Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made. If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History". "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a checkmark.

Never remember history means that you switch to Private Browsing mode and stay in that mode until you you disable PB mode. If you want to leave PB mode then you need to remove the tick. *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use Private Browsing mode" ---- "Use custom settings for history" allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings. Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made. If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History". "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a checkmark.

Question owner

Hi Cor-el,

Thank you. That makes it a little more clear for me. Firefox is really confusing for me.

FredMcD, I used your how-to-fix-preferences-won't-save link. I don't have any other software that would prevent this from saving. However, I used the Refresh Firefox which cleared out the Private Browsing (shield icon).

I guess update 42 changed how it handles some of the "never remember history" because I had this ticked before and there were no issues. Guess I'll just have everyone track me when I have to use Firefox.

Thanks to all for your help. I appreciate it.

Hi Cor-el, Thank you. That makes it a little more clear for me. Firefox is really confusing for me. FredMcD, I used your how-to-fix-preferences-won't-save link. I don't have any other software that would prevent this from saving. However, I used the Refresh Firefox which cleared out the Private Browsing (shield icon). I guess update 42 changed how it handles some of the "never remember history" because I had this ticked before and there were no issues. Guess I'll just have everyone track me when I have to use Firefox. Thanks to all for your help. I appreciate it.
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

Private browsing mode only disables storing personal data in the Firefox profile folder. All session data is kept in memory while you are in PB mode and is purged when you end the PB mode session, either by closing all PB mode widows/tabs or by closing Firefox. If doesn't make a difference to how internet servers see you.

Private browsing mode only disables storing personal data in the Firefox profile folder. All session data is kept in memory while you are in PB mode and is purged when you end the PB mode session, either by closing all PB mode widows/tabs or by closing Firefox. If doesn't make a difference to how internet servers see you. *https://support.mozilla.org/kb/Private+Browsing